Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't manually add Cookie exception for various websites, must globally disable cookie blocking

  • 12 odpovedí
  • 1 má tento problém
  • 387 zobrazení
  • Posledná odpoveď od cor-el

more options

If you look at the attached image you can easily see what my problem is. Because I can't make exceptions for various websites those websites will remain broken unless I change the Global settings for cookies... which makes the Exceptions - Content Blocking UI redundant.

Oh I guess I should throw in a question. Is there a way to manually add websites to the exception list? Through some convoluted user unfriendly configuration file or some such?

Priložené obrázky

Upravil(a) Franpa dňa

Vybrané riešenie

Hello Franpa,

Would you try this please :

When you're on a site where you want to permanently allow cookies, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

(according to your screenshot, you haven't given the site any permissions; as soon as you, you will see a little dot appear on the edge if the circle)

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (12)

more options

Delete this comment.

Upravil(a) Franpa dňa

more options

Vybrané riešenie

Hello Franpa,

Would you try this please :

When you're on a site where you want to permanently allow cookies, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

(according to your screenshot, you haven't given the site any permissions; as soon as you, you will see a little dot appear on the edge if the circle)

more options

Cool, but why the completely different process for some websites? Some you click the Green Padlock and there's an option there to make an exception while on other websites that option doesn't exist.

Upravil(a) Franpa dňa

more options

For example... the website in the below attached image has this Exception option. (compare it to the image in my first post, the option is missing for those 2 websites)

Also your process doesn't add the websites to the exception list, so I'll have an invisible list of exceptions that can't be easily reviewed...

Upravil(a) Franpa dňa

more options

removed

Upravil(a) McCoy dňa

more options

It isn't adding the websites to that UI. The only website added to that UI is the one where I clicked the "Turn off blocking for this site" button on the Site Information screen (via clicking the green padlock).

That UI is also quite featureless too, you can't edit nor view the permissions... you can only remove the exception.

Upravil(a) Franpa dňa

more options

You are right : If you want to add a site to "Manage Exceptions" in Options => Privacy & Security => Content Blocking, you'll have to turn off content blocking for that site.

If you want to only allow or block cookies for that site, you will then have to do that as described in my first post.

Maybe these articles will shed a better light on it :

https://support.mozilla.org/en-US/kb/enable-and-disable-cookies-website-preferences

https://support.mozilla.org/en-US/kb/content-blocking

(I removed my second post, as it didn't make sense - my sincere apologies)

more options

Note that your screenshot show the Content Blocking window. If you need to manage cookie exceptions then you need to look further down under "Cookies and Site Data -> Manage Permissions" where you can add exceptions for various websites (domains) with the proper protocol (https:// or http://).

more options

Yeah that's another method. So 3 methods with varying pros and cons:

1) "Page Info > Permissions Tab" to allow cookies for a website. Seemingly no way to get an overview of what websites you've done this for.

2) Click the green padlock/encircled i symbol in the address bar and click the "Turn off blocking for this site" button which appears in the Cookies section. Various websites won't trigger this button to display (why must a website trigger the buttons visibility? it should always be visible!). This will add an exception to "Content Blocking > Manage Exceptions" UI.

3) Cookies & Site Data > Manage Permissions works nice enough but, what's the purpose of "Content Blocking" at the top of the options when this "Cookies & Site Data > Manage Permissions" UI exists?

You need to perform the 2nd method to add websites to the "Content Blocking > Manage Exceptions" UI, the 2nd method isn't always available and the UI for reviewing exceptions made via the 2nd method is abysmal. The 1st & 2nd method is effectively 100% superseded by Method 3's vastly more configurable & reviewable UI for cookies.

Upravil(a) Franpa dňa

more options

There is a difference between Content Blocking and cookie permissions. Content Blocking is about blocking content from specific website that are part of a special list that includes all kind of categories.

Cookie permissions are about allowing or blocking cookies for specific domains, so no content is blocked. Content Blocking includes blocking third-party cookies, so you can block cookies from domains other that the domain you currently visit. This can be third-party domains that embed ads on a web page, but in some cases a website can host content on a b;locked server. Some websites rely on third-party cookies and won't work properly when you block all third-party cookies. In this case a cookie allow exception for involved domains helps in this case.

more options

This has since been solved, either I wasn't looking hard enough or an update to Firefox added an extra button to the left of the Padlock button in the Address Bar that when clicked will let me disable Content Blocking for the domain, regardless of what the domain is.

more options

Yes, in Firefox 70 and later you have the Content Blocking shield permanently visible at the left end of the location/address bar. On older Firefox versions this button was only present when blockable content was detected.