Search Support

how do i change an autofill option? Firefox autofills a web form when i load the page. but it uses the wrong email

  • 12 odpovedí
  • 1 má tento problém
  • 37 zobrazení
  • Posledná odpoveď od cor-el

more options

help. Here's what's happening: Firefox is autofilling a web form when i load the page (which i want)

BUT its entering the wrong email address (which i dont want)

How do i get firefox to enter the RIGHT email upon page load? (note: i'm not talking about manual autofill selection. I want it to be correct, automatically, when the page loads)

All Replies (12)

more options
more options

i've read all sections on autofill, this doesn't deal with the issue. is there an actual way to to contact mozilla help?

I need someone who can answer the specific question.

more options

Difficult to access Mozilla other than via the forums. I would think you may need to clear your form as described and reconstruct it with the correct details. May be a bit of work but could save time down the track.

more options

Sir, I actually don't know HOW it started autofilling my form details (when i go to ta certain website). So i wouldn't know how to undo that, or how to reconstruct it. I don't see a function anywhere in the help section on how to make the form autofill, automatically, upon page load.

Thanks for following up.

Upravil(a) rkinds123 dňa

more options

Hi rkinds123.

If I understand you correctly you are trying to delete the data saved by the Password Manager. There is a knowledgebase article from Mozilla on how to delete or change these details.

Please let us know if following this article helped you get rid of the wrong email adress.

more options

nope. if you read the original question, it says the browser AUTOFILLS UPON OPENING THE WEB PAGE.

I want it to KEEP doing that, but with the CORRECT email address.

Thanks

more options

Right. But the only case that I know of that would make Firefox fill out these forms is whenever an email adress or password has been saved in the Password Manager.

To delete (or change for that matter) these credentials:

  1. Click the menu button and choose Options.
  2. Click the Privacy & Security panel.
  3. Click Saved Logins… under Forms & Passwords. The Password Manager will open.
  • To see the passwords you have saved, click Show Passwords. When you close the window, your passwords will be automatically hidden. Use the search box to find a particular website or username. Click the X in the search bar to clear your search and see the full list again.
  • To remove the username and password for a website, select the site's entry from the list and click Remove.
  • To remove all stored usernames and passwords, click Remove All. After confirming this choice, all of your stored usernames and passwords will be deleted.
  • To edit passwords or emails right-click on an entry and click on either Change password or Change Username.
  • To import passwords from Chrome or Internet Explorer, click Import… and follow the instructions in the wizard.

I hope this could help. If this is not the solution for your problem could you share any additional information on the circumstances under which this problem arises?

Upravil(a) dario.be dňa

more options

no, its not a LOGIN per se, its just a form. Fill it out, click enter.

I can't find the website in those sections you mentioned, and i don't see a login WITH that email, so i really don't know where to start.

GOtta know why it STARTED autofilling my info, i guess.

more options

Okay. Well I assumed it might be something stored by the Password Manager because the Password Manager is not necessarily limited to login forms. The picture I attached shows a suggestion that comes from the Password Manager. It can be identified by the key icon next to the suggestion.

So if it doesn't show up in the Password Manager window then it should be the regular autofill feature from Firefox. With this feature you can delete previous suggestions as such:

  1. Click on the form field and press the ↓ key to display all the saved entries. You may type the first few letters of the entry to limit the number of entries displayed.
  2. Use the ↓ key or the mouse pointer to highlight the entry you wish to delete.
  3. Press Delete. The entry will be removed.

After it has been removed simply using the field with another adress will create a new suggestion that Firefox is going to show in the future.

more options

what you're describing is MANUAL entry. if anyone knows how to change the issue from my original question, please chime in.

Thanks folks.

If noone answers, that's ok. Its a hassle, that i can deal with, but i'd rather avoid it

more options

I might be a bit dumb here but I reckon my first answer will give you what you want extract here - Using Auto Form Fill

To use your previous entry in a form:

   Type the first few letters of the entry 

into the form field. Firefox will display a drop-down menu with what you've typed into the form before.

       You may see a list of all the entries
stored for a particular form field by 

pressing the ↓ key when the field is empty.

   Press the ↓ key to select the entry you want
to re-use. Press Enter when the appropriate 

entry is highlighted. The text of the entry will

appear in the form field. You may also use the 

mouse to click on the entry.

Deleting individual form entries

If you want to remove one of your

previous form entries from Firefox's
history:
   Click on the form field and press the ↓ key 

to display all the saved entries. You may type the first few letters of the entry to limit the

number of entries displayed.
   Use the ↓ key or the mouse pointer to 

highlight the entry you wish to delete.

   Press Delete. The entry will be removed. 

Repeat the process for each entry that you'd

like to delete.

Upravil(a) malaus1 dňa

more options

Only when there is one username and password stored then Firefox will be able to fill this data automatically. So you need to remove the currently used wrong data and let Firefox store the correct data.

You can use these steps to remove saved items from an autocomplete drop-down list.

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

Note that hovering with the mouse no longer works.

See also: