Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

What is the code to remove the following from the bookmarks drop down menu in FF 38?

  • 7 odpovedí
  • 2 majú tento problém
  • 234 zobrazení
  • Posledná odpoveď od Avengement

more options

View Bookmarks Sidebar Show All Bookmarks Ctrl+Shift+B Separator Subcribe To This Page... Separator Bookmarks Toolbar Unsorted Bookmarks

I would like to remove all of this so that the drop down only shows my bookmark list.

Thank you in advance and appreciate anyone that's willing to help.

Vybrané riešenie

The userChrome.css shouldn't show as a Text file, but as a CSS file (Cascading Style Sheet). If it shows as a Text file then there is likely a hidden .txt file extension appended (i.e. the file name is userChrome.css.txt).

Note that the @namespace line should be this:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */
Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (7)

more options

Sorry, I meant to post this under the PC Web browser section. Please move it there.

more options

cor-el said

See:

I appreciate the help but am unable to figure out how to use this add-on?

Would you be willing to explain to be how to achieve what I am trying to accomplish?

more options

I was referring to the code in userChrome.css that I posted in a reply in that thread in case you were looking at the s3menu-wizard extension.

Where do you want to remove these items? In the "Show your bookmarks" drop-down list (button next to the star on the Navigation Toolbar) or in the Bookmarks menu?


  • create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userChrome.css file in the editor window
  • make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file

You can use this button to go to the current Firefox profile folder:

more options

Yes, that's correct. I'm talking about the drop down menu for the "show your bookmarks" in the navigation toolbar.

I created the "chrome" folder in the "hltp6fad.default" folder and created a text file named userChrome.css and saved the pasted code that was provided using the "all files" option as you suggested inside the chrome folder.

Here is the exact code that currently sits inside the text file:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* items in Bookmarks menu */
#menu_bookmarkThisPage,
#subscribeToPageMenuitem,
#subscribeToPageMenupopup,
#menu_bookmarkAllTabs,
#bookmarksShowAll, #organizeBookmarksSeparator,
#bookmarksToolbarFolderMenu,
#bookmarksToolbarFolderMenu+menuseparator,
#menu_unsortedBookmarks {
 display: none !important;
}

/* items in Bookmarks Menu button (Show your bookmarks) popup */
#BMB_viewBookmarksSidebar,
#BMB_bookmarksShowAllTop, #BMB_bookmarksShowAll,
#BMB_bookmarkThisPage,
#BMB_subscribeToPageMenuitem,
#BMB_subscribeToPageMenupopup, #BMB_subscribeToPageMenupopup+menuseparator,
#BMB_bookmarksToolbar, #BMB_bookmarksToolbar+menuseparator,
#BMB_unsortedBookmarks {
 display: none !important;
}

This still has not removed the following above my bookmarks:

"View Bookmarks Sidebar" "Show All Bookmarks Ctrl+Shift+B" spacer "Subcribe To This Page" spacer "Bookmarks Toolbar" "Unsorted Bookmarks"

What am I doing wrong?

Upravil(a) cor-el dňa

more options

Vybrané riešenie

The userChrome.css shouldn't show as a Text file, but as a CSS file (Cascading Style Sheet). If it shows as a Text file then there is likely a hidden .txt file extension appended (i.e. the file name is userChrome.css.txt).

Note that the @namespace line should be this:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */
more options

That worked!

I had to enable file extensions and once I did the text file still had .txt at the end of the file name.

Thank you for taking the time and having the patience to help. Most people wouldn't have.

You are a gentleman :)