Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

large file is attached and linked to wetransfer - nevertheless the file is attached to the mail making the mail untransferable

  • 16 ответов
  • 1 имеет эту проблему
  • 51 просмотр
  • Последний ответ от Stans

more options

This bug was first observe with Windows 10, Thunderbird 78.8.0 and persists in 78.8.1. The larger picture shows the situation after trying to send the mail: uploading the large file was completed and the link shows up in the mail. And this is the first hint for a malfunction I get a warning that my mailserver might reject my mail due to size. The next, smaller picture shows that the mailserver really rejects the mail. I then tried to remove the appanded file from the mail - I could not do so...

Приложенные скриншоты

Все ответы (16)

more options

Are you using the File Link option?

Полезно?

more options

As you can see in the first screenshot the normal response to pressing the link button is visible - the block about the uploaded file is included in the message text, the line in the attachments list is flagged with the wetransfer logo. I thought my problem description made that clear...

Полезно?

more options

There are two ways of using WeTransfer on Tbird. One way is to attach the file, and then a popup shows up asking you to use WeTransfer to link the file. The other way is to click the arrowhead next to the Attach button then choose Filelink option and finally select WeTransfer. This is the option I was asking about, and the question still remains, is this the option you are using or the other (popup) option? It seems Thunderbird thinks the attachment is a regular attachment, which obviously exceeds the file size permitted by the outgoing server. Using one or the other option may have a different result. If the outcome is the same and Tbird treats both cases as regular attachments (hence the warning), then you should report this as a new bug here https://bugzilla.mozilla.org/home. The version of Thunderbird that you're reporting has not been released yet. I suppose you meant 68.8.x and not 78.8.x

Полезно?

more options

Hallo, the procedure using scrolldown next to attach was unknown to me. Unfortunately it doesn't result in a better outcome. The same error shows up. A screenshot of my attempt is uploaded. I'll try to file the bug ... Of course you are right - version is 68 and not 78.

Полезно?

more options

I submitted bug 1640642

Полезно?

more options

On second thought, I don't think this is a bug because I just tested WeTransfer file linking in Tbird 68 and it's working as expected. I can't reproduce your problem, which means the error is in your Thunderbird installation and not Thunderbird's coding. I suggest you remove WeTransfer from Tbird and re-add it. You can do so by going to Options > Attachments, select WeTransfer then click the Remove button. Restart Tbird then re-add WeTransfer from the same Options tab.

Полезно?

more options

May I quote Nicolaus Wirth: A faulty program is behaving erratically. Erratic behaviour includes that the outcome is in many cases as expected. According to this please do not derive from Thunderbird doing its job properly most of the time that it is free from bugs and that the bug must be elsewhere. It is not possible to remove a wetransfer add on. The only thing possible is to delete the wetransfer service provider from the list of "large file link services". I tried to do the test you suggested and then re-added wetransfer. For the next attempt I used a file slightly smaller file, only 55MB. The result was bad too but interestingly somewhat different: The send button was greyed preventing me from an attempt to send. I made another experiment. I used a 9MB file. Again it was linked and confirmed and I could send the mail. However the attachment was actually part of the 12MB mail... I could do both download the file from wetransfer but also extract the attachment from the mail...

Полезно?

more options

I never said you remove the WeTransfer add-on, you must have gotten that from elsewhere. I'm not saying Tbird is bug-free, what I'm saying is this specific case is not a bug in Tbird's programing, and as such should not be reported as a bug via the page I linked to earlier, just yet. Something else you can try is do a clean reinstallation of Thunderbird. Exit then uninstall Tbird via Control Panel or the Settings app, then delete its installation folder found in C:\Program Files and/or C:\Program Files (x86) then download the latest version from thunderbird.net and install it. This will not touch/affect your profile folder, so you won't lose your emails or settings. Since WeTransfer is integrated into Tbird and is not repairable separately, a clean reinstall might fix it.

Изменено Stans

Полезно?

more options

I made a successful new attempt. TB unmodified, Test attachment again 9MB but - the file now resides on local HD and not on a NAS-drive (smb-file service, network drive). Et voila: TB behaves perfectly! The email message is really small now. Could you possible try again to reproduce the bug with attachment of a file residing in the network?

Полезно?

more options

I'll give it a try, but since you already filed the bug report, you should update it by adding comments to the effect that this only happens when the linked file resides on a network drive. I suppose you've mapped the network drive and are not accessing it from the Network location of Explorer, correct?

Полезно?

more options

I am sorry I cannot answer your question. Explorer has the following path for my attached file: Netzwerk \NAS-Hartl\Sabine_nas\Leopoldo Richter\Leopoldo Richter\leopoldo_16-03-2020.pdf The NAS is 2-bay QNAP device. The HD's are mirrored. Unfortunately I configured this device 2years ago without much understanding. As far as I can remember Sabine_nas is a share on that device. NAS-Hartl has an IP-Adress 192.168.178.45 in the local Network. What should I look up to answer your question

Полезно?

more options

When you open Explorer, the left pane aka the navigation pane, has a location called Network, among others like This PC. When you click this Network location the main pane shows its contents, which is where you'd normally look for network attached devices like your NAS. Unfortunately, this location doesn't always show network devices when expected. I find it to be a cumbersome way of accessing network shares. The alternative, is to Map the network drive so that it appears like a regular drive with a drive letter assigned to it, under This PC. When you open This PC, at the ribbon menu on top, under the Computer tab, there is an option for Map network drive. If this is the option you used to setup access to the NAS, then the NAS should be appearing under This PC with a drive letter assigned to it when you did so. Is that the case? If so, then you will have answered my question.

Полезно?

more options

my NAS-device is not mapped. Explorer "Dieser PC" has 3 categories: Folders, Devices and drives and Network addresses. Devices and drives lists: local HD (C:) and DVD-drive (E:) Network addresses lists: NAS-Hartl The NAS is not assigned a drive letter.

Полезно?

more options

In that case, the Add a network location option was used instead of the Map network drive option. No matter, the important thing is that the NAS is accessible directly and persistently from This PC instead of the Network folder. I doubt if this has any impact to the issue at hand though, because the location of the attached file is still a remote (network) one and not a local one. Will let you know if I can reproduce the same from my end.

Полезно?

more options

Hallo Stans, in bug 1640642 I reported that I was able to reproduce the bug - with another W10-Laptop and also my QNAP-nas device - without my QNAP-nas device by providing a network share with a windows 10 laptop

My problem now only is to find someone to confirm the bug... Can you help?

Полезно?

more options

Sure, I will try and reproduce the bug then post a comment in that report.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.