Произошел крах плагина Adobe Flash - Как предотвратить появление этого сообщения снова

(Перенаправлено с Падение Flash 11.3)

Сообщение Произошёл крах плагина Adobe Flash отображается в случае, когда плагин Flash неожиданно прекратил работу. Чтобы снова показать видео, анимацию или продолжить игру, попробуйте просто перезагрузить страницу.

Plugin crash notification
Plugin crash notification Fx21

Если Flash плагин продолжает падать, обновление до последней версии Flash может решить эту проблему для большинства пользователей. В данной статье рассказано, как обновить Flash и другие возможные решения.

Обновите Flash

Последняя версия плагина Flash должна работать лучше и падать реже. Чтобы проверить, находится ли плагин Flash в актуальном состоянии, посетите страницу проверки плагинов Mozilla. Если она говорит, что Flash нужно обновить, установите вручную его последнюю версию, используя описанные ниже шаги.

  1. Перейдите на страницу загрузки Flash Player Adobe и загрузите файл установки Flash.
    Внимание: Страница загрузки Adobe может содержать флажок установки опциональных программ (таких как Google Chrome или McAfee Security Scan), установленный по умолчанию. Если вы не снимете этот флажок перед загрузкой, то эти программы будут установлены при запуске программы установки Flash.
  2. По завершении загрузки закройте Firefox.

    В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  3. Запустите загруженный вами файл установки Flash и следуйте инструкциям.
Примечание: Если у вас возникли проблемы с программой установки Flash со страницы загрузки Adobe, вы можете использовать эту ссылку на установщик Flash Player для загрузки автономной программы установки Flash Player напрямую.
  1. Перейдите на страницу загрузки Flash Player Adobe и загрузите файл установки Flash.
  2. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  3. Откройте загруженный вами файл (напр. install_flash_player_osx_intel.dmg).
  4. В Finder откройте Install Adobe Flash Player.app, чтобы запустить программу установки, затем следуйте инструкциям программы установки.
  1. Перейдите на страницу загрузки Flash Player Adobe.
  2. При выдаче запроса, сохраните файл (напр. install_flash_player_"version"_linux."processor".tar.gz).
  3. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  4. Откройте окно Терминала (в Gnome, откройте меню Приложения, выберите раздел Стандартные, и в нём выберите пункт Терминал.)
  5. В окне Терминала, перейдите в каталог в который вы сохранили загруженный вами файл (напр. cd /home/user/Downloads).
  6. Извлеките файл libflashplayer.so из загруженного вами файла с помощью команды tar -zxvf install_flash_player_"version"_linux."processor".tar.gz.
  7. Используя полномочия администратора, скопируйте извлечённый файл, libflashplayer.so, в подкаталог plugins каталога, в который установлен ваш Firefox. Например, если Firefox установлен в каталог /usr/lib/mozilla, выполните команду sudo cp libflashplayer.so /usr/lib/mozilla/plugins и введите пароль вашего администратора, когда он будет запрошен.

    0a85171f1802a3b0d9f46ffb997ddc02-1260326970-447-1.png

Отключите аппаратное ускорение Flash

Многие проблемы с Flash могут быть решены путем отключения аппаратного ускорения в настройках вашего Flash Player (более подробная информация приведена на странице Справки Flash Player - Параметры Отображения на сайте Adobe). Чтобы отключить аппаратное ускорение Flash:

  1. Перейдите к этой странице помощи Adobe Flash Player.
  2. Щёлкните правой кнопкой мыши Удерживая клавишу Ctrl, щёлкните мышью. по логотипу Flash Player на этой странице, затем щёлкните на Параметры в контекстном меню. Откроется экран параметров Adobe Flash Player.
  3. Щёлкните по значку в нижней левой части окна параметров Adobe Flash Player, чтобы открыть панель Дисплей.
  4. Снимите флажок с Включить аппаратное ускорение.

    fpSettings1.PNG
  5. Щёлкните Закрыть, чтобы закрыть окно параметров Adobe Flash Player.
  6. Перезапустите Firefox.

Отключите защищённый режим Flash

Вы можете отключить защищённый режим Flash. Для этого обратитесь к инструкции Adobe под заголовком "Last Resort": Форум Adobe: Как отключить защищённый режим Flash Player для Firefox?

Отключите защищённый режим Flash, следуя следующей инструкции.
Внимание: Защищённый режим является функцией безопасности Adobe Flash, которая включена по умолчанию. Отключение этой функции приведёт к выключению этой системы обеспечения безопасности.
  1. В панели адреса, наберите about:config и нажмите EnterReturn.

    • Может появится страница предупреждения about:config "Будьте осторожны, а то лишитесь гарантии!". Щелкните по Я обещаю, что буду осторожен!, чтобы перейти на страницу about:config.
  2. Найдите dom.ipc.plugins.flash.disable-protected-mode в списке настроек.
  3. Дважды щёлкните по этой настройке, чтобы переключить её значение из false в true. (Если значение настройки уже установлено в true, это означает, что защищённый режим Flash в настоящее время отключен).
  4. Закройте Firefox.

    В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  5. Перезапустите Firefox.

Отключите Защищённый Режим Flash. Для этого обратитесь к инструкции Adobe под заголовком "Last Resort": Форум Adobe: Как отключить защищённый режим Flash Player для Firefox?

Отключите защищённый режим Flash, следуя следующей инструкции.
Внимание: Защищённый режим является функцией безопасности Adobe Flash, которая включена по умолчанию. Отключение этой функции приведёт к выключению этой системы обеспечения безопасности.
  1. В панели адреса, наберите about:config и нажмите EnterReturn.

    • Может появится страница предупреждения about:config "Будьте осторожны, а то лишитесь гарантии!". Щелкните по Я обещаю, что буду осторожен!, чтобы перейти на страницу about:config.
  2. Найдите dom.ipc.plugins.flash.disable-protected-mode в списке настроек.
  3. Дважды щёлкните по этой настройке, чтобы переключить её значение из false в true. (Если значение настройки уже установлено в true, это означает, что защищённый режим Flash в настоящее время отключен).
  4. Закройте Firefox.

    В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  5. Перезапустите Firefox.
Отключите Защищённый Режим Flash, следуя следующей инструкции.
Внимание: Защищённый режим является функцией безопасности Adobe Flash, которая включена по умолчанию. Отключение этой функции приведёт к выключению этой системы обеспечения безопасности.
  1. В верхней части окна Firefox щёлкните по кнопке FirefoxВ панели меню щёлкните по меню ИнструментыВ верхней части окна Firefox щёлкните по меню Инструменты, и затем щёлкните по Дополнения. Будет открыта вкладка Управление дополнениями. Щёлкните по кнопке меню New Fx Menu и выберите Дополнения. Будет открыта вкладка Управление дополнениями.

  2. На вкладке Управление дополнениями, выберите панель Плагины.
  3. Найдите в списке плагинов Shockwave Flash и щёлкните по кнопке Настройки.
  4. Снимите флажок с пункта Включить защищённый режим Adobe Flash.
    Fx38-UI-AdobeFlash-protected-mode
  5. Закройте Firefox.

    В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  6. Перезапустите Firefox.

Другие решения


Поделиться этой статьей: http://mzl.la/14Ad7Md

Помогла ли эта статья? Пожалуйста, подождите...

Следующие хорошие люди помогли написать эту статью: Unghost, AnonymousUser, faega, harrierr. Вы тоже можете помочь - узнайте как.