Как проверять орфографию в Firefox?

Firefox автоматически проверяет орфографию слов, вводимых вами в многострочные текстовые поля. Как только вы завершаете ввод слова, оно проверяется по установленному словарю проверки орфографии. Если его нет в словаре, оно подчёркивается красным, например, как на этом изображении.

Spell checker - ru

Примечание:
  • Автоматическая проверка орфографии срабатывает только в текстовых полях, имеющих более чем одну строку, в которые вы можете ввести сколько угодно текста.
  • В связи с проблемами несовместимости лицензий не все переводы Firefox идут в комплекте со словарем проверки орфографии.

Отключение автоматической проверки орфографии

По умолчанию Firefox настроен на автоматическую проверку орфографии. Вы можете это отключить в окне «Настройки»:

  1. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт НастройкиВ верхней части окна Firefox откройте меню Инструменты и выберите пункт НастройкиВ панели меню откройте меню Firefox и выберите пункт Настройки...В верхней части окна Firefox откройте меню Правка и выберите пункт Настройки

    Щёлкните по кнопке меню New Fx Menu и выберите НастройкиНастройки

  2. Выберите панель Дополнительные.
  3. Выберите вкладку Общие.
  4. Снимите галочку Проверять орфографию при наборе текста. проверка орфографии - настройки
  5. Щёлкните OK, чтобы закрыть окно НастройкиЩёлкните Закрыть, чтобы закрыть окно НастройкиЗакройте окно Настройки
Примечание: Некоторые настройки могут не отображаться в переделанных под ваш дистрибутив версиях Firefox.

Как исправлять опечатки

Когда проверка орфографии включена, вы можете легко исправлять опечатки. Чтобы исправить опечатку, нажмите на правую кнопку мышиудерживая Ctrl нажмите на кнопку мыши в подчёркнутом красным слове и выберите одно из предложенных в верхней части меню слов. проверка орфографии - предложения

Если ни одно из предложенных слов не подходит, то вам нужно исправить его вручную. Если вы уверены, что слово написано правильно, вы можете добавить его в словарь: нажмите на правую кнопку мышиудерживая Ctrl нажмите на кнопку мыши в подчёркнутом красным слове и выберите Добавить в словарь.

Примечание: Добавление слов распространяется на все ваши словари.

Добавление словарей

Если нужно, вы можете установить дополнительные словари.

  1. Щёлкните правой кнопкой мыши Удерживая клавишу Ctrl, щёлкните мышью. в любом текстовом поле, содержащем более одной строки.
  2. Выберите Языки.
  3. Выберите Добавить словари....

проверка орфографии - добавить словари

  1. Откроется страничка Mozilla дополнения - словари. Чтобы установить словарь в ваш Firefox, щёлкните по ссылке «Установить словарь» напротив наименования языка, для которого вы хотите поставить словарь. Вы перейдёте на страницу дополнения, содержащего этот словарь. На этой странице щёлкните по кнопке «Добавить в Firefox». Появится диалог «Установка программы». Нажмите на кнопку Установить сейчас, тогда откроется окошко, отображающие прогресс загрузки и установки дополнения. Spell Checker - Win4
  2. После установки некоторых словарей может появиться просьба перезапустить Firefox для завершения его установки. В этом случае перезапустите Firefox.
Примечание: Если не установлено никаких словарей, то Языки не будет, вместо него сразу будет Добавить словари....

Переключение словарей

После установки словаря вы можете переключиться на него, если нужно. Щёлкните правой кнопкой мыши Удерживая клавишу Ctrl, щёлкните мышью. по многострочному полю, выберите Языки, и выберите словарь, который вам нужен.
проверка орфографии - выбор языка

Как удалить случайно добавленное слово

  1. Откройте папку вашего профиля:

    В верхней части окна Firefox, щёлкните по кнопке Firefox, перейдите в меню СправкаВ панели меню щёлкните по меню СправкаВ верхней части окна Firefox, щёлкните по меню Справка и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.Щёлкните по кнопке меню New Fx Menu , затем щёлкните по кнопке справки Help-29 и выберите Информация для решения проблем. Откроется вкладка Информация для решения проблем.

  2. В разделе Сведения о приложении щёлкните по кнопке Показать папкуПоказать в FinderОткрыть каталог. Откроется окно, содержащее файлы с папкой вашего профиля.
  3. Примечание: Если вы не можете открыть или использовать Firefox, следуйте инструкциям из статьи Как найти свой профиль не открывая Firefox.

  4. В верхней части окна Firefox щёлкните по кнопке Firefox и выберите пункт ВыходВ верхней части окна Firefox откройте меню Файл и выберите пункт ВыходВ панели меню откройте меню Firefox и выберите Выйти из FirefoxВ верхней части окна Firefox откройте меню Файл и выберите пункт Выход

    Щёлкните по кнопке меню New Fx Menu и затем щёлкните по кнопке ВыходВыход Close 29

  5. Откройте файл persdict.dat в текстовом редакторе (таком как Wordpad).
  6. В текстовом редакторе каждое добавленное вами слово расположено на отдельной строке. Удалите строку, на которой расположено слово, которое вы хотите убрать из вашего словаря.
  7. Откройте меню Файл и выберите Сохранить, чтобы сохранить ваши изменения.
Примечание: Удаление слов распространяется на все ваши словари.



Поделиться этой статьей: http://mzl.la/LrKs1T

Помогла ли эта статья? Пожалуйста, подождите...

Следующие хорошие люди помогли написать эту статью: Unghost, Gryllida. Вы тоже можете помочь - узнайте как.