Часто задаваемые вопросы - Технология дополнений Firefox модернизируется

Что такое устаревшее расширение?

Расширение, созданные с помощью окружений, не совместимых с Firefox 57 и более поздними версиями (таких как SDK или XUL), рассматриваются как "устаревшие" расширения.

Как я могу узнать, есть ли у меня установленные устаревшие расширения?

Чтобы узнать, есть ли у вас установленные несовместимые расширения, перейдите в Управление дополнениями (Меню > Дополнения или наберите “about:addons” в новой вкладке). Если у вас есть устаревшее расширение, вы увидите такое уведомление в верхней части экрана:

Legacy extension warning

Щёлкните по ссылке “Показать устаревшие расширения”, чтобы увидеть список устаревших расширений, установленных в вашем браузере. Щёлкните по “Найти замену” рядом с каждым устаревшим расширением для рекомендуемой альтернативы. Вы можете узнать больше об этой функции в нашем блоге.

Если я вижу ярлык "устаревшее", это означает, что моё расширение сломается после обновления на 57+?

Да, дополнения, отмеченные "устаревшее", скорее всего, не будет работать после апгрейда. Однако большинство наиболее популярных расширений Firefox совместимы с Firefox 57+. В некоторых случаях разработчики работают над обновлениями своих расширений, чтобы они стали совместимыми с текущими версиями Firefox. В этих случаях расширение автоматически обновится, когда станет доступна совместимая версия.

Если я вижу ярлык "устаревшее", это означает, что моё расширение сломано?

Да, расширения, отмеченное меткой "устаревшее", не будет работать с Firefox 57. В некоторых случаях разработчикам потребуется продолжать работу после даты релиза - 14 ноября 2017 г., чтобы сделать их расширения совместимыми. В этих случаях расширение автоматически обновится, когда совместимая версия будет доступна.

Вы можете порекомендовать замену для моих устаревших расширений?

Да! Вы можете просмотроеть нашу рекомендуемую коллекцию, которая состоит из часто используемых расширений, или совершить поиск совместимых расширений по сайту addons.mozilla.org (AMO).

Также вы можете использовать утилиту поиска расширений для поиска расширений, которые вы хотите заменить, и изучения рекомендованных замен.

Да! Перейдите в в Управление дополнениями (Меню > Дополнения или наберите "about:addons" в новой вкладке) и выберите Устаревшие расширения. Щёлкните по "Найти замену" рядом с каждым устаревшим расширением для рекомендуемой альтернативы. Вы можете узнать больше об этой функции в нашем блоге.

Мы рекомендуем вам искать совместимые расширения на addons.mozilla.org (AMO) или с помощью поиска по рекомендуемой коллекции.

Также вы можете использовать утилиту поиска расширений для поиска расширений, которые вы хотите заменить, и изучения рекомендованных замен.

Для одного из моих устаревших расширений нет рекомендуемых замен. Что теперь?

Если вы не сможете найти подходящую замену, воспользуйтесь нашим форумом, чтобы попросить предложения у сообщества.

Как я могу найти расширения, которые совместимы с Firefox 57 и последующих?

Вы можете совершить поиск совместимых расширенийна сайте addons.mozilla.org. Коллекция рекомендуемых расширений также включает в себя замечательные расширения, которые будут совместимы после появления Firefox 57.

Когда Firefox ESR перестанет поддерживать устаревшие расширения?

Firefox Extended Support Release (ESR) версии 52 - последняя версия, поддерживающая устаревшие расширения. Поддержка ESR 52 не будет предоставляться с 5 сентября 2018 года.

В октябре 2018 года все устаревшие дополенния будут отключены на addons.mozilla.org (AMO). Когда это произойдёт, пользователи больше не смогут найти устаревшие дополнения на AMO.

Если вы решили использовать неподдерживаемые релизы, чтобы использовать устаревшие дополнения, это может сделать вас уязвимым к угрозам безопасности и мы настоятельно не рекомендуем их использование.

Мои темы сломаются в Firefox 57?

Если вы используете лёгкую тему, то не ощутите никаких изменений. Если вы используете полноценную тему, она будет отключена, начиная с Firefox 57, и больше работать не будет. Если вы используете тёмную полноценную тему, Тёмная тема в Управлении дополнениями может стать для вас хорошим вариантом. Перейдите на вкладку Темы в about:addons и попробуйте её.

Что случилось с моей полноценной темой?

Полноценные темы не работают в Firefox 57 и отключены. Если вы используете тёмную полноценную тему, Тёмная тема в Управлении дополнениями может стать для вас хорошим вариантом. Перейдите вкладку Темы в about:addons и попробуйте. Мы готовим улучшения для тем в предстоящие месяцы, так что ожидайте темы с дополнительной функциональностью за пределами покрытия изображениями в будущих релизах.

Что случилось с моими дополнениями, касающимися Flash?

Начиная с релиза Firefox 55 Adobe Flash не запускается по умолчанию, т.к. в браузер встроен Click-to-run Flash. Вы можете выбрать, как бы вы хотели, чтобы вёл себя Flash на определённых сайтах или всех сайтах.

Некоторые из наиболее популярных Flash-расширений, предоставлявших эту возможность ранее, стали частью браузера. Так как эти расширения теперь устарели, они, вероятно, больше не будут поддерживаться разработчиками и больше не будут работать.

В некоторых случаях у нас есть WebExtension API для дополнительных возможностей для Flash (например, удаление Flash LSO) и мы ожидаем, что дополнения получат со временем больше возможностей для Flash, учитывая, что мы работаем вместе, чтобы выяснить, что требуется для того, чтобы предоставить равноценную функциональность.

// Следующие хорошие люди помогли написать эту статью:Anticisco Freeman, Valery Ledovskoy. Вы тоже можете помочь - узнайте как.

Помогла ли эта статья? Пожалуйста, подождите...

Вступите в Поддержку Mozilla