Pesquisar no apoio

Evite burlas no apoio. Nunca iremos solicitar que telefone ou envie uma mensagem de texto para um número de telefone ou que partilhe informações pessoais. Por favor, reporte atividades suspeitas utilizando a opção "Reportar abuso".

Learn More

Websites not using user-defined default fonts

  • 4 respostas
  • 1 tem este problema
  • 39 visualizações
  • Última resposta por cor-el

more options

I've set custom fonts through Settings > Fonts > Advanced, but the fonts I have specified are not being used on any websites even if I uncheck the box that says "Allow pages to choose their own fonts, instead of your selections above". For example, I've set the default sans serif to Source Sans 3, but websites use Arial regardless of the settings. The only custom font I've gotten to work is Segoe UI (the UI font on Windows); all other just fall back to Arial. The problem persists even if I disable all extensions/add-ons. I'm also experiencing the problem for non-Latin scripts; I've tried to set the default Bengali font to Noto Sans Bengali, but websites are using Vrinda instead.

I'm running Firefox version 120.0 on Windows 11, any help is greatly appreciated!

I've set custom fonts through Settings > Fonts > Advanced, but the fonts I have specified are not being used on any websites even if I uncheck the box that says "Allow pages to choose their own fonts, instead of your selections above". For example, I've set the default sans serif to Source Sans 3, but websites use Arial regardless of the settings. The only custom font I've gotten to work is Segoe UI (the UI font on Windows); all other just fall back to Arial. The problem persists even if I disable all extensions/add-ons. I'm also experiencing the problem for non-Latin scripts; I've tried to set the default Bengali font to Noto Sans Bengali, but websites are using Vrinda instead. I'm running Firefox version 120.0 on Windows 11, any help is greatly appreciated!

Solução escolhida

In Firefox 119 Fingerprinting protection has been added to Enhanced Tracking Protection in Strict/Custom mode (Suspected fingerprinters) what affects accessing local fonts. To include user installed fonts, modify this pref on the about:config page: privacy.fingerprintingProtection.overrides => -FontVisibilityBaseSystem,-FontVisibilityLangPack

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

Ler esta resposta no contexto 👍 1

Todas as respostas (4)

more options

Immediately after posting this I figured out the issue: I had my enhanced tracking protection set to strict, which only allows a specific list of fonts. I disabled "suspected fingerprinters" which re-allowed my custom fonts.

Útil?

more options

Solução escolhida

In Firefox 119 Fingerprinting protection has been added to Enhanced Tracking Protection in Strict/Custom mode (Suspected fingerprinters) what affects accessing local fonts. To include user installed fonts, modify this pref on the about:config page: privacy.fingerprintingProtection.overrides => -FontVisibilityBaseSystem,-FontVisibilityLangPack

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

Útil?

more options

This has been such a headache for me since they introduced it in 117 or whenever. It's such an incredibly stupid "feature". I asked for help about this issue from the community and every response I got was people trying to gaslight me into thinking I had my system or browser configured wrong. I downgraded to 111 because I could not work around this.

cor-el said

To include user installed fonts, modify this pref on the about:config page: privacy.fingerprintingProtection.overrides => -FontVisibilityBaseSystem,-FontVisibilityLangPack

I tried this and it worked. Thank you.

The only problem now is that this issue persists when browsing localhost. I disabled "Enhanced Tracking Protection" for localhost and that did not help. I can confirm that "https://localhost" is listed under "Exceptions for Enhanced Tracking Protection"; however, it appears using the "https://" schema. I don't know if that matters; but I cannot add "http://localhost". If I remove "https://localhost" and try to add either "localhost" or "http://localhost", the item added appears with "https". Again, I don't know if that matters. And I do not understand what in the fuck Firefox is doing at this point. Designing a user agent to ignore its user's configuration is completely incomprehensible to me. This really sucks.

Útil?

more options

Hi sqwishy

Did you try ETP Standard mode or Custom mode with Known fingerprinters and Suspected fingerprinters disabled as this font issue is only a problem with ETP Strict mode ?

Útil?

Colocar questão

Deve iniciar a sessão com a sua conta para responder às mensagens. Por favor, comece uma nova pergunta, se ainda não tiver uma conta.