X
Stuknij, by przejść do witryny w wersji zoptymalizowanej dla urządzeń przenośnych.

Forum pomocy

firefox tries to resolve DNS before using /etc/hosts

Wysłano

entries in /etc/hosts that are not real (e.g. notrealsubdomain.example.com) work. If I try to point e.g. example.com to 127.0.0.1 it is ignored and the "real" resolution is used. Entries in /etc/hosts should have the highest priority. Also, I've tried every recommended solution by modifying settings in about:config.

entries in /etc/hosts that are not real (e.g. notrealsubdomain.example.com) work. If I try to point e.g. example.com to 127.0.0.1 it is ignored and the "real" resolution is used. Entries in /etc/hosts should have the highest priority. Also, I've tried every recommended solution by modifying settings in about:config.

Zmodyfikowany przez qshan w dniu

Wybrane rozwiązanie

It started working for me, I'm not really sure why. Thank you for the detailed responses!

Przeczytaj tę odpowiedź w całym kontekście 0

Dodatkowe dane o systemie

Zainstalowane wtyczki

  • Shockwave Flash 27.0 r0

Aplikacja

  • Identyfikator przeglądarki: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:57.0) Gecko/20100101 Firefox/57.0

Więcej informacji

Shadow110 1072 rozwiązań 14836 odpowiedzi

No idea what you have done : I've tried every recommended solution by modifying settings in about:config.

Refresh and make a new Profile, contact back before playing in about : config please if still have issues.

Please Refresh but do this 1st:

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Please let us know if this solved your issue or if need further assistance.

No idea what you have done : I've tried every recommended solution by modifying settings in about:config. Refresh and make a new Profile, contact back before playing in about : config please if still have issues. Please Refresh but do this 1st: *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles then *https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...: *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If is your Profile : *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Note: Any customization will revert back to default, you will also need to reinstall Extensions. Please let us know if this solved your issue or if need further assistance.
jscher2000
  • Top 10 Contributor
8638 rozwiązań 70677 odpowiedzi

It should work.

Did you clear Firefox's cache between changes?

You can use the steps in this article: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress.

Do you use a proxy that may change the normal DNS resolution behavior?

You can check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your OS setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

Past Threads

These may be one-offs, but in case they're helpful:

It should work. '''Did you clear Firefox's cache between changes?''' You can use the steps in this article: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress. '''Do you use a proxy that may change the normal DNS resolution behavior?''' You can check that here: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page type ''proxy'' and Firefox should filter to the "Settings" button, which you can click. The default of "Use system proxy settings" piggybacks on your OS setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy". Any difference? '''Past Threads''' These may be one-offs, but in case they're helpful: * [https://support.mozilla.org/questions/1041757 Firefox ignores settings in /etc/hosts Mac Mavericks] * [https://support.mozilla.org/questions/1011327 MAJOR BUG: Firefox ignores the hosts file]

Wybrane rozwiązanie

It started working for me, I'm not really sure why. Thank you for the detailed responses!

It started working for me, I'm not really sure why. Thank you for the detailed responses!