Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I want to change the default email in firefox.

  • 6 svar
  • 2 har dette problemet
  • 8 views
  • Siste svar av cor-el

more options

I found the answer to how to change my default email when using Firefox, but I'm not able to do what it says. It instructed me to go to Tools/Options/Applications and to find something that says "mailto" on the list, but "mailto" is not anywhere in the list. I'd appreciate help --

I'm running Firefox 10.0.2 on Windows 7. Thanks.

I found the answer to how to change my default email when using Firefox, but I'm not able to do what it says. It instructed me to go to Tools/Options/Applications and to find something that says "mailto" on the list, but "mailto" is not anywhere in the list. I'd appreciate help -- I'm running Firefox 10.0.2 on Windows 7. Thanks.

All Replies (6)

more options

Hi ewormuth,

What happens when you click on a "mailto" link as it is? You can find a test link at the bottom of this article. I might be wrong, but I think you need to click on one first before that type will show up in the list.

Hopefully this helps!

Endret av Matt_G

more options

Hi Matt -- thanks for your reply. I'm not sure I understand your question, but if I'm on a website and I hit their "email me" button (which has a mailto link behind it?) I get the Outlook configuration page (because I don't want another email account to worry about, I've never configured it). Could that be the problem? That I've never configured the default one, so there is no "mailto" list on my applications?

more options

Try to delete the mimeTypes.rdf file in the Firefox Profile Folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder
more options

Deleting the mimeTypees.rdf file (or renaming it, e.g., mimeTypes.rdfX ) will reset all download actions. You should first double-check the Applications panel - Set how Firefox handles different types of files by entering mailto in the search box (in case you missed it the first time you checked) as shown here: Change the program used to open email links

more options

Nope -- I searched and it wasn't there. Thanks for your replies.

more options

Did you try to delete the mimeTypes.rdf file to see if that brings back the default Mailto entry in Options > Application?

You can also check the mailto prefs on the about:config page (Filter: mailto) and reset mailto prefs that show bold (user set) to the default via the right-click context menu.