Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Default search engine

  • 3 antwoorden
  • 1 heeft dit probleem
  • 43 weergaven
  • Laatste antwoord van cor-el

more options

While trying to switch my default search engine in Firefox preferences, the only search engine that is available says "a browser" and has the firefox logo next it. There are no additional search engines to choose and it's driving me insane.

Is there something I'm missing? If anyone could help me get a google search engine in the toolbar, I would be grateful.

Thanks Austen

While trying to switch my default search engine in Firefox preferences, the only search engine that is available says "a browser" and has the firefox logo next it. There are no additional search engines to choose and it's driving me insane. Is there something I'm missing? If anyone could help me get a google search engine in the toolbar, I would be grateful. Thanks Austen

Alle antwoorden (3)

more options

Hello,

You can choose from different search providers such as Google or Bing when you search the Internet using Firefox. To change the default search engine that Firefox uses:

  1. Click the menu button Fx89menuButton and choose Settings.
    • In older Firefox versions, choose "Options" (Windows) or "Preferences" (Mac, Linux) instead.
  2. Select Search in the left pane.
  3. In the Search settings panel that opens, go to the Default Search Engine section.
  4. Select a different search engine from the drop-down menu:
    Fx57DefaultSearchEngine

For more information, see Change your default search settings in Firefox.

Let us know if this helps!

more options

Hi andmagdo!

I appreciate your reply. However, when I click on the drop down menu for default search engines, I don't get a list of different search engines. It just has the one option "a go" which seems to be yahoo. I don't know if it's the new version of firefox, but I can't figure out how to switch it. I am also trying to load a screenshot of what I'm looking at, but this thread won't load a PNG or jpeg file.

more options

Sounds that you got an extension (malware) that disables (hides) all search engines and only leaves its own search engine.

You should be able to remove this extension by starting Firefox in Troubleshoot Mode and have the other search engines show up again. Try to start Firefox in Troubleshoot Mode to see if that works.

  • Windows: hold down the Shift key while starting Firefox
  • Mac: hold down the Options key while starting Firefox

You can also rename/remove search.json.mozlz4 in the Firefox profile folder.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).