X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox repeatedly asks for Master Password, but won't let me enter it

Geplaatst

I recently established a Firefox.com account so I could sync bookmarks across devices. Every time I start FF, it asks me for my master password, but won't accept it. Even after I've just signed into my FF.com account. When I type in my password, the window to enter my password just reappears. I tried unchecking the box to use a master password, since I won't be using FF to store passwords anyway. To do this, you have to enter your current password, which I did, but the 'Remove' button remains greyed-out and unclickable.

So basically, FF won't accept my password, but also won't let me remove the password.

I recently established a Firefox.com account so I could sync bookmarks across devices. Every time I start FF, it asks me for my master password, but won't accept it. Even after I've just signed into my FF.com account. When I type in my password, the window to enter my password just reappears. I tried unchecking the box to use a master password, since I won't be using FF to store passwords anyway. To do this, you have to enter your current password, which I did, but the 'Remove' button remains greyed-out and unclickable. So basically, FF won't accept my password, but also won't let me remove the password.

Gekozen oplossing

If you have key3.db and key4.db in the Firefox profile folder then try to remove key4.db in case something went wrong from migrating from key3.db used previously to key4.db used in current Firefox releases.

If that doesn't work then rename/remove logins.json and key4.db and key3.db when present.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Dit antwoord in context lezen 1

Aanvullende systeemdetails

Toepassing

  • Useragent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0

Meer informatie

FredMcD
  • Top 10 Contributor
4306 oplossingen 60428 antwoorden

Ambivalent said

asks me for my master password, but won't accept it

What do you mean? You can't click in the password box? You can't enter anything in the password box?

If you have passwords selected for sync, you need to enter the master for sync to work.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

''Ambivalent [[#question-1215406|said]]'' <blockquote> asks me for my master password, but won't accept it </blockquote> What do you mean? You can't click in the password box? You can't enter anything in the password box? If you have passwords selected for sync, you need to enter the master for sync to work. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17673 oplossingen 159870 antwoorden

Gekozen oplossing

If you have key3.db and key4.db in the Firefox profile folder then try to remove key4.db in case something went wrong from migrating from key3.db used previously to key4.db used in current Firefox releases.

If that doesn't work then rename/remove logins.json and key4.db and key3.db when present.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

If you have key3.db and key4.db in the Firefox profile folder then try to remove key4.db in case something went wrong from migrating from key3.db used previously to key4.db used in current Firefox releases. If that doesn't work then rename/remove logins.json and key4.db and key3.db when present. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Vraageigenaar

What do you mean? You can't click in the password box? You can't enter anything in the password box?

What I mean is what I said: the dialog box appears, I type in my password, and then the dialog box immediately reappears.

Yes, the problem is still there in Safe Mode.

<blockquote>What do you mean? You can't click in the password box? You can't enter anything in the password box?</blockquote> What I mean is what I said: the dialog box appears, I type in my password, and then the dialog box immediately reappears. Yes, the problem is still there in Safe Mode.

Vraageigenaar

cor-el said

If that doesn't work then rename/remove logins.json and key4.db and key3.db when present.

I had to delete all three files and restart Firefox. When I restarted FF, there was a yellow warning triangle over the menu hamburger and the message "reconnect to sync" at the top of the menu.

Clicked on that to sign in again. Signed in, and had to confirm the login via a link sent to my email address. After that, did not receive any more asks for my master password, and the preferences reflected my choice to not use a master password.

Thanks!

''cor-el [[#answer-1105423|said]]'' <blockquote> If that doesn't work then rename/remove logins.json and key4.db and key3.db when present. </blockquote> I had to delete all three files and restart Firefox. When I restarted FF, there was a yellow warning triangle over the menu hamburger and the message "reconnect to sync" at the top of the menu. Clicked on that to sign in again. Signed in, and had to confirm the login via a link sent to my email address. After that, did not receive any more asks for my master password, and the preferences reflected my choice to not use a master password. Thanks!