Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Cannot find Border property

  • 5 antwoorden
  • 1 heeft dit probleem
  • 41 weergaven
  • Laatste antwoord van ErraticFox

more options

Hello, I'm making a FF theme with DOMi and there's a border that I can't seem to get rid of or find where it's coming from. It's the very thin border between the actual webpage and the navbar in FireFox. As you can see in the screenshot below, the very bottom border of where the webpage and FF connect. I cannot find where that is coming from. I've search for it for over an hour. I know it's coming from within the toolbar I think. I've even done (for testing) stuff like

    #main-window * {
         border: none !important;
    }


and even then that didn't rid of it. I've also tried padding, margin, background-color, etc.

Where is this line coming from?

Hello, I'm making a FF theme with DOMi and there's a border that I can't seem to get rid of or find where it's coming from. It's the very thin border between the actual webpage and the navbar in FireFox. As you can see in the screenshot below, the very bottom border of where the webpage and FF connect. I cannot find where that is coming from. I've search for it for over an hour. I know it's coming from within the toolbar I think. I've even done (for testing) stuff like #main-window * { border: none !important; } and even then that didn't rid of it. I've also tried padding, margin, background-color, etc. Where is this line coming from?
Gekoppelde schermafbeeldingen

Bewerkt door ErraticFox op

Gekozen oplossing

A larger screenshot I think would take away from the subject. It's the little grey border at the bottom and that is the default FF theme in the picture. I've gave #navigator-toolbox a border of 0 with !important before and that didn't work.


EDIT: Found it by looking at another theme and searching through their #navigator-toolbox properties. The way to get rid of this is:

    #navigator-toolbox::after { 
      height: 0px;
    }
Dit antwoord in context lezen 👍 0

Alle antwoorden (5)

more options

I can't figure it out, either. It could be one of the -moz attributes or properties.

more options

It is probably the border of the #navigator-toolbox. Sometimes you can remove (hide) such a border with a negative margin. It can also be a box-shadow.

The screenshot is a bit msall and doesn't show much, so I'm not sure what your current toolbar setup is and what toolbars you show and in what order.

Maybe you can provide a larger screenshot.

Bewerkt door cor-el op

more options

Gekozen oplossing

A larger screenshot I think would take away from the subject. It's the little grey border at the bottom and that is the default FF theme in the picture. I've gave #navigator-toolbox a border of 0 with !important before and that didn't work.


EDIT: Found it by looking at another theme and searching through their #navigator-toolbox properties. The way to get rid of this is:

    #navigator-toolbox::after { 
      height: 0px;
    }

Bewerkt door ErraticFox op

more options

See:

  • chrome://browser/skin/browser.css
#navigator-toolbox::after {
  content: "";
  display: -moz-box;
  -moz-box-ordinal-group: 101; /* tabs toolbar is 100 */
  height: 1px;
  background-color: ThreeDShadow;
}
more options

Accidentally hit not helpful (on my phone) and it won't let me switch it... Though I was questioning why this is even a thing? That property, I mean.