Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cant stop autofilling of url. Tried tools-options privacy-then any and all settings there to no avail.

  • 1 reply
  • 4 have this problem
  • 3 views
  • Last reply by dcgruen

more options

Trying to delete whatever autofills doesn't work. I have tried to never remember history and customize history and I unchecked remember browsing history, download history and remember search and form history, clear history when FF closes but it still does autofill. I am using version 3.6.13

Modified by dcgruen

All Replies (1)

more options

I found my fix. Go to Tools-Options-Privacy-Location Bar-then choose Suggest Nothing. I am guessing that this fix was there all the time and I didn't see it which is usually the case with me. I found the fix after I downloaded version 4.0 and then went back to look at the problem a week later. If these options are not in your version of FF then I have no answer but to download version 4. Good luck!