X
Tap here to go to the mobile version of the site.

Support Forum

how can i tell if javascript is on? How do i turn it on/off?

Posted

One of the answers on your support page says JavaScript is on by default. A webmaster at a page I visited said the reason clicking on his email address did not automatically load Outlook is because JavaScript is turned off. If it is turned off, I don't know how it got that way. I do not see any options to turn it on or off. All I can find is an offer for an add-on to control which sites may or may not use it.

I do not use Sharepoint, so I don't know where that plugin came form, in case that has anything to do with it.

One of the answers on your support page says JavaScript is on by default. A webmaster at a page I visited said the reason clicking on his email address did not automatically load Outlook is because JavaScript is turned off. If it is turned off, I don't know how it got that way. I do not see any options to turn it on or off. All I can find is an offer for an add-on to control which sites may or may not use it. I do not use Sharepoint, so I don't know where that plugin came form, in case that has anything to do with it.

Chosen solution

"Can't find the file" is an unusual message for a mailto: URL. Could you look in the about:config preferences editor and see whether you have any non-default settings relating to the mailto: protocol? Here's what I mean:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste mailto and pause while the list is filtered

(3) If any lines are bolded and "user set" could you copy them (right-click > copy to get both the preference name and value) and paste them into a reply? Or save the information someone and then right-click > reset to see whether that makes any difference.


It's also possible that the file which stores your downloading handling preferences (most of what you see in Options > Applications) has become corrupted. The usual workaround for that is to rename the file and let Firefox regenerate it.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Then start up Firefox.

As the default mail client on your system, Outlook should still be the default mailto method. However, you might need to update some other preferences (e.g., PDF) if you have modified them.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • LastPass Plugin
  • ActiveTouch General Plugin Container Version 105
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • Firefox 28.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
  • Support URL: https://support.mozilla.org/1/firefox/28.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.5.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Diigo Toolbar 5.1.0.39 ({fc2b8f80-d9a5-4f51-8076-7c7ce3c67ee3})
  • LastPass 3.1.1 (support@lastpass.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Zotero 4.0.19 (zotero@chnm.gmu.edu)
  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Norton Toolbar 2014.7.0.43 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 12.2.0.5 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0162
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 10-1-2013
  • driverDate2:
  • driverVersion: 10.18.10.3316
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.use_document_fonts: 0
  • browser.places.smartBookmarksVersion: 6
  • browser.search.useDBForOrder: false
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517
  • browser.startup.homepage: https://www.google.com/
  • browser.startup.homepage_override.buildID: 20140314220517
  • browser.startup.homepage_override.mstone: 28.0
  • browser.zoom.full: False
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 28.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • network.http.max-persistent-connections-per-server: 4
  • places.database.lastMaintenance: 1396299612
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1395598066

Misc

  • User JS: Yes
  • Accessibility: Yes
Gingerbread Man 403 solutions 1537 answers

You do have JavaScript enabled globally.

  1. Type about:config into the address bar and press Enter.
  2. Press the big button to bypass the warning.
  3. In the search bar, type javascript.enabled
  4. In the search results, javascript.enabled should be set to true

Chances are you have something blocked in Adblock Plus that shouldn't be.

  1. Manually update your filter subscriptions.
  2. Click the Adblock Plus icon on the toolbar and chose Open Blockable Items.
  3. Go a page that has a filter you want to remove.
  4. In the Blockable Items Pane, click the rightmost icon (below the search box, and to the right side of the Type column) and make sure Filter Source is checked in that menu.
  5. In the list of blockable items, look for filters with the source "My Blocking Filters" or similar. Right-click (Mac: Ctrl+click) a filter and choose Edit Filter in Effect.
  6. In the filter preferences window that opens, clear the checkbox next to the filter to disable it, or press the Delete key to remove it.
You do have JavaScript enabled globally. # Type ''about:config'' into the address bar and press Enter. # Press the big button to bypass the warning. # In the search bar, type ''javascript.enabled'' # In the search results, ''javascript.enabled'' should be set to '''true''' Chances are you have something blocked in Adblock Plus that shouldn't be. # [https://adblockplus.org/en/faq_basics#update-filterlists Manually update your filter subscriptions]. # Click the Adblock Plus icon on the toolbar and chose Open Blockable Items. # Go a page that has a filter you want to remove. # In the Blockable Items Pane, click the rightmost icon (below the search box, and to the right side of the Type column) and make sure Filter Source is checked in that menu. # In the list of blockable items, look for filters with the source "My Blocking Filters" or similar. Right-click (Mac: Ctrl+click) a filter and choose Edit Filter in Effect. # In the filter preferences window that opens, clear the checkbox next to the filter to disable it, or press the Delete key to remove it.

Question owner

When I enter javascript.enabled in the search bar, I get a blank screen with only headings.

When I enter javascript.enabled in the search bar, I get a blank screen with only headings.

Question owner

OK, so I'm lazy. If I *type* javascript.enabled instead of c/p, then I get the result you predicted.

However, when I go to the AdBlock page, I see nothing that says "Open Blockable Items".

I appear to have the following blacklists installed: EasyList, Malware Domains, Fanboy's Social Blocking List, and EasyPrivacy. There is one that says it was just downloaded today, AdBlock Warning Removal List.

Do I have to search these lists to see if the page in question is on it? Not sure I have that kind of time! <g>

OK, so I'm lazy. If I *type* javascript.enabled instead of c/p, then I get the result you predicted. However, when I go to the AdBlock page, I see nothing that says "Open Blockable Items". I appear to have the following blacklists installed: EasyList, Malware Domains, Fanboy's Social Blocking List, and EasyPrivacy. There is one that says it was just downloaded today, AdBlock Warning Removal List. Do I have to search these lists to see if the page in question is on it? Not sure I have that kind of time! <g>
John99 971 solutions 13138 answers

Maybe you are adding a trailing space ?

You may see more than one preference that includes

javascript.enabled

You are looking for the one that exactly matches.

Maybe you are adding a trailing space ? You may see more than one preference that includes ''javascript.enabled'' You are looking for the one that exactly matches.
jscher2000
  • Top 10 Contributor
8784 solutions 71841 answers

Do email links work on other pages? I find it hard to believe that a filter would block all email links.

But if the problem site's script launches a pop-up window, perhaps that is being blocked.

(Just guesswork without viewing the page...)

Do email links work on other pages? I find it hard to believe that a filter would block all email links. But if the problem site's script launches a pop-up window, perhaps that is being blocked. (Just guesswork without viewing the page...)

Question owner

As a matter of fact, now that you mention it, I have had this problem on another site (I don't use this feature much). I went to Tools > Options > Applications, and I see there that under "Content Type" it says, "mailto" and under "Action" it says "Use Microsoft Outlook (default)" -- so that appears to be working. I remember that it works when someone sends me email with an email address in the body, so I'm guessing that part is working as expected.

If it helps, the site I am currently experiencing the issue with is: http://hotalarmclock.com/

As a matter of fact, now that you mention it, I have had this problem on another site (I don't use this feature much). I went to Tools > Options > Applications, and I see there that under "Content Type" it says, "mailto" and under "Action" it says "Use Microsoft Outlook (default)" -- so that appears to be working. I remember that it works when someone sends me email with an email address in the body, so I'm guessing that part is working as expected. If it helps, the site I am currently experiencing the issue with is: http://hotalarmclock.com/

Modified by martyr6623

jscher2000
  • Top 10 Contributor
8784 solutions 71841 answers

With JavaScript blocked, I see the green button, but it doesn't do anything. With JavaScript enabled, the email address fills in before the green button (see attached). Do you get that far?

But the email address isn't a real mailto link, it still depends on a script.

The script in the page generates the address from an array of numbers. This is somewhat similar to how some attack scripts work, so perhaps some security software is filtering it?

With JavaScript blocked, I see the green button, but it doesn't do anything. With JavaScript enabled, the email address fills in before the green button (see attached). Do you get that far? But the email address isn't a real mailto link, it still depends on a script. The script in the page generates the address from an array of numbers. This is somewhat similar to how some attack scripts work, so perhaps some security software is filtering it?
Gingerbread Man 403 solutions 1537 answers

martyr6623 wrote:

However, when I go to the AdBlock page, I see nothing that says "Open Blockable Items".

What Adblock page? I said to click the Adblock Plus toolbar icon and choose Open Blockable Items from that menu. You can also press Ctrl+Shift+V (except on websites that assign this shortcut to pasting the clipboard contents as plain text).

martyr6623 wrote:

Do I have to search these lists to see if the page in question is on it? Not sure I have that kind of time! <g>

No, I never suggested that. Click the Adblock Plus toolbar icon and choose Disable Everywhere, then reload the page. If that doesn't solve anything, then you can forget the troubleshooting steps I posted earlier, since there's nothing blocked in Adblock Plus that shouldn't be.

''martyr6623 wrote:'' However, when I go to the AdBlock page, I see nothing that says "Open Blockable Items". What Adblock page? I said to click the Adblock Plus toolbar icon and choose Open Blockable Items from that menu. You can also press Ctrl+Shift+V (except on websites that assign this shortcut to pasting the clipboard contents as plain text). ''martyr6623 wrote:'' Do I have to search these lists to see if the page in question is on it? Not sure I have that kind of time! <g> No, I never suggested that. Click the Adblock Plus toolbar icon and choose Disable Everywhere, then reload the page. If that doesn't solve anything, then you can forget the troubleshooting steps I posted earlier, since there's nothing blocked in Adblock Plus that shouldn't be.
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

This code it tied to the email link and the submit button:

var mayvar1 = "alarmclock#adoga#comfort-software.com"; 
function runme1()
{ 
location.href = "mailto:" + mayvar1.replace("#adoga#", "@")+"?subject=Hot%20Alarm%20Clock"; 
}

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
This code it tied to the email link and the submit button: <pre><nowiki>var mayvar1 = "alarmclock#adoga#comfort-software.com"; function runme1() { location.href = "mailto:" + mayvar1.replace("#adoga#", "@")+"?subject=Hot%20Alarm%20Clock"; }</nowiki></pre> ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

OK, first, I must apologize for not supplying sufficient information. When I first signed up for this help forum, I was asked to download a program that supplies system information. I ass-umed this meant that you all would be able to see any needed information -- apparently that was an incorrect assumption.

I am using Windows 8.1. This is a fairly new computer, and I am not nearly as familiar with Win 8 as with previous versions.

So, I dug around and found the "Open Blockable Items" on the AdBlock Plus menu under the Tools menu. I went to the page in question and turned on the Filter Source column. Nothing appears in that column.

When I click on the email address, I get a message from FireFox that says, "Firefox can't find the file at mailto:alarmclock@comfort-software.com?subject=Hot Alarm Clock."

I am wondering if this is a coding error on the part of the site in question.

OK, first, I must apologize for not supplying sufficient information. When I first signed up for this help forum, I was asked to download a program that supplies system information. I ass-umed this meant that you all would be able to see any needed information -- apparently that was an incorrect assumption. I am using Windows 8.1. This is a fairly new computer, and I am not nearly as familiar with Win 8 as with previous versions. So, I dug around and found the "Open Blockable Items" on the AdBlock Plus menu under the Tools menu. I went to the page in question and turned on the Filter Source column. Nothing appears in that column. When I click on the email address, I get a message from FireFox that says, "Firefox can't find the file at mailto:alarmclock@comfort-software.com?subject=Hot Alarm Clock." I am wondering if this is a coding error on the part of the site in question.
jscher2000
  • Top 10 Contributor
8784 solutions 71841 answers

Chosen Solution

"Can't find the file" is an unusual message for a mailto: URL. Could you look in the about:config preferences editor and see whether you have any non-default settings relating to the mailto: protocol? Here's what I mean:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste mailto and pause while the list is filtered

(3) If any lines are bolded and "user set" could you copy them (right-click > copy to get both the preference name and value) and paste them into a reply? Or save the information someone and then right-click > reset to see whether that makes any difference.


It's also possible that the file which stores your downloading handling preferences (most of what you see in Options > Applications) has become corrupted. The usual workaround for that is to rename the file and let Firefox regenerate it.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Then start up Firefox.

As the default mail client on your system, Outlook should still be the default mailto method. However, you might need to update some other preferences (e.g., PDF) if you have modified them.

"Can't find the file" is an unusual message for a mailto: URL. Could you look in the about:config preferences editor and see whether you have any non-default settings relating to the mailto: protocol? Here's what I mean: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''mailto''' and pause while the list is filtered (3) If any lines are bolded and "user set" could you copy them (right-click > copy to get both the preference name and value) and paste them into a reply? Or save the information someone and then right-click > reset to see whether that makes any difference. ---- It's also possible that the file which stores your downloading handling preferences (most of what you see in Options > Applications) has become corrupted. The usual workaround for that is to rename the file and let Firefox regenerate it. Open your current Firefox settings (AKA Firefox profile) folder using Help > Troubleshooting Information > "Show Folder" button Leaving that window open, switch back to Firefox and Exit Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old Then start up Firefox. As the default mail client on your system, Outlook should still be the default mailto method. However, you might need to update some other preferences (e.g., PDF) if you have modified them.

Question owner

When I click on Help, I see "Troubleshooting Information". When I click on that, it opens a web page with several bits of information. At the top right is a button that says, "Reset Firefox". I do not see a "Show Folders" button. Should I Reset Firefox?

When I click on Help, I see "Troubleshooting Information". When I click on that, it opens a web page with several bits of information. At the top right is a button that says, "Reset Firefox". I do not see a "Show Folders" button. Should I Reset Firefox?
Gingerbread Man 403 solutions 1537 answers

Helpful Reply

martyr6623 wrote:

I do not see a "Show Folders" button.

It's in the middle of the "Application Basics" section.

''martyr6623 wrote:'' I do not see a "Show Folders" button. It's in the middle of the "Application Basics" section. * [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]]

Question owner

YAY! That fixed it! Now I can contact the people at Comfort Software (and others) by simply clicking on the email address! Not sure I understood this, but it now works, and I'm a happy camper. Thanks to all for your patience and knowledge, especially jscher2000 and Gingerbread Man.

Marty

YAY! That fixed it! Now I can contact the people at Comfort Software (and others) by simply clicking on the email address! Not sure I understood this, but it now works, and I'm a happy camper. Thanks to all for your patience and knowledge, especially jscher2000 and Gingerbread Man. Marty