Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot install Firefox on Mac 10.5.8 PowerPC G5, Icon crossed over

  • 1 reply
  • 70 have this problem
  • 4000 views
  • Last reply by SafeBrowser

more options

I had FF running fully OK, but then tried to upgrade to FF9. After downloading the FFicon was crossed over, an a dialogbox said that my system did not support this version. So I threw this away and downloaded version 6, but this still has the crossed over thing, and won't open. How can I get a version of Firefox running on my Mac? Everything else works perfectly.

Chosen solution

You posted with an Intel Mac, so you must have another that is a PPC Mac. Correct?

Beginning with Firefox 4, Macs must have an Intel x86 processor (G5 is a PPC Mac) and OSX 10.5 or higher.

The good news is that Firefox 3.6.x still supports OSX 10.4 and Macs with the PPC Mac architecture. The bad news is that support for the Firefox 3.6.x series is likely to end in the first quarter of 2012.

You can try the third-party product TenFourFox that supports PPC Macs with OSX 10.4.11 and OSX 10.5.8. Firefox 9 version of TenFourFox is available. The product is based on Firefox released versions. All support is provided by the developer, not by this site:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Read this answer in context 👍 6

All Replies (1)

more options

Chosen Solution

You posted with an Intel Mac, so you must have another that is a PPC Mac. Correct?

Beginning with Firefox 4, Macs must have an Intel x86 processor (G5 is a PPC Mac) and OSX 10.5 or higher.

The good news is that Firefox 3.6.x still supports OSX 10.4 and Macs with the PPC Mac architecture. The bad news is that support for the Firefox 3.6.x series is likely to end in the first quarter of 2012.

You can try the third-party product TenFourFox that supports PPC Macs with OSX 10.4.11 and OSX 10.5.8. Firefox 9 version of TenFourFox is available. The product is based on Firefox released versions. All support is provided by the developer, not by this site:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Modified by SafeBrowser