Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF 4.0 does not work with Mac OS 10.5 unless Mac is intel based

  • 1 reply
  • 14 have this problem
  • 3 views
  • Last reply by TonyE

more options

I have a non-intel Mac OS 10.5 with FF 3.6.15 and cannot upgrade to FF 3.6.16 (FF4.0) because it is not intel. What to do (besides a new computer which will be months away)? Thanks for your help.

Photo

Chosen solution

There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox

Read this answer in context 👍 3

All Replies (1)

more options

Chosen Solution

There is a third party version of Firefox 4 that runs on OS X 10.4/10.5 and PPC Macs, for details see http://www.floodgap.com/software/tenfourfox