X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

FF always opens in 2nd monitor

Posted

I have dual monitors and occasionally set my 2nd monitor as the primary when testing software. On reverting back to use my 1st monitor as primary (using display settings) I find FF disregards the changed setting and always opens on the second monitor. Reboot does not resolve the problem. All other apps open in primary.

Any way to resolve this?

I have dual monitors and occasionally set my 2nd monitor as the primary when testing software. On reverting back to use my 1st monitor as primary (using display settings) I find FF disregards the changed setting and always opens on the second monitor. Reboot does not resolve the problem. All other apps open in primary. Any way to resolve this?

Chosen solution

If Firefox is maximized then make the window smaller and drag that window over to the correct monitor and close Firefox to save that setting.

After restarting you can maximize again.

Read this answer in context 4

Additional System Details

This happened

Every time Firefox opened

This started when...

I rest display settings as described above

Installed Plug-ins

  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.732
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Image Control Plugin for viewing images on Ancestry.com. Version 1.0.0.1
  • np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape
  • EntriqVersionCheck
  • Download Manager Plugin
  • Shockwave Flash 10.1 r82
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.11) Gecko/20100701 Firefox/3.5.11 (.NET CLR 3.5.30729)

More Information

Morbus 135 solutions 2340 answers

Helpful Reply

Maybe it was fixed in newer versions of Firefox? You are using Firefox 3.5.

If you see that Firefox 3.6 has the same problem, read this and, if you see it's a bug with Firefox, file a bug at bugzilla, if it hasn't been filed before.

Maybe it was fixed in newer versions of Firefox? You are using Firefox 3.5. If you see that Firefox 3.6 has the same problem, read [https://support.mozilla.com/en-us/kb/basic+troubleshooting this] and, if you see it's a bug with Firefox, file a bug at [https://bugzilla.mozilla.org bugzilla], if it hasn't been filed before.
cor-el
  • Top 10 Contributor
  • Moderator
17859 solutions 161600 answers

Chosen Solution

If Firefox is maximized then make the window smaller and drag that window over to the correct monitor and close Firefox to save that setting.

After restarting you can maximize again.

If Firefox is maximized then make the window smaller and drag that window over to the correct monitor and close Firefox to save that setting. After restarting you can maximize again.

Question owner

Thanks cor-el, that solved it. Assume it is stored in profile.

Thanks cor-el, that solved it. Assume it is stored in profile.
twade1 0 solutions 1 answers

I have ther same issue and I have tried several, (try hundreds) of times to get it to go back to the original monitor and I have arrived on the conclusion that it just won't unless I unplug the second monitor and relaunch the app several times. I'm running a MacBook Pro with a 2.4 GHz Intel and mac OsX 10.6.5. I finally deleted Firefox and started over. Either fix it or lose me as a user. I'm done!

I have ther same issue and I have tried several, (try hundreds) of times to get it to go back to the original monitor and I have arrived on the conclusion that it just won't unless I unplug the second monitor and relaunch the app several times. I'm running a MacBook Pro with a 2.4 GHz Intel and mac OsX 10.6.5. I finally deleted Firefox and started over. Either fix it or lose me as a user. I'm done!
cor-el
  • Top 10 Contributor
  • Moderator
17859 solutions 161600 answers

This can be a problem with the file localstore.rdf in the Profile Folder.

Delete localstore.rdf or rename the file to localstore.rdf.sav in the Profile Folder to test if the file is corrupted.

See http://kb.mozillazine.org/Corrupt_localstore.rdf

This can be a problem with the file [http://kb.mozillazine.org/localstore.rdf localstore.rdf] in the [http://kb.mozillazine.org/Profile_folder_-_Firefox Profile Folder]. Delete localstore.rdf or rename the file to localstore.rdf.sav in the [http://kb.mozillazine.org/Profile_folder_-_Firefox Profile Folder] to test if the file is corrupted. See http://kb.mozillazine.org/Corrupt_localstore.rdf

Modified by cor-el