Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fresh Firefox install on Mac has no spell checking and no spelling/language items in right-click menu

  • 3 replies
  • 0 have this problem
  • 27 views
  • Last reply by timday1

more options

I've long had a Mac with a Firefox install. For as a long as I remember, the spellchecking (when entering text in textedit boxes) has never worked. But that's been ok because I only had the Mac for an xcode/iOS development job, and did most of my web browsing (using Firefox) elsewhere (Linux machines running Debian) and spell checking always worked fine there.

However stupid typos slipping through when I was using Firefox on the Mac eventually led to me wanting to get to the bottom of this.

It wasn't so much simply that the spellchecking doesn't operate... it's that the right-click menu is strangely devoid of anything but

 Undo Redo | Cut Copy Paste Delete Select All | Inspect | Block Element

(that last one from uBlock Origin plugin). NB there were no "Language" or "Check spelling" items there at all, which are the first things I'd look for on my other machines if spellchecking went awry.

I tied all the usual diagnostics/fixes: remove plugins (uBlock Origin is the only one I ever use), new profile, "refresh firefox"... none of it made any difference. I went through a ton of items on this site by nothing seemed to be quite the same problem and the suggested solutions didn't work for me.

I eventually decided reinstalling from scratch was the only option: binned Applications/Firefox and Library/Application Support/Firefox and did a fresh install of the 119.0 download. But no joy. I'm typing this in it right now and there's no spellchecking happening and the right-click menu is just the same as it was before: devoid of "Check spelling" or "Language" items.

The Firefox settings "Language" section does show "English (GB)" selected, and "Check your spelling as you type" enabled. But spell-checking certainly isn't happening in any text box I'm using.

(I've attached a screenshot of what the right-click menu does look like, when I bring it up in this text box I'm typing in now.)

I'm not a "Mac native" so I'm not sure what else on the system could be messing things up. In the system settings the Trackpad is set to "Click with 2 fingers" and certainly brings up a menu in Firefox text edit boxes... but it seems odd that the Language/Spelling-related items I'd expect to see are missing from it.

I'm totally baffled. Any help much appreciated.

I've long had a Mac with a Firefox install. For as a long as I remember, the spellchecking (when entering text in textedit boxes) has never worked. But that's been ok because I only had the Mac for an xcode/iOS development job, and did most of my web browsing (using Firefox) elsewhere (Linux machines running Debian) and spell checking always worked fine there. However stupid typos slipping through when I was using Firefox on the Mac eventually led to me wanting to get to the bottom of this. It wasn't so much simply that the spellchecking doesn't operate... it's that the right-click menu is strangely devoid of anything but Undo Redo | Cut Copy Paste Delete Select All | Inspect | Block Element (that last one from uBlock Origin plugin). '''NB''' there were no "Language" or "Check spelling" items there at all, which are the first things I'd look for on my other machines if spellchecking went awry. I tied all the usual diagnostics/fixes: remove plugins (uBlock Origin is the only one I ever use), new profile, "refresh firefox"... none of it made any difference. I went through a ton of items on this site by nothing seemed to be quite the same problem and the suggested solutions didn't work for me. I eventually decided reinstalling from scratch was the only option: binned Applications/Firefox and Library/Application Support/Firefox and did a fresh install of the 119.0 download. But no joy. I'm typing this in it right now and there's no spellchecking happening and the right-click menu is just the same as it was before: devoid of "Check spelling" or "Language" items. The Firefox settings "Language" section does show "English (GB)" selected, and "Check your spelling as you type" enabled. But spell-checking certainly isn't happening in any text box I'm using. (I've attached a screenshot of what the right-click menu does look like, when I bring it up in this text box I'm typing in now.) I'm not a "Mac native" so I'm not sure what else on the system could be messing things up. In the system settings the Trackpad is set to "Click with 2 fingers" and certainly brings up a menu in Firefox text edit boxes... but it seems odd that the Language/Spelling-related items I'd expect to see are missing from it. I'm totally baffled. Any help much appreciated.

Chosen solution

Install a Dictionary like this one.

Read this answer in context 👍 1

All Replies (3)

more options

Screenshot didn't seem to upload with the post above; here's a second attempt.

Helpful?

more options

Chosen Solution

Install a Dictionary like this one.

Helpful?

more options

(Re zeroknight's simple solution)

Thanks... that's strange... I thought I'd tried that before - but with the old install (and I think a different dictionary) - and it didn't seem to help then.

But anyway, a (ticked) Check Spelling and a "Languages >" item have now appeared in my right-click menu, and more importantly spelling errors are highlighted.

Seems a bit of a weakness that Firefox's own "Languages" settings don't somehow detect the lack of a dictionary and point out it's going to be an issue; I was assuming choosing a language and selecting "Check my spelling as I type" was sufficient.

Interestingly, looking at my Linux boxes where I just use the stock Debian stable firefox ESR releases I see I've never installed a dictionary there and spellchecking just works. However I see there's also a firefox-esr-l10n-en-gb "localization package" installed which has a recommended dependency on a hunspell-en-gb package and presumably that's what Debian's firefox is using.

But thanks again... quite glad it was something simple!

Modified by timday1

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.