Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I dont use google as my search and yet whenever i start typing g the search option is google

  • 7 replies
  • 1 has this problem
  • 22 views
  • Last reply by zeroknight

more options

I don't use google as my default search and yet whenever i start typing g or go or goo, etc. the search option automatically becomes a google search. I don't even have google as a search engine option in my settings. how do i get that to stop doing that.

I don't use google as my default search and yet whenever i start typing g or go or goo, etc. the search option automatically becomes a google search. I don't even have google as a search engine option in my settings. how do i get that to stop doing that.
Attached screenshots

All Replies (7)

more options

If you go to settings/search scroll down to search suggestions, you can deselect "provide search suggestions" If that is done IDK

Helpful?

more options

Do you have a Google shortcut on the Firefox Home page (about:newtab|about:home) ?

Helpful?

more options

The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, top sites, and search suggestions. You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Settings -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    Browsing history
    Bookmarks
    Open tabs
    Shortcuts
    Search engines

Helpful?

more options

Thanks Chris. I had already removed all other search engines, so nothing else even listed.

Thanks cor-el, I don't have a google shortcut.

I then unchecked all the firefox suggestions it did improve but not completely. If I now type googl it remains on my default search engine ... but the moment I complete typing google it reverts back to insisting on offering searching with google! Argh! It does say below "this time search with" offering me my default engine. I guess I have to be careful but the fact that google shows up at a is still a concern. I may have to clear history and cookies but really didn't want to have to do that. Thanks

Helpful?

more options

not solved as of yet.

Helpful?

more options

You need at least have a default search engine and have this selected on the "Settings -> Search" page and you can't remove/disable this default search engine.

You can disable searching via the location bar by setting keyword.enabled to false<\b> on the <b>about:config page.

Helpful?

more options

That's a domain autofill since you have visited Google sites in the past, it has nothing to do with your default search engine. You can disable autofill in the address bar by going to about:config and changing browser.urlbar.autoFill to false.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.