Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Websites loading e-x-t-r-e-m-e-l-y slow on version 101.0

  • 17 replies
  • 1 has this problem
  • 47 views
  • Last reply by Kymber

more options

Upgraded to version 101.0 after getting the pop-up prompt and now every site I visit is taking at least twice as long to load and display compared to yesterday. (Even this support site!)

It has to be something in this release and not my connection, because:

  • My mail client is completely unaffected and is behaving normally.
  • I tried accessing the sites that were loading/displaying slowest using Opera, and they loaded as fast as they had in Firefox previously.
  • Nothing else that uses my internet connection is working any differently than yesterday.

I also cleared the Firefox cache. No improvement.

It's not my add-ons because the only one I have installed is uBlock, which is recommended in various help articles here at the support site.

Nothing in the knowledge base has proven helpful.

Is anyone else having this problem? Is there some tweak I need to make in about:config to fix this? Or is this another case of "wait until the next release", yet again???

Upgraded to version 101.0 after getting the pop-up prompt and now '''every''' site I visit is taking at least twice as long to load and display compared to yesterday. (Even this support site!) It has to be something in this release and '''not''' my connection, because: * My mail client is completely unaffected and is behaving normally. * I tried accessing the sites that were loading/displaying slowest using Opera, and they loaded as fast as they had in Firefox previously. * Nothing else that uses my internet connection is working any differently than yesterday. I also cleared the Firefox cache. No improvement. It's not my add-ons because the only one I have installed is uBlock, which is recommended in various help articles here at the support site. Nothing in the knowledge base has proven helpful. Is anyone else having this problem? Is there some tweak I need to make in about:config to fix this? Or is this another case of "wait until the next release", yet again???

Chosen solution

I am happy to report that I did some more brainstorming and tried looking at CPU usage in Task Manager. Sure enough, every time I went to a new URL Firefox's CPU usage went to over 90% of CPU.

Quick Google search on "reduce CPU usage Firefox" and -- long story short -- unchecking both "use recommended settings" and "use hardware acceleration when available" under Performance in Settings solved the problem.

I would like to thank everyone who tried to help and I hope I didn't drive you all crazy.

Read this answer in context 👍 0

All Replies (17)

more options

If you feel your issue is purely related to this build and nothing else... You can change your release channel "app.update.channel" in about:config to beta, developer or nightly to use a newer test release. I have never had stability issues in developer or beta releases.

"release

All final releases. esr

Special release channel for extended support releases. beta

Betas / release candidates (up to Gecko 2.0 also final releases). aurora

Pre-beta nightly

All nightly builds. default

No updates are offered. "

Helpful?

more options

While that might solve problems for some users, I fear that getting beta releases would potentially make my situation worse, since Firefox is well-known for not having the ability to rollback to a previous version without destroying profile information, etc. The last thing I want or need is to have a problem with a beta release and then be stuck with it until a "real" release (hopefully) resolved the issue.

I think that, going forward, I am not going to click "yes" to the "new version" pop-up unless I have had problems with the current release. Again, absent a miracle and a non-destructive rollback process is developed, I need to fix the problem that version 100.0 created here.

Just thinking about the probability that I will be stuck with slow loading of every site I visit until some future release resolves the issue makes me incredibly angry, but I am going to try not to vent.

Again, is there something I can tweak in about:config that may be causing this slowness?

Helpful?

more options

I have no issues with this release. Nor any previous release. The latest update I had was a security mitigation. Normally these come with some performance cost. You want to always have updates on, for security mitigations.

However if you wish to update less frequently you can install ESR. But it generally has lower performance, as it doesn't have cutting edge changes.

Additional things you can do for performance is noscript. [But without script, there will be way more breakage in sites], you can clear and update your ublock origin cache, you can use localcdn to pull more resources locally, rather than from the CDNs. All of these also improve privacy and security.

Personally I use brave mostly now-a-days because it by far has the best features and performance on android for me. Also on Desktop I mostly use Librewolf, but the anti-fingerprinting can break some sites, also some DRM like spotify doesn't work with firefox forks.

Modified by Chaython

Helpful?

more options

I'm glad that you have no issues. But I do, and your suggestions aren't helping me. But thanks anyway.

Helpful?

more options

Hi

You should not really need to move version to make this better.

So that we can look into this further for you, please can you provide some examples of websites that are not opening so swiftly in Firefox 101.

Please can you also list any add-ons that you have installed in Firefox.

Helpful?

more options

Hi Paul,

The only add-on I have installed is uBlock Origin.

Everything is loading noticeably slower, but the ones I particularly noticed over the past 24 hours are:

Los Angeles Times - http://www.latimes.com/ HSBC - https://www.us.hsbc.com/ US Bank - https://onlinebanking.usbank.com/ GoComics - http://www.gocomics.com/ Providence Health - https://mychartor.providence.org/

And ... this site! - https://support.mozilla.org/

I should note that the slowness is only with the page loading. Once it finally loads and displays, scrolling, accessing text boxes like this one, etc. all work perfectly with no lag time.

Thank you for looking into it. I hope you can come up with some configuration suggestions that will help.

Helpful?

more options

Can you open a command prompt and run the below command. nslookup latimes.com Server: 1.1.1.1 <--- My DNS sever Address: 1.1.1.1#53

Non-authoritative answer: Name: latimes.com Address: 76.223.88.230 Name: latimes.com Address: 13.248.222.133

Post the results here.

Modified by jonzn4SUSE

Helpful?

more options

I see what you are getting at, as I am familiar with DNS lookups. My result was similar to yours:

DNS request timed out.

   timeout was 2 seconds.

Server: UnKnown Address: 68.94.156.12

DNS request timed out.

   timeout was 2 seconds.

DNS request timed out.

   timeout was 2 seconds.

DNS request timed out.

   timeout was 2 seconds.

DNS request timed out.

   timeout was 2 seconds.
      • Request to UnKnown timed-out

But the site is still loading here, despite that DNS response.

I should point out -- again -- that through Thursday, before I installed the update from 100.0.2 to 101.0, none of these sites loaded as slowly as they do now, and every site is loading slower. So I do not believe that any DNS issue is to blame, because I was using the same nameservers both before and after the Firefox update.

Anticipating your next question, my DNS settings are, in order: 68.94.156.12 68.94.157.12 192.168.12.1 (Not that I believe any of that matters, as I have explained above.)

Helpful?

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


You can also check the Timings in the Network Monitor.

Helpful?

more options

Okay, let me say this again.

The odds of the internet connection suddenly going awry at the exact same time as the Firefox update are astronomical. My mail client is unaffected. Sites that now load like molasses in Firefox load at their previous speed in Opera. Nothing else on my computer that uses the network connection is operating any differently than was the case on Thursday.

With all due respect to those of you who are trying to help, you've gone down the wrong fork in the road and I would like to refocus on what has apparently changed in Firefox to cause this behavior.

(And every time I reload this page to read another post that isn't really helping, I have to w-a-i-t for it to r-e-l-o-a-d, which just annoys me further.)

Helpful?

more options

It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process.

See:

Helpful?

more options

Looking at your results, the dns did not provide results similar to mine. This explains the slowness. Just as a test, are you up for temporarily tweaking your dns? If not, then I want bother anymore. Also, have a look at this tool--> https://www.grc.com/dns/benchmark.htm These questions are in an effort to not just help your browser issue, but your system setup. Your results should've looked like this... see screenshot

Helpful?

more options

Kymber said

(And every time I reload this page to read another post that isn't really helping, I have to w-a-i-t for it to r-e-l-o-a-d, which just annoys me further.)

DNS

Helpful?

more options

I think we are sort of on the right track now.

Something with the update is causing Firefox 101 to access my internet connection (and by extension, the DNS) in some way that is different from version 100.

I have to reject all suggestions that it is the DNS themselves (or how my connection accesses them), because if that were the case Opera would not function normally. And to answer the excellent question above, I never "tweak" the DNS as I have never needed to. (BTW, Jon, I do know what a proper DNS lookup should look like, but thanks for the screenshot in case I didn't.) Given that Opera works fine, I'm not convinced that any such tweaking would help.

I did think of the firewall possibly being the issue, but I admit that all I did was look up the permissions and when I saw Firefox was already checked I did not look further. I'm 99.9% sure it's not the anti-malware software as I am still using Windows 7 Professional and Microsoft Security Essentials (since they are continuing to provide daily updates to that even though they no longer support the underlying OS ... talk about your conflicts of interest!). That idea is certainly worth trying and can't hurt, since I know how to manually add it back if Windows Firewall won't do it by answering Firefox's permission request.

Helpful?

more options

Later...

Helpful?

more options

Doesn't appear to be Windows Firewall either. Undid Firefox permissions, rebooted, added Firefox permissions back in when nothing would load, rebooted again, internet access normal but still taking forever.

I got to thinking that maybe because my DNS settings are in the router and the PC is set to obtain the DNS IPs automatically that I should check the router configuration. And something worth mentioning happened. When I went to the router's internal IP of 192.168.1.1 in Firefox, it was as slow to load as an external site. And Opera, yet again, loaded the router setup page near-instantaneously. (For the record: The PC running both browsers is using an Ethernet connection, not wi-fi.) So it's not the DNS or anything else "out there on the Net" because I should have gotten an instant load of the router.

There is definitely something about Firefox 101 that causes it to access the router (the internet connection, from its point of view) differently than did Firefox 100 and its predecessors. What that is, I have no idea, because nothing has changed in the OS settings. I am more convinced than ever that there is a setting in about:config that was set in a way in version 100 which prevented the lag, and which somehow got changed in version 101, introducing the lag.

Here is what I am thinking. All of you who have tried so hard to help are likely running Windows 10 or 11, whereas I am still on Windows 7 Professional (and no, upgrading to 10 is not an option here). So if whatever changed in the new Firefox release only affects operation under Win 7, none of you are able to replicate my problem.

So I am back to my original question: What in Firefox 101's about:config needs to be changed to make it behave the same way as Firefox 100 did?

Modified by Kymber

Helpful?

more options

Chosen Solution

I am happy to report that I did some more brainstorming and tried looking at CPU usage in Task Manager. Sure enough, every time I went to a new URL Firefox's CPU usage went to over 90% of CPU.

Quick Google search on "reduce CPU usage Firefox" and -- long story short -- unchecking both "use recommended settings" and "use hardware acceleration when available" under Performance in Settings solved the problem.

I would like to thank everyone who tried to help and I hope I didn't drive you all crazy.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.