On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 97.0 ignores the Settings/Applications for jnlp files and only offers to save to a file

  • 10 replies
  • 2 have this problem
  • 2393 views
  • Last reply by Charly

more options

In Settings/Applications, have "JNLP file" set to "Use Java(TM) Web Launcher (default)". This is used in Oracle's Agile to view documents. In previous versions of Firefox when selected, the file would open using Java to display the document from Agile. As of Firefox 97, now only "Save File" or "Cancel" options are offered. What happened that this functionality has been removed?

In Settings/Applications, have "JNLP file" set to "Use Java(TM) Web Launcher (default)". This is used in Oracle's Agile to view documents. In previous versions of Firefox when selected, the file would open using Java to display the document from Agile. As of Firefox 97, now only "Save File" or "Cancel" options are offered. What happened that this functionality has been removed?

Chosen solution

Hi Gary, I don't have an explanation about IE, but for Firefox, do you have "Use other..." in the box on the Settings page? Then you can manually add the new handler by drilling down in the Program Files folder through Java\<version>\bin\javaws.exe. This screenshot is for a bug about file naming, so the notes on the left aren't directly applicable to launching JNLP files, but this is what you could see after adding that and setting it as the default:

Read this answer in context 👍 0

All Replies (10)

more options

Is this JNLP file send by the server with the correct content type (application/x-java-jnlp-file) ?

more options

I am having the same issue. The options of Save File and Always ask are above the line. The option I want to use is: Use JAVA(TM) Web Launcher (default). I can select it, but when I try to go back and use the function the option is changed back to Always ask.

This worked just fine prior to Firefox 97.0.

more options

In the Firefox 97 downloads list -- the one that drops from the toolbar button -- could you try this:

right-click the download > Always Open in System Viewer

I don't know whether it will work because JNLP files have at times been considered similar to an executable, and EXE files can't be auto-launched.

more options

Thanks for the suggestion. Unfortunately this option does not appear for me. Each time I launch the application a new jnlp file is downloaded with app specific information.

The option I have is open and then I have to choose the the application to use to launch the file. In chrome it downloads the file and when I click it automatically executes it. I have the file associated at the windows level to execute with the correct program.

Something broke this functionality in this release.

Modified by djuncews

more options

Could you take a look at this reply in a similar thread and see whether it is relevant to your system: https://support.mozilla.org/en-US/questions/1368109#answer-1484095

more options

Thanks a lot! It was pointing to a generic one and not the one with the Icon. I did not even notice that. Once I selected the Icon version from the program list it worked.

more options

Been away for a while fighting other fires. Good suggestions, except that I do not have the Java Web Start Launcher as an option (it was there pre-97) and there is no "Choose App" option.

So, I guess I'll just have to live with the great browser regression... honestly, if work didn't require I use Oracle, I wouldn't really worry about this. But it is odd that this launching really only works in Internet Explorer -- it doesn't in Edge, Chrome, or Firefox.

more options

Chosen Solution

Hi Gary, I don't have an explanation about IE, but for Firefox, do you have "Use other..." in the box on the Settings page? Then you can manually add the new handler by drilling down in the Program Files folder through Java\<version>\bin\javaws.exe. This screenshot is for a bug about file naming, so the notes on the left aren't directly applicable to launching JNLP files, but this is what you could see after adding that and setting it as the default:

more options

Thanks. I was looking at the wrong selector (please don't ask which I was looking at, it's too embarrassing). It's working now.

Now I'm wondering whether I used the "Use other..." option earlier and that is what was "lost" with the update. This is the downside of my not keeping copious notes.

more options

Gary said

Thanks. I was looking at the wrong selector (please don't ask which I was looking at, it's too embarrassing). It's working now. Now I'm wondering whether I used the "Use other..." option earlier and that is what was "lost" with the update. This is the downside of my not keeping copious notes.

You may have had the right option selected earlier, when it did not work. I found that the 97.0.1 update indeed set the JNLP file association to "Always Ask". I reset it to "Use Java(TM) Platform SE Binary" and now Firefox hands over the JNLP file to Web Start as before, i.e. w/o needing to save the JNLP in the download folder and starting it from there as a workaround. However, the Java app still fails to start.

Modified by michaelv@corp.ptd.net FF acct