Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

make Firefox my default browser

more options

in the instructions to make Firefox my default browser it says that when you click on the Make Default button "The Set Default Programs window will open."

that isn't what happens.

instead I get a window headed: "Set Associations for a Program". this asks me to make choices about filetypes I know nothing about. four of them are pre-selected, so I click Save at the bottom right but this does not make Firefox my default browser.

what am I doing wrong?

thank you

in the instructions to make Firefox my default browser it says that when you click on the Make Default button "The Set Default Programs window will open." that isn't what happens. instead I get a window headed: "Set Associations for a Program". this asks me to make choices about filetypes I know nothing about. four of them are pre-selected, so I click Save at the bottom right but this does not make Firefox my default browser. what am I doing wrong? thank you

All Replies (3)

more options

Hmm, maybe something change in Windows 8.1 that no one noticed so the article needs a further update (or Firefox needs to summon a different dialog).

This PC Magazine article has a section for Windows 8.1: https://www.pcmag.com/how-to/how-to-change-your-default-web-browser

Helpful?

more options

thank you for engaging,

the PC Mag article you linked to shows how to make your operating system consider Firefox as your default web browser, and mine already does. but the settings screen in Firefox itself displays the message, "Firefox is not your default browser."

thank you,

Helpful?

more options

Oh, well, it sounds like Firefox must be mistaken if external http: and https: links are opening in Firefox already.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.