Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Font display problem after goingn to version 90.x

  • 1 reply
  • 1 has this problem
  • 3 views
  • Last reply by FredMcD

more options

This has happened on several of my computers. Upgrading from some version of FF80 to some version of FF90 results in gibberish text.

What Mac OS system fonts does Firefox require? I somehow got this fixed on one system, but many monthds ago, so I don't know what actually worked. I have cleaned font caches, etc. but cannot get it fixed on the latest so far. Settings are Latin, normal fonts like Georgia or Verdana.

Attached screenshots

All Replies (1)

more options

This looks like a problem with fonts.

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.