Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After upgrade to firefox 90, I am not able to login in some HTTPS pages with SSO certificate

  • 1 reply
  • 1 has this problem
  • 101 views
  • Last reply by aronjan

more options

After upgrade to firefox 90, I am not able to login in some pages. I use sso with certificate on these pages and Firefox just show this error message: "Error code: SSL_ERROR_CERTIFICATE_UNKNOWN_ALERT".

I also not able to downgrade back to old version because firefox does not want to open with alert that I use older version.

I use firefox on MacOS Mojave and after upgrade Firefox tried to access to my keychain for certificate, but without success. I do not have set my firefox to use my keychain, so I do not know why it tried to access keychain.

So I have to migrade to chrome :(. I wait for a while if there is solution before I delete firefox.

After upgrade to firefox 90, I am not able to login in some pages. I use sso with certificate on these pages and Firefox just show this error message: "Error code: SSL_ERROR_CERTIFICATE_UNKNOWN_ALERT". I also not able to downgrade back to old version because firefox does not want to open with alert that I use older version. I use firefox on MacOS Mojave and after upgrade Firefox tried to access to my keychain for certificate, but without success. I do not have set my firefox to use my keychain, so I do not know why it tried to access keychain. So I have to migrade to chrome :(. I wait for a while if there is solution before I delete firefox.

Chosen solution

Issue was in using MacOS keychain. I had to unload OS security module in Device manager. Settings -> Privacy & Security -> Certificates -> Security Devices. I also set in "about:config" -> security.osclientcerts.autoload - false.

Then Firefox use its internal store for my personal certificates and everything works well.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Issue was in using MacOS keychain. I had to unload OS security module in Device manager. Settings -> Privacy & Security -> Certificates -> Security Devices. I also set in "about:config" -> security.osclientcerts.autoload - false.

Then Firefox use its internal store for my personal certificates and everything works well.