Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

prevent firefox from showing the address bar in fullscreen mode

  • 2 replies
  • 1 has this problem
  • 22 views
  • Last reply by mishash1998

more options

Hello,

After recent Firefox update ( ver. 85.0 - 01.2021 / 64-bit, Windows )

code:

  1. fullscr-toggler {display:none!important;}

in file: "userChrome.css"

that was effectively preventing firefox from showing the address bar in fullscreen mode seems stopped working.

Does anyone know workaround solution?

Thanks!

Chosen solution

#fullscr-toggler has been moved to HTML namespace, so you need to update the code in userChrome.css

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

*|div#fullscr-toggler {display:none!important;}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

#fullscr-toggler has been moved to HTML namespace, so you need to update the code in userChrome.css

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

*|div#fullscr-toggler {display:none!important;}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Helpful?

more options

Yep, that worked. Thank you! :)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.