Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

other - update

  • 3 replies
  • 1 has this problem
  • 4 views
  • Last reply by FredMcD

more options

The latest update has resulted in an error message: Platform version 84.0.1 is incompatible min version >= 84.0.1 and max version <= 84.0.1 Can this computer no longer use Firefox?

Chosen solution

What's your computer system?

Try reinstalling the browser. Download Firefox For All languages And Systems {web link}

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

What's your computer system?

Try reinstalling the browser. Download Firefox For All languages And Systems {web link}

Helpful?

more options

Thank you very much, firefox appears to be working properly now. Am very grateful for your help

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.