X
Tap here to go to the mobile version of the site.

Support Forum

how do i turn off the popup urlbar in the latest nightly build?

Posted

when clicking in the urlbar it popups, how do i turn this off?

when clicking in the urlbar it popups, how do i turn this off?
Attached screenshots

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5348 solutions 23617 answers

hello, this is a new feature, but work in progress and needing more polish still. at the moment it can be turned off through the browser.urlbar.megabar preference in about:config but this pref might go away eventually when the new design is "finished".

hello, this is a new feature, but work in progress and needing more polish still. at the moment it can be turned off through the ''browser.urlbar.megabar'' preference in about:config but this pref might go away eventually when the new design is "finished".

Question owner

thanks a lot, thanks to philipp I turned off the pop-up urlbar feature, I just hope the compact ui will be still available in the new design.

thanks a lot, thanks to philipp I turned off the pop-up urlbar feature, I just hope the compact ui will be still available in the new design.
jonpal 0 solutions 19 answers

browser.urlbar.megabar doesn't exist in about:config

browser.urlbar.megabar doesn't exist in about:config

Question owner

try browser.urlbar.update1

try browser.urlbar.update1
Glynn 0 solutions 1 answers

I'm had the same issue after updating Firefox Dev edition and setting browser.urlbar.update1 to false didn't fix it.

Took me a while to realise that you have to restart the browser after changing the variable.

I'm had the same issue after updating Firefox Dev edition and setting browser.urlbar.update1 to false didn't fix it. Took me a while to realise that you have to restart the browser after changing the variable.

Modified by Glynn

Question owner

set browser.urlbar.update1 to false and then close and reopen FF

set browser.urlbar.update1 to false and then close and reopen FF
jonpal 0 solutions 19 answers

Don't have browser.urlbar.update1 either. I have version 62.0 . I fixed the problem by going back to the earlier version.

Don't have browser.urlbar.update1 either. I have version 62.0 . I fixed the problem by going back to the earlier version.
Lars-Erik 0 solutions 4 answers

If you like the new style URL-bar except for the increase in size when active you can add this code to the "userCrome.css" (in the "Chrome" folder in the active Firefox profile). It makes the "popup" URL-bar look like normal (not selected) when active (sets the size == the inactive URL-bar):

/* Make URL-bar look like before by setting the "expanded" URL-bar position/size == the "normal" URL-bar */
#urlbar[breakout-extend]{top:calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2)!important;left:calc((var(--urlbar-toolbar-width) - var(--urlbar-width)) / 2)!important;width:100%!important}
#urlbar[breakout-extend] #urlbar-input-container{height:var(--urlbar-height)!important;padding:0px!important}
.urlbarView{margin:0px!important;width:100%!important}
.urlbarView-row{padding:0px!important}
If you like the new style URL-bar except for the increase in size when active you can add this code to the "userCrome.css" (in the "Chrome" folder in the active Firefox profile). It makes the "popup" URL-bar look like normal (not selected) when active (sets the size == the inactive URL-bar): /* Make URL-bar look like before by setting the "expanded" URL-bar position/size == the "normal" URL-bar */ #urlbar[breakout-extend]{top:calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2)!important;left:calc((var(--urlbar-toolbar-width) - var(--urlbar-width)) / 2)!important;width:100%!important} #urlbar[breakout-extend] #urlbar-input-container{height:var(--urlbar-height)!important;padding:0px!important} .urlbarView{margin:0px!important;width:100%!important} .urlbarView-row{padding:0px!important}

Modified by Lars-Erik