X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 68 Mac, can't start w/profile from command line

Posted

Long-time Firefox user with several profiles defined via ProfileManager. Have several AppleScript apps that start firefox-bin with "-P profilename" to start Firefox with the named profile (see <https://spf13.com/post/managing-multiple-firefox-profiles-in-os-x/> for a description of how this is set up). They no longer work. Starting the profiles from a shell prompt also does not seem to work, at best it opens a new Firefox window in each currently-open Firefox profile. Have tried -P with profile name (profile name quoted), --profile with path to profile's "Root Directory", --profile with path to profile's "Local Directory", pathnames quoted if necessary; all of the above with --new-instance. No joy. What am I missing?

Long-time Firefox user with several profiles defined via ProfileManager. Have several AppleScript apps that start firefox-bin with "-P profilename" to start Firefox with the named profile (see <https://spf13.com/post/managing-multiple-firefox-profiles-in-os-x/> for a description of how this is set up). They no longer work. Starting the profiles from a shell prompt also does not seem to work, at best it opens a new Firefox window in each currently-open Firefox profile. Have tried -P with profile name (profile name quoted), --profile with path to profile's "Root Directory", --profile with path to profile's "Local Directory", pathnames quoted if necessary; all of the above with --new-instance. No joy. What am I missing?

Chosen solution

There were a few changes here recently, you might want to try `firefox -P profile -no-remote`

Read this answer in context 2
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

Question owner

Additional information: One way profiles do work: about:profiles, and "Launch profile in new browser". So I think my profile definitions are in order, it's getting them going via firefox-bin command-line arguments that is broken.

Additional information: One way profiles do work: about:profiles, and "Launch profile in new browser". So I think my profile definitions are in order, it's getting them going via firefox-bin command-line arguments that is broken.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157254 answers

Does it work if you use firefox -P "profile" instead of firefox-bin ?

Does it work if you use firefox -P "profile" instead of firefox-bin ?
Was this helpful to you?
Quote

Question owner

It works the same way: I get a new window for each in-use profile.

It works the same way: I get a new window for each in-use profile.
Was this helpful to you?
Quote

Question owner

Running this from the AppleScript again, I am reminded that it put up a dialog, "The command exited with a non-zero status", and that if I echo $? after trying the same command from a shell prompt the status is 1. (I also get the new window open under the in-use profile, as opposed to the profile I wanted to launch).

Running this from the AppleScript again, I am reminded that it put up a dialog, "The command exited with a non-zero status", and that if I echo $? after trying the same command from a shell prompt the status is 1. (I also get the new window open under the in-use profile, as opposed to the profile I wanted to launch).
Was this helpful to you?
Quote
Standard8 35 solutions 190 answers

Chosen Solution

There were a few changes here recently, you might want to try `firefox -P profile -no-remote`

There were a few changes here recently, you might want to try `firefox -P profile -no-remote`
Was this helpful to you? 2
Quote

Question owner

That seems to work well enough to get the AppleScript method going again. Thanks! (Might be nice if it were in the usage message.)

That seems to work well enough to get the AppleScript method going again. Thanks! (Might be nice if it were in the usage message.)
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.