X
Tap here to go to the mobile version of the site.

Support Forum

Disable search bar(blue) when typing in address bar

Posted

I have been through numerous support pages and nothing helps, did a few about config changes as listed but still it appears. One post said it has always been there, I can assure you I never had this before and do not want it now. Is there any way to stop it please as I hate it even though just clicking removes it, I would prefer not to have it in the first place

I have been through numerous support pages and nothing helps, did a few about config changes as listed but still it appears. One post said it has always been there, I can assure you I never had this before and do not want it now. Is there any way to stop it please as I hate it even though just clicking removes it, I would prefer not to have it in the first place

Chosen solution

neilbowls said

I did look some more since my last post and found reference to this from about a year ago. This worked browser.urlab.maxRichResults turn value from 10 to 0

The preference "browser.urlbar.maxRichResults" has nothing to do with getting rid of the blue bar you started this thread about; hence I didn't look for a way for you to get rid of the search
results ......

A little miscommunication ......

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

jonpal said

But the larger question, why did firefox alter my preferences when I upgraded to 68.0.1? The pop up blue bar is very distracting.

What preferences were altered?

Although not visible to the human eye, Firefox 68 contains all new structural code for the address bar drop-down. If you want to keep using the old code, there is a preference for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.quantumbar preference to switch the value from true to false

That shouldn't make much difference unless you were modifying the drop-down using userChrome.css, in which case it will allow your old rules to keep working.

''jonpal [[#answer-1239572|said]]'' <blockquote> But the larger question, why did firefox alter my preferences when I upgraded to 68.0.1? The pop up blue bar is very distracting. </blockquote> What preferences were altered? Although not visible to the human eye, Firefox 68 contains all new structural code for the address bar drop-down. If you want to keep using the old code, there is a preference for that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.quantumbar''' preference to switch the value from true to false That shouldn't make much difference unless you were modifying the drop-down using userChrome.css, in which case it will allow your old rules to keep working.
jonpal 0 solutions 18 answers

jscher2000 said

Hi jonpal, each person seems to be looking for something a bit different. Could you describe more exactly how you want the drop-down to work? The blue bar informs you of what Firefox would do if you submit the contents of the address bar right now (either by pressing Enter or clicking the Go button). The bar can be hidden using a custom style rule, but when the bar is hidden the highlight won't move to the next matching item automatically. With that in mind, would you want to:
  • Hide just the blue bar, keep the rest of the drop-down
  • Hide the entire drop-down, blue bar and all

I don't want any drop down at all. Very distracting to my old brain. This seems to work: https://support.mozilla.org/en-US/questions/1251014 On the 'about:config' page set the value of the preference keyword.enabled to false (and then close and restart Firefox). In case you don't want anything to appear under the address bar : Type in the search bar browser.urlbar. Look for the preference : browser.urlbar.maxRichResults And set its value to 0 (= zero) (then close and restart Firefox)

But the larger question is, why did firefox alter my preferences when I upgraded to 68.0.1 (64bit)? My browser should be a problem solver, not a problem in itself.

''jscher2000 [[#answer-1239564|said]]'' <blockquote> Hi jonpal, each person seems to be looking for something a bit different. Could you describe more exactly how you want the drop-down to work? The blue bar informs you of what Firefox would do if you submit the contents of the address bar right now (either by pressing Enter or clicking the Go button). The bar can be hidden using a custom style rule, but when the bar is hidden the highlight won't move to the next matching item automatically. With that in mind, would you want to: * Hide just the blue bar, keep the rest of the drop-down * Hide the entire drop-down, blue bar and all </blockquote> I don't want any drop down at all. Very distracting to my old brain. This seems to work: https://support.mozilla.org/en-US/questions/1251014 On the 'about:config' page set the value of the preference keyword.enabled to false (and then close and restart Firefox). In case you don't want anything to appear under the address bar : Type in the search bar browser.urlbar. Look for the preference : browser.urlbar.maxRichResults And set its value to 0 (= zero) (then close and restart Firefox) But the larger question is, why did firefox alter my preferences when I upgraded to 68.0.1 (64bit)? My browser should be a problem solver, not a problem in itself.
jonpal 0 solutions 18 answers

</blockquote>

What preferences were altered?

</blockquote>

Prior to the upgrade no blue drop down appeared, after the upgrade it appeared. I don't know what preferences in about:preferences were altered, as I don't have my previous preferences available. But, something was changed.

</blockquote> What preferences were altered? </blockquote> Prior to the upgrade no blue drop down appeared, after the upgrade it appeared. I don't know what preferences in about:preferences were altered, as I don't have my previous preferences available. But, something was changed.