Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox STILL making multiple processes in the Task Manager despite changing the settings, eating up my Memory.

  • 6 replies
  • 46 have this problem
  • 266 views
  • Last reply by bobf650

more options

I am having issues with Firefox creating several processes in the Task Manager whether it be because I just opened it or I open new tabs. My computer can't handle running that many firefox.exe processes at once all for tabs as it'll slow down and crash any other programs I have running and I can't seem to figure out why I can't reduce it all to a single process.

I have tried using about:config to change browser.tabs.remote.autostart.2 from true to false. It is set, but absolutely nothing has changed.

I have tried going into Options>Performance and limiting the Content Process Limit to 1 instead of 4. The setting was saved, and yet it has not changed a thing.

I have run virus scans and everything is working fine, though I have noticed that AdBlock Plus is letting some ads through and I can't even alter its settings (I can't set a check mark for what's allowed or anything).

I only need one process of Firefox running, I do not want 4 processes every time I have new tabs open or anything. If I end any of the processes, it causes all my tabs to crash and reloading them only adds another firefox process.

Please help me.

I am having issues with Firefox creating several processes in the Task Manager whether it be because I just opened it or I open new tabs. My computer can't handle running that many firefox.exe processes at once all for tabs as it'll slow down and crash any other programs I have running and I can't seem to figure out why I can't reduce it all to a single process. I have tried using about:config to change browser.tabs.remote.autostart.2 from true to false. It is set, but absolutely nothing has changed. I have tried going into Options>Performance and limiting the Content Process Limit to 1 instead of 4. The setting was saved, and yet it has not changed a thing. I have run virus scans and everything is working fine, though I have noticed that AdBlock Plus is letting some ads through and I can't even alter its settings (I can't set a check mark for what's allowed or anything). I only need one process of Firefox running, I do not want 4 processes every time I have new tabs open or anything. If I end any of the processes, it causes all my tabs to crash and reloading them only adds another firefox process. Please help me.

Chosen solution

The multi-process opt-in pref browser.tabs.remote.autostart.2 is no longer used in Firefox 58. In Firefox 58+ only browser.tabs.remote.autostart is used, so you need to set this pref to false to disable multi-process.

Read this answer in context 👍 16

All Replies (6)

more options

Chosen Solution

The multi-process opt-in pref browser.tabs.remote.autostart.2 is no longer used in Firefox 58. In Firefox 58+ only browser.tabs.remote.autostart is used, so you need to set this pref to false to disable multi-process.

more options

Ditto what Felis-Licht said. It seems that the Process Content Limit setting was just a placebo to make users think that they actually had some control. I've been going back-n-forth with a contributor for weeks w/o any results. Like Felis-Lict, I've reduced the process Limit down to 1. However, did nothing to the number of actual process running and only shot cpu usage up to 90+% and laptop crashes have been more frequent. Screen print attached showing 5 process running when the setting was at 1. My work-around has been to use MS Edge. It runs with almost a dozen processes but sucks up far less cpu & mem, doesn't freeze up the system or crash my laptop. I was about to post yet another complaint when I came across this post. I wasn't told about the browser.tabs.remote.autostart trick. I'll give that a try and post an update later.

Da**m..WTF!!! Sorry about the outburst. Against my better judgement, I was using Firefox to make this post and it crashed my laptop before I finished. Took forever to recover and to make sure nothing else was crapped out or lost.

Modified by vj000000

more options

Wow!! I can't believe what a difference changing the browser.tabs.remote.autostart values to FALSE made!!

The number of Firefox processes active is actually ONE. CPU usage is nominal. Mem usage is nominal. See screen print where CPU usage is 11%. No keyboard lag/freeeze in email (or typing this post) whatsoever!! No hangs, delays when moving around email folders. No hangs/lags when opening up new tabs from within another tab (eg. clicking on a CNN link). Hope this change makes Firefox more stable and my laptop won't crash like it did before.

Wish someone had told me about his a long time ago. Thanks Felis-Licht & Cor-el!!

more options

cor-el said

The multi-process opt-in pref browser.tabs.remote.autostart.2 is no longer used in Firefox 58. In Firefox 58+ only browser.tabs.remote.autostart is used, so you need to set this pref to false to disable multi-process.

Where do I find browser.tabs.remote.autostart to make the changes?

more options

You can inspect and modify prefs on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Hi all.

The advice above appears to be working.

Maybe someone can answer: Why was the multiple application introduced in the first place when it is detrimental to users computers and why has the practise not been eradicated? I'm getting very cynical! Regards