X
Tap here to go to the mobile version of the site.

Support Forum

Firefox using 90%+ CPU when browsing

Posted

For the last couple of weeks (possibly since Firefox 52.4.0 was released) the CPU usage has been 90-99% when browsing. Sometimes when I open another tab I get a second version of Firefox showing in processes in task manager. I have had the high CPU usage before but it went away. I'm using Windows XP service pack 3. I did read about Firefox stopping plug-ins from v52 - I still have the following plug-ins: OpenH264 video codec Shockwave Flash 27.0 Adobe Acrobat 11.0.8 (showing as 'vulnerable and should be updated') Microsoft DRM (2 of these - Netscape plugin and network object) canon image gateway mycamera plug-in windows media player plug-in dynamic link library windows presentation foundation for mozilla. I'm not sure what most of these do or if they're needed! I'm using Sky Broadband speed approx 7mb which is what it's always been. Also Panda free anti-virus. Any ideas gratefully received as this is driving us mad!

For the last couple of weeks (possibly since Firefox 52.4.0 was released) the CPU usage has been 90-99% when browsing. Sometimes when I open another tab I get a second version of Firefox showing in processes in task manager. I have had the high CPU usage before but it went away. I'm using Windows XP service pack 3. I did read about Firefox stopping plug-ins from v52 - I still have the following plug-ins: OpenH264 video codec Shockwave Flash 27.0 Adobe Acrobat 11.0.8 (showing as 'vulnerable and should be updated') Microsoft DRM (2 of these - Netscape plugin and network object) canon image gateway mycamera plug-in windows media player plug-in dynamic link library windows presentation foundation for mozilla. I'm not sure what most of these do or if they're needed! I'm using Sky Broadband speed approx 7mb which is what it's always been. Also Panda free anti-virus. Any ideas gratefully received as this is driving us mad!

Modified by Noah_SUMO

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Shockwave Flash 27.0 r0
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

FredMcD
  • Top 10 Contributor
4271 solutions 59913 answers

Helpful Reply

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding


More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding ------------------ More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false http://www.ghacks.net/2016/07/22/multi-process-firefox/ Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar.

Question owner

Thanks for the reply. I haven't tried safe start yet but did go and change the multi-process option - seemed to make it slightly quicker yet this morning I've got 2 lots of Firefox running again, so don't know how that's happened!

Thanks for the reply. I haven't tried safe start yet but did go and change the multi-process option - seemed to make it slightly quicker yet this morning I've got 2 lots of Firefox running again, so don't know how that's happened!
Shadow110 1072 solutions 14836 answers

did you change both of these ? browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type in the address bar about:support actually see this page url above or here https://www.ghacks.net/2016/07/22/multi-process-firefox/ it shows what about:support looks like when turned off.

So if did not turn off both you must do so.

Please let us know if this solved your issue or if need further assistance.

did you change both of these ? browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false Type in the address bar about:support actually see this page url above or here https://www.ghacks.net/2016/07/22/multi-process-firefox/ it shows what about:support looks like when turned off. So if did not turn off both you must do so. Please let us know if this solved your issue or if need further assistance.

Question owner

Thanks - I only have one entry - browser.tabs.remote.autostart.2 - which shows 'false'. Even so, not sure that is the main problem. Browser is very, very slow, taking several seconds to load any webpage and constantly using in excess of 90% cpu when so doing. I'm sure I had this problem a few months ago and it went away (or I did something possibly). I've cleared history right down, deleted temporary files. I've got a 80gb hard disk with about 20mb space on it; 2gb of RAM.

Thanks - I only have one entry - browser.tabs.remote.autostart.2 - which shows 'false'. Even so, not sure that is the main problem. Browser is very, very slow, taking several seconds to load any webpage and constantly using in excess of 90% cpu when so doing. I'm sure I had this problem a few months ago and it went away (or I did something possibly). I've cleared history right down, deleted temporary files. I've got a 80gb hard disk with about 20mb space on it; 2gb of RAM.
Shadow110 1072 solutions 14836 answers

That is a problem. Hope sweet talk that thing nicely......lol You are beyond pushing the limits of that thing.

Free up some lots more space, then increase your swap file size is about all I can suggest: Open the System Folder then Click on left side Advanced System Settings which opens System Properties click the Advanced Tab then click Performance button Settings then the Advanced Tab then Click the Change under Virtual Memory click Custom Size and Change Size to where it says Recommended Size then Click Set and then Click Apply then please Re-boot.

NOTE: recommended size is greyed out, that is the size you enter in both places.

System - -> Advanced System Settings --> System Properties - -> Advanced Tab - -> Change Virtual Memory - -> Custom Size - -> ENTER Recommended Size - -> Set - -> Apply-- > Reboot

Please let us know if this solved your issue or if need further assistance.

That is a problem. Hope sweet talk that thing nicely......lol You are beyond pushing the limits of that thing. Free up some lots more space, then increase your swap file size is about all I can suggest: Open the System Folder then Click on left side Advanced System Settings which opens System Properties click the Advanced Tab then click Performance button Settings then the Advanced Tab then Click the Change under Virtual Memory click Custom Size and Change Size to where it says Recommended Size then Click Set and then Click Apply then please Re-boot. NOTE: recommended size is greyed out, that is the size you enter in both places. System - -> Advanced System Settings --> System Properties - -> Advanced Tab - -> Change Virtual Memory - -> Custom Size - -> ENTER Recommended Size - -> Set - -> Apply-- > Reboot Please let us know if this solved your issue or if need further assistance.

Question owner

at present total physical memory is 1046512; kernel total is 74584 of which 57570 is paged ; swap size seems to be 1536mb. How does that seem?

at present total physical memory is 1046512; kernel total is 74584 of which 57570 is paged ; swap size seems to be 1536mb. How does that seem?
FredMcD
  • Top 10 Contributor
4271 solutions 59913 answers

dave61 said

I've got a 80gb hard disk with about 20mb space on it

That can bother the computer. You should get an external hard drive and transfer file you don't use to it, clearing the drive.

''dave61 [[#answer-1017773|said]]'' <blockquote> I've got a 80gb hard disk with about 20mb space on it </blockquote> That can bother the computer. You should get an external hard drive and transfer file you don't use to it, clearing the drive.

Question owner

Really? What does it need that space for?

Really? What does it need that space for?
FredMcD
  • Top 10 Contributor
4271 solutions 59913 answers

Today's computers are always writing to the disk while also removing those same files later. Then there are the files that you are working on as well as any downloads you may be doing.

20mb is not much to work with. And if an application tries to write to the disk, but there is no room . . . .

Today's computers are always writing to the disk while also removing those same files later. Then there are the files that you are working on as well as any downloads you may be doing. 20mb is not much to work with. And if an application tries to write to the disk, but there is no room . . . .

Question owner

Sorry, I mistyped. Should have been 20GB free! Thought that seemed a bit odd. Anyway I removed some software I was no longer using and backed up some photos and now have 23 GB free. I also installed a new router that Sky had sent as they reckoned there might be a problem with the old one. This morning it seems even slower than ever. My current stats are: Physical memory- 1046512; available 362300; cache 316080. Kernel memory- total 52960; paged 36864; nonpaged 16096. Commit charge - total 615680; Limit 2523976; peak 775572. Handles 9644; Threads 541; processes 37. This is just with this window open. Any ideas? Thanks

Sorry, I mistyped. Should have been 20GB free! Thought that seemed a bit odd. Anyway I removed some software I was no longer using and backed up some photos and now have 23 GB free. I also installed a new router that Sky had sent as they reckoned there might be a problem with the old one. This morning it seems even slower than ever. My current stats are: Physical memory- 1046512; available 362300; cache 316080. Kernel memory- total 52960; paged 36864; nonpaged 16096. Commit charge - total 615680; Limit 2523976; peak 775572. Handles 9644; Threads 541; processes 37. This is just with this window open. Any ideas? Thanks
FredMcD
  • Top 10 Contributor
4271 solutions 59913 answers

Glad you have more memory then you thought.

Is Sky the name of your ISP? Have them test your service.

Check your internet using Windows Internet Explorer. Any problems?

Glad you have more memory then you thought. Is Sky the name of your ISP? Have them test your service. Check your internet using Windows Internet Explorer. Any problems?

Question owner

Sky speed is between 6mbps and 7mbps. I don't have IE. I did a search on here for '52' and lots of people seem to be complaining about slow speed with this version of Firefox. Has anyone actually come up with a solution?

Thanks

Sky speed is between 6mbps and 7mbps. I don't have IE. I did a search on here for '52' and lots of people seem to be complaining about slow speed with this version of Firefox. Has anyone actually come up with a solution? Thanks
FredMcD
  • Top 10 Contributor
4271 solutions 59913 answers

All Windows systems should have a version of Internet Explorer. Do you have any other browser? Real Player for example?

All Windows systems should have a version of Internet Explorer. Do you have any other browser? Real Player for example?

Question owner

My IE was out of date and never loaded properly so I took it off. I don't have anything else. Surely with so many complaining about it, someone must know why v52 is so much slower and what the solution is?

My IE was out of date and never loaded properly so I took it off. I don't have anything else. Surely with so many complaining about it, someone must know why v52 is so much slower and what the solution is?

Question owner

Also, despite turning off multiple processes in about:config (restart2 set to false), I am still occasionally getting 2 lots of firefox running in processes - how can this be? Thanks

Also, despite turning off multiple processes in about:config (restart2 set to false), I am still occasionally getting 2 lots of firefox running in processes - how can this be? Thanks
SyncroScales 1 solutions 13 answers

To dave61 and anyone else using Windows XP, Windows Vista or other old Operating Systems:

The problems I have noticed with Windows XP and Windows Vista being used online is that the internet it self has moved on. Software might not support Windows 7 and 8/8.1.

There are computers that are quad-core and up that run or come pre-installed with Windows 7, 8/8.1 and even Windows 10, they start at $200-$400-$1000+ when you look at electronic retailers or in stores.

For faster speeds: Your system specs are terrible. Make backups of all of your stuff, important stuff, bookmarks and other internet things you need to save. Do this once a month or more.

You could try Linux. There is a learning curve with Linux and things you need to do for security. There are many videos on Social Media. Try Linux on a DVD or USB stick. For your current computer Linux Mint (looks like Windows computers) Xfce or Linux Ubuntu (looks like Apple Mac computers) Xfce.

Buy a newer version of Windows, an Apple Mac or a Google Chrome device. Even a tablet that is better than your current computer.

To dave61 and anyone else using Windows XP, Windows Vista or other old Operating Systems: The problems I have noticed with Windows XP and Windows Vista being used online is that the internet it self has moved on. Software might not support Windows 7 and 8/8.1. There are computers that are quad-core and up that run or come pre-installed with Windows 7, 8/8.1 and even Windows 10, they start at $200-$400-$1000+ when you look at electronic retailers or in stores. For faster speeds: Your system specs are terrible. Make backups of all of your stuff, important stuff, bookmarks and other internet things you need to save. Do this once a month or more. You could try Linux. There is a learning curve with Linux and things you need to do for security. There are many videos on Social Media. Try Linux on a DVD or USB stick. For your current computer Linux Mint (looks like Windows computers) Xfce or Linux Ubuntu (looks like Apple Mac computers) Xfce. Buy a newer version of Windows, an Apple Mac or a Google Chrome device. Even a tablet that is better than your current computer.

Modified by SyncroScales