X
Tap here to go to the mobile version of the site.

Support Forum

Bookmarks toolbar keeps jumping above Web Address Toolbar on startup, how can I stop this

Posted

Every time I start my browser my bookmarks toolbar appears above my web address browser (see top pane in image, red box outlines toolbars).

To fix this, I have to open Customise Firefox and simply mouse over the two toolbars. Instantly they revert back to the right way, with the Web address bar on top and the bookmarks underneath (see middle pane in image)

I then close customise the settings persist (see bottom pane), only until I close the browser or open a new window, and then I have to go through the whole process again. Its very frustrating.

I've had a look at prefs.js, but I can't see any settings that revert on closing the browser. Any help to resolve this would be very much appreciated

Every time I start my browser my bookmarks toolbar appears above my web address browser (see top pane in image, red box outlines toolbars). To fix this, I have to open Customise Firefox and simply mouse over the two toolbars. Instantly they revert back to the right way, with the Web address bar on top and the bookmarks underneath (see middle pane in image) I then close customise the settings persist (see bottom pane), only until I close the browser or open a new window, and then I have to go through the whole process again. Its very frustrating. I've had a look at prefs.js, but I can't see any settings that revert on closing the browser. Any help to resolve this would be very much appreciated
Attached screenshots

Chosen solution

Ok stand down, the universe is at peace, balance has been brought to the force and I now have two well-behaving toolbars.

After searching around I found this gem: https://support.mozilla.org/en-US/questions/1049464 and adding few mere lines of css to my favourite file, good ol' UserChrome.jss, now I am feeling much happier and less reluctant close my browser window.

Thanks for stopping by

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Version 5.41.3.0
  • Google Update
  • IE Tab plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • VLC media player Web Plugin 2.0.6
  • NPWLPG

Application

  • Firefox 45.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
  • Support URL: https://support.mozilla.org/1/firefox/45.0.1/WINNT/en-GB/

Extensions

  • Adblock Plus 2.7.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add-on Compatibility Reporter 2.0.6.1-signed (compatibility@addons.mozilla.org)
  • Avast Online Security 10.3.3.39 (wrc@avast.com)
  • Avast SafePrice 10.3.5.39 (sp@avast.com)
  • Classic Theme Restorer 1.4.9 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Ebay Button 1.4.0.1-signed (ebayHotStuff@wangtom.com)
  • Ebay Toolbar 1.4.0.1-signed (FFEbayShoppingToolbar@wangtom.com)
  • Firefox Hello Beta 0.1 (loop@mozilla.org)
  • IE Tab 4.0.20130422.1-signed ({77b819fa-95ad-4f2c-ac7c-486b356188a9})
  • Multirow Bookmarks Toolbar 6.0 ({FBF6D7FB-F305-4445-BB3D-FEF66579A033})
  • Session Manager 0.8.1.12 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Tab Groups 1.0.2 (tabgroups@quicksaver)
  • Tabs on Bottom 0.7.1 (tabsonbottom@piro.sakura.ne.jp)
  • All In 1 Search Bar 4.0.1-signed (07bce030@pribic.am) (Inactive)
  • Google Toolbar for Firefox 7.1.20110512W ({3112ca9c-de6d-4884-a869-9855de68056c}) (Inactive)
  • Improved searchbar 2.0.2.1-signed (improversearchbar@giovanni) (Inactive)
  • Keyword Search 1.1.6 (keywordsearch@kaply.com) (Inactive)
  • Skype 8.0.0.9103 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)
  • Treat Street Points Booster 1.3.0.0 (treatstreet@boots.com) (Inactive)
  • Xmarks 4.3.18 (foxmarks@kei.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0106
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 16521043
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 5-27-2015
  • driverDate2:
  • driverVersion: 9.17.10.4229
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Scribe 735 solutions 3502 answers

Hi, this is likely to be an issue with your theme or an add-on(s). So try disabling them one by one until you find the culprit - Add-ons Manager (Ctrl+Shift+A > Extensions/Appearance).


Alternatively, you can try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!

Hi, this is likely to be an issue with your theme or an add-on(s). So try disabling them one by one until you find the culprit - Add-ons Manager (Ctrl+Shift+A > Extensions/Appearance). ----------------- Alternatively, you can try Firefox Safe Mode to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!

Question owner

Hi,

Thank you for your suggestion.

I have tried disabling all add-ins and themes and the issue still occurs. It looks exactly the same as before just without the custom skin seen in the screenshot.

I have also tried starting in safe mode. In safe mode, its even worse. The Bookmarks toolbar doesn't even appear. In fact, the title bar and options bar are also missing, and the Tabs appear above the Web address bar.

In safe mode the Bookmarks toolbar, title bar, and options bar can be re-enabled, but the settings do not persist.

I am using the latest version of Firefox (45 I think).

The only clue as to where this may lie is that disabling add-ons seemed to have very little effect. e.g. I disabled my "tabs on bottom" add-on and when i restarted the browser the tabs still appeared at the bottom.

Any ideas? Could this be a clue?

Hi, Thank you for your suggestion. I have tried disabling all add-ins and themes and the issue still occurs. It looks exactly the same as before just without the custom skin seen in the screenshot. I have also tried starting in safe mode. In safe mode, its even worse. The Bookmarks toolbar doesn't even appear. In fact, the title bar and options bar are also missing, and the Tabs appear above the Web address bar. In safe mode the Bookmarks toolbar, title bar, and options bar can be re-enabled, but the settings do not persist. I am using the latest version of Firefox (45 I think). The only clue as to where this may lie is that disabling add-ons seemed to have very little effect. e.g. I disabled my "tabs on bottom" add-on and when i restarted the browser the tabs still appeared at the bottom. Any ideas? Could this be a clue?

Question owner

My current view.

I'm on Firefox 45.0.1

Someone please help me, I'm this close to doing a factory reset and I really dont wanna do that

My current view. I'm on Firefox 45.0.1 Someone please help me, I'm this close to doing a factory reset and I really dont wanna do that

Chosen Solution

Ok stand down, the universe is at peace, balance has been brought to the force and I now have two well-behaving toolbars.

After searching around I found this gem: https://support.mozilla.org/en-US/questions/1049464 and adding few mere lines of css to my favourite file, good ol' UserChrome.jss, now I am feeling much happier and less reluctant close my browser window.

Thanks for stopping by

Ok stand down, the universe is at peace, balance has been brought to the force and I now have two well-behaving toolbars. After searching around I found this gem: https://support.mozilla.org/en-US/questions/1049464 and adding few mere lines of css to my favourite file, good ol' UserChrome.jss, now I am feeling much happier and less reluctant close my browser window. Thanks for stopping by