Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Doesn't display correctly and is very laggy on sites with CloudFlare DDoS Protection

  • 14 replies
  • 3 have this problem
  • 33 views
  • Last reply by Gnospen

more options

Since 35.0 and above i have been getting weird behaviour on sites with CloudFlare DDoS protection.

When i open the site in a new window, it takes a really long time and sometimes doesn't display at all and gives me a blank page. and now it just starts to say "New Tab" and i can't hit refresh.

When the site actually loads after 20 something attempts, the site is laggy, any action takes upwards of 20 seconds.

Whenever i try to open something, i get a blank page with the URL at tabs. Whenever i try to like or post anything, it delays by 15-20 seconds.

Site i am trying to use with much failure. http://hypixel.net/

Anyone else having this issue?

Chosen solution

Have you installed incredibar yourself? Do you want it? I realy think thats what slowing you down. Its a hijacking ad-ware here is how to UN-install it http://malwaretips.com/blogs/remove-mystart-by-incredibar-virus/

Read this answer in context 👍 1

All Replies (14)

more options

And what's your hardware configuration?

more options

MekliCZ said

And what's your hardware configuration?

i don't know where to find that...

more options

If you're running on Windows, right-click on the Computer and click on the "Properties". If you're running on Mac, click on Apple symbol in top-left corner and "About this Mac".

more options

i took a print screen, hopefully this helps

Running a Toshiba Satatlite that i got as a gift in November of 2012. It may just be that it's out dated, but back when i was using 34.x i didn't have this problem at all

more options

Okay. Do you see this issue in other browsers (Internet Explorer, Chrome, Maxthon, Opera...)?

more options

MekliCZ said

Okay. Do you see this issue in other browsers (Internet Explorer, Chrome, Maxthon, Opera...)?

No, only on Firefox.

more options

So, check that all your drivers are up-to-date. If not, update it. Reinstall Firefox or try Firefox Nightly. It can be repaired in it.

more options

maybe it would help if you open "troubleshooting information" (under help) and copy it to clipboard and paste it here

more options

Gnospen said

maybe it would help if you open "troubleshooting information" (under help) and copy it to clipboard and paste it here

{

 "application": {
   "name": "Firefox",
   "version": "35.0.1",
   "userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0",
   "supportURL": "https://support.mozilla.org/1/firefox/35.0.1/WINNT/en-US/",
   "numTotalWindows": 1,
   "numRemoteWindows": 0
 },
 "crashes": {
   "submitted": [
     {
       "id": "bp-267af71f-8bf3-46cc-883e-ff65e2150222",
       "date": 1424594056152,
       "pending": false
     }
   ],
   "pending": 1
 },
 "modifiedPreferences": {
   "accessibility.typeaheadfind.flashBar": 0,
   "browser.cache.disk.smart_size.first_run": false,
   "browser.cache.disk.smart_size.use_old_max": false,
   "browser.cache.disk.capacity": 358400,
   "browser.cache.disk.smart_size_cached_value": 358400,
   "browser.cache.frecency_experiment": 4,
   "browser.fixup.domainwhitelist.googler": true,
   "browser.fixup.domainwhitelist.google": true,
   "browser.fixup.domainwhitelist.gmail": true,
   "browser.fixup.domainwhitelist.totaldramawiki": true,
   "browser.fixup.domainwhitelist.omegle": true,
   "browser.newtab.url": "http://mystart.incredibar.com/?a=6PRnKQcHXQ&i=26&did=10963&loc=skw",
   "browser.places.smartBookmarksVersion": 7,
   "browser.sessionstore.upgradeBackup.latestBuildID": "20150122214805",
   "browser.sessionstore.max_resumed_crashes": 100,
   "browser.sessionstore.enabled": true,
   "browser.startup.homepage_override.mstone": "35.0.1",
   "browser.startup.homepage": "http://mystart.incredibar.com/?a=6PRnKQcHXQ&i=26&did=10963&loc=skw|http://www.youtube.com/",
   "browser.startup.homepage_override.buildID": "20150122214805",
   "dom.max_chrome_script_run_time": 0,
   "dom.mozApps.used": true,
   "extensions.lastAppVersion": "35.0.1",
   "font.internaluseonly.changed": true,
   "gfx.direct3d.last_used_feature_level_idx": 0,
   "keyword.URL": "http://mystart.incredibar.com/?a=6PRnKQcHXQ&i=26&did=10963&loc=skw&search=",
   "media.gmp-gmpopenh264.lastUpdate": 1423171183,
   "media.gmp-gmpopenh264.version": "1.3",
   "media.gmp-manager.lastCheck": 1424516177,
   "network.cookie.prefsMigrated": true,
   "places.database.lastMaintenance": 1424565640,
   "places.history.expiration.transient_current_max_pages": 104858,
   "plugin.disable_full_page_plugin_for_types": "application/pdf",
   "plugin.state.nppdf": 2,
   "plugin.importedState": true,
   "privacy.sanitize.timeSpan": 0,
   "privacy.cpd.cookies": false,
   "privacy.sanitize.migrateFx3Prefs": true,
   "privacy.cpd.sessions": false,
   "storage.vacuum.last.places.sqlite": 1424326926,
   "storage.vacuum.last.index": 1
 },
 "lockedPreferences": {},
 "graphics": {
   "numTotalWindows": 1,
   "numAcceleratedWindows": 1,
   "windowLayerManagerType": "Direct3D 11",
   "windowLayerManagerRemote": true,
   "adapterDescription": "Intel(R) HD Graphics 4000",
   "adapterVendorID": "0x8086",
   "adapterDeviceID": "0x0166",
   "adapterSubsysID": "00000000",
   "adapterRAM": "Unknown",
   "adapterDrivers": "igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32",
   "driverVersion": "8.15.10.2712",
   "driverDate": "3-26-2012",
   "adapterDescription2": "",
   "adapterVendorID2": "",
   "adapterDeviceID2": "",
   "adapterSubsysID2": "",
   "adapterRAM2": "",
   "adapterDrivers2": "",
   "driverVersion2": "",
   "driverDate2": "",
   "isGPU2Active": false,
   "direct2DEnabled": true,
   "directWriteEnabled": true,
   "directWriteVersion": "6.2.9200.16571",
   "webglRenderer": "Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)",
   "info": {
     "AzureCanvasBackend": "direct2d",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "cairo",
     "AzureContentBackend": "direct2d"
   }
 },
 "javaScript": {
   "incrementalGCEnabled": true
 },
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 },
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.7",
     "version": "4.10.7"
   },
   "NSS": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   },
   "NSSUTIL": {
     "minVersion": "3.17.2",
     "version": "3.17.2"
   },
   "NSSSSL": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   },
   "NSSSMIME": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   }
 },
 "userJS": {
   "exists": true
 },
 "extensions": [
   {
     "name": "Adblock Plus",
     "version": "2.6.7",
     "isActive": false,
     "id": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}"
   },
   {
     "name": "FastFreeConverter",
     "version": "5.6",
     "isActive": false,
     "id": "extension@Fast_Free_Converter.com"
   },
   {
     "name": "Mozilla hotfix",
     "version": "2.0",
     "isActive": false,
     "id": "hotfix@mozilla.org"
   },
   {
     "name": "Updater By SweetPacks",
     "version": "2.0.0.609",
     "isActive": false,
     "id": "{8E9E3331-D360-4f87-8803-52DE43566502}"
   }
 ],
 "experiments": []

}

more options

As MekliCZ said update your graphic driver. this is from 2012.

But I also saw that you have user.js in your profile. If you haven't made it yourself its probably some adware hijacking you that did. So open troubleshooting info again and click on show folder this opens explorer. Close Firefox (important) rename user.js to whatever restart firefox

more options

Gnospen said

As MekliCZ said update your graphic driver. this is from 2012. But I also saw that you have user.js in your profile. If you haven't made it yourself its probably some adware hijacking you that did. So open troubleshooting info again and click on show folder this opens explorer. Close Firefox (important) rename user.js to whatever restart firefox

The user.js is mine, i just never renamed it

more options

Chosen Solution

Have you installed incredibar yourself? Do you want it? I realy think thats what slowing you down. Its a hijacking ad-ware here is how to UN-install it http://malwaretips.com/blogs/remove-mystart-by-incredibar-virus/

more options

Gnospen said

Have you installed incredibar yourself? Do you want it? I realy think thats what slowing you down. Its a hijacking ad-ware here is how to UN-install it http://malwaretips.com/blogs/remove-mystart-by-incredibar-virus/

That's probably it..

when i got FireFox 53.0 it just showed up and i thought it was a deafulut thing.

God dammit. i disabled everything that came with and wiped it off my computer.

Considering it was Adware maybe the CloudFlare saw it as a threat?

Turns out that CloudFlare was actually doing me a favor...


EDIT: Holy crap you were right, i disabled everything that came with it and now everything is running so smoothly, i have also been having random crashes and freexing between switching tabs, was that also a side effect.

now i feel stupid because AVG never picked up on it.

Modified by djice777

more options

Just never download from any site except https://www.mozilla.org