Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Skipping cookie popup by Firefox

more options

Since some time I encounter on more and more sites that on loading, the home page is showed as expected, but only during a fraction of a second. After it a kind of light gray filter layer is added to the screen. It's possible to scroll down the page, but all buttons/links on it are disabled. Using Google Chrome previous described mistake does not occur. Instead a cookie popup appears and after accepting, the normal homepage appears. So it seems that some sites are freezing their home page by the gray overlay in order to force the user to accept/reject the cookies. But when Firefox skips the cookie popup you're always blocked. Do you see a solution for a user of sutch sites?

Since some time I encounter on more and more sites that on loading, the home page is showed as expected, but only during a fraction of a second. After it a kind of light gray filter layer is added to the screen. It's possible to scroll down the page, but all buttons/links on it are disabled. Using Google Chrome previous described mistake does not occur. Instead a cookie popup appears and after accepting, the normal homepage appears. So it seems that some sites are freezing their home page by the gray overlay in order to force the user to accept/reject the cookies. But when Firefox skips the cookie popup you're always blocked. Do you see a solution for a user of sutch sites?
Pridėtos ekrano nuotraukos

Chosen solution

Thanks for your solution. Adblock Plus has 2 new filters : "Block cookie warnings" and "Block push notifications". Disabling "Block cookie warnings" solves the problem.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (3)

more options

Hi, Firefox doesn't (can't) automatically skip or remove web page overlay dialogs. Your screenshot shows the button of Adblock Plus. Maybe the add-on has determined that the cookie dialog looks a lot like an ad and is suppressing it? You may need to adjust its settings.

more options

Chosen Solution

Thanks for your solution. Adblock Plus has 2 new filters : "Block cookie warnings" and "Block push notifications". Disabling "Block cookie warnings" solves the problem.

more options

Thank you for reporting back. Someone should fix that filter to ALSO peel off the blocking overlay. Maybe that's harder than it sounds...