Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some websites display Text out of alignment?

  • 7 replies
  • 1 has this problem
  • 14 views
  • Paskiausią atsakymą parašė edstudios

more options

For the last few versions of FF (currently on 88.0.1 (64-bit) OSX Big Sur) certain websites display text incorrectly where the text is bold and each character is offset with the next one (see attached Images).

It only seems to happen to certain websites and happens both within my web based email and on standard websites - but only some of them.

I've attached a photo of the issue in my webmail - I'm viewing an email sent to me using mailchimp, but even this is inconsistent as other emails using mailchimp are fine. And as I said before it happens on websites too (examples attached).

I have this issue on my 2020 iMac and my 2020 M1 MacBook Air but not on my 2019 iMac. All 3 are running latest version of FF and all synced to my FF account and have all the same settings. Attached photo of plugins/extensions installed too.

Please help me fix this it's so frustrating!

Thanks

Pridėtos ekrano nuotraukos

All Replies (7)

more options

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

Also see: https://support.mozilla.org/en-US/search/advanced?q=fonts&language=en-US&product=firefox&sortby_documents=relevance&a=1&w=1

Helpful?

more options

@FredMcD I followed your instructions and that box was already ticked. I deselected and re-selected it but it didn't fix my issue :(

I'm also using the default FF theme

Helpful?

more options

Reboot the computer.

Helpful?

more options

That font is hilarious! So in your second screenshot, it shows that the specified font "Open Sans" is actually being displayed using the font "WLM Idea Play Alt".

Any single site can use any font they like, but it sounds like it is bleeding over to other sites. Does that weird font also substitute for Open Sans on my site here? https://www.userchrome.org/

Perhaps this association is cached. Could you try clearing it as described in

How to clear the Firefox cache

Note: just clear the web cache, not all site data.

The next time you visit a problem page, any difference?

Helpful?

more options

FredMcD - Reboot didn't change anything :(

jscher2000 - yes your website has the messed up font for me. I cleared the web cache as per the instructions and rebooted but it made no difference - see attached image :(

Helpful?

more options

Firefox appears to prefer the Open Sans font variant you have installed on your computer over the font that can be downloaded, so you can try to uninstall this open sans font.

Helpful?

more options

Ok - removing Open Sans from my font book on Mac seems to fix the issue. The websites now display correctly. I'm wondering if the Open Sans was loaded when I installed Davinci Resolve studio? This program is the only differece between my MacAir and 2020 iMac (displaying incorrectly) and my 2019 iMac (displaying correctly)?

In any case, it seems to have fixed the issue - thank you very much for your assistance!

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.