Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mozilla New Tab with Flickr

  • 9 replies
  • 1 has this problem
  • 1 view
  • Paskiausią atsakymą parašė cor-el

more options

I want to see only my Google.com search page when I open a new tab. I have updated tools, options to reflect that. But every time i opened a new tab, a page wtih Flickr photos come up. So the next step is to always click the home button to see the google.com search page.

I don't really want to see any of those photos and I just want to pull up the Google.com search page every time. I don't need to waste time with an extra click to get to a search. This feature is very annoying. Please advise how to remove that page and allow me to go straight to the Google search engine. Please advise too, if it is not an option so that I could stop using Mozilla.

Thanks.

All Replies (9)

more options

I have no idea why Flickr is on your new tab page! Here's how you can change it to Google:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

For Google, use the secure address https://www.google.com/ for best results

Press Ctrl+t to open a new tab and verify that it worked. Fixed?


If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel. If the status says "locked" we will need to help you investigate an "autoconfig" file.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

more options

It worked but... only once. Your procedure is similar to the one I found on internet. I only posted the question because I could not find another option on the internet.

Following the procedure (did it twice), when I completed the procedure as you have provided and opened a new tab, sure it took me to Google.com. As a check, I closed all tabs, and opened a new window. The homepage is the Google search page. When I opened a new tab, it once again shows the search by Yahoo with the Flickr photos at the back. Looks like I am uninstalling Mozilla.

more options

p.s. I did find the user.js file and i could not find the directory to use Notepad to open. When I tried to get the program to search for a suitable program to open the file, it takes me to http://www.openthefile.net/extension/js?utm_source=fah&utm_medium=searchweb&utm_campaign=fah

I don't want to install more files/ programs etc which could create other issues too. Who knows... I am not a IT person. I just don't think I should be forced to see all those Flickr photos. Anyway, thanks for your help.

more options

Okay, that's useful information.

t3ddy said

Following the procedure (did it twice), when I completed the procedure as you have provided and opened a new tab, sure it took me to Google.com. As a check, I closed all tabs, and opened a new window. The homepage is the Google search page. When I opened a new tab, it once again shows the search by Yahoo with the Flickr photos at the back.

When you say you closed all the tabs, do you mean you closed everything Firefox had open and Firefox shut down? And then you restarted Firefox again and the problem was back?

I mentioned some things to check if you lose the change between Firefox sessions and there are more. Those include:

(1) Possible user.js file

user.js file is an optional settings file Firefox uses at startup to override your saved preferences from the previous session. You can check for and remove any user.js file using the steps in this article: How to fix preferences that won't save.

Note: By default, Windows hides the .js file extension and several others. To work with files as accurately as possible, I suggest showing ALL file extensions. This Microsoft support article has the steps: http://windows.microsoft.com/en-us/wi.../show-hide-file-name-extensions.

(2) Possible bad add-on

Try disabling ALL Yahoo/Flickr-related, as well as any nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable. Bear in mind that all extensions are optional, none are included with Firefox.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that allow you to save changes to settings between sessions?

(3) Utility programs that undo browser settings changes

Advanced SystemCare and other utility programs often have a settings protection feature called variously home page protection, browser protection, surfing protection, etc. These will restore old copies of settings between sessions to "protect" you from unwanted changes. Since they have no idea what is wanted vs. unwanted, they mostly cause aggravation. Turn off any such features.

(4) Malware like "SearchProtect" which you can check for in the Windows Control Panel.

In fact, I suggest opening the Windows Control Panel, Uninstall a Program. Then after the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can surface undisclosed bundle items that snuck in with some software you agreed to install. Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it. Take out as much trash as possible here.

more options

Oops, our posts crossed.

t3ddy said

p.s. I did find the user.js file and i could not find the directory to use Notepad to open. When I tried to get the program to search for a suitable program to open the file, it takes me to http://www.openthefile.net/extension/js?utm_source=fah&utm_medium=searchweb&utm_campaign=fah

Don't download anything. Right-click user.js and choose Edit to open it in Notepad.

more options

I did the right click and had 2 options: "Open" and "Open with...". I tried both and of course I don't have a program installed that could open java script files (I didn't know what it was and did a quick google search). I did not want to install any new programs so I opened Notepad directly and tried to find the directory but didn't know to do it. Honestly this is beyond me; I understood the English but not all these IT technicalities.

Many thanks for the quick response; I am really impressed with the promptness. I am just out of patient with the browser and have already uninstalled it. I have been using it for years... it is a pity, fortunately there are other browsers I could use. Many thanks once again.

more options

Well, one last hack. Just change the name of the file to user.js.txt so it will open automatically in Notepad.

Or if you prefer other browsers now, then never mind.

more options

P.S. The next version of Firefox, Firefox 41, is going to insulate the new tab page from being changed, to protect against this kind of problem. This involves completely removing the browser.newtab.url preference. If you want to set your new tab to Google on Firefox 41, you will need to use an add-on like https://addons.mozilla.org/firefox/addon/new-tab-override/ to do that.

more options

You can always use the Scratchpad that is part of the built-in Developer tools (Firefox/Tools > Web Developer) to inspect and edit files in Firefox.