Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Overprinted text in PDF when using built-in PDF viewer and using my own colors.

  • 4 replies
  • 3 have this problem
  • 19 views
  • Paskiausią atsakymą parašė guigs

more options

When I uncheck the option "allow pages to use their own colors..." in preferences, and view a PDF using the built-in viewer, all text in PDF documents appears to be printed twice with the default color (usually black) then printed again with my preferred color slightly shifted giving the appearance of all the text having shadows. I usually set my color preferences for pages to have a black background and a light gray text. This may be a bug.

All Replies (4)

more options

Hi seablue, In order to further investigate, please update to Firefox 36. If this continues please provide a test link to a pdf for further investigation.

more options
more options

I see the same thing when I uncheck that option and view the PDF using the built-in viewer. However, I always let websites pick their colors so I've never noticed it.

Personally, I don't think those options should affect PDFs at all.

more options

Fix printing problems in Firefox

  • Does this happen in other pdf viewers? Print preview in pdf does not use pdf.js afaik

Note: bug?

Modified by guigs