X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Extremly slow autocomplete for addresses after Thunderbird update

Paskelbta

Yesterday I upgraded Thunderbird from version 30 to 31, now while I writing messages the autocomplete for addresses is extremly slow to suggest contacts. If I enter only a letter in the destination field, thunderbird hangs for about twenty seconds and after show me the suggestions. Typing two letters quickly, thunderbird hangs for 13 seconds. typing 3 after 6 seconds All tested even in safe mode I have a local address book with about 9870 contacts (no remote address book) and before the upgrade everything worked fine

Yesterday I upgraded Thunderbird from version 30 to 31, now while I writing messages the autocomplete for addresses is extremly slow to suggest contacts. If I enter only a letter in the destination field, thunderbird hangs for about twenty seconds and after show me the suggestions. Typing two letters quickly, thunderbird hangs for 13 seconds. typing 3 after 6 seconds All tested even in safe mode I have a local address book with about 9870 contacts (no remote address book) and before the upgrade everything worked fine

Modified by Wayne Mery

Chosen solution

The problem may be due to the new feature in autocomplete that searches for matches that include the entered string, not just ones that match the beginning of address book fields, which was the old method.

If you install MoreFunctionsForAddressBook, it will add a preference, morecols.autocomplete.match_just_beginning, which you can switch to true, and see if it makes any difference. Tools(or AppMenu/Options)/Options/Advanced/General/Config. editor, paste the preference in Search and double-click it to switch from false to true.

Edit: Version 0.7 of MoreFunctionsForAddressBook includes this switch on the Autocomplete tab of its Options (valid for TB 31+).

Skaityti atsakymą kartu su kontekstu 12

Papildomi duomenys apie sistemą

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

sfhowes
  • Top 10 Contributor
Sprendimų: 1842 Atsakymų: 9089

Chosen Solution

The problem may be due to the new feature in autocomplete that searches for matches that include the entered string, not just ones that match the beginning of address book fields, which was the old method.

If you install MoreFunctionsForAddressBook, it will add a preference, morecols.autocomplete.match_just_beginning, which you can switch to true, and see if it makes any difference. Tools(or AppMenu/Options)/Options/Advanced/General/Config. editor, paste the preference in Search and double-click it to switch from false to true.

Edit: Version 0.7 of MoreFunctionsForAddressBook includes this switch on the Autocomplete tab of its Options (valid for TB 31+).

The problem may be due to the new feature in autocomplete that searches for matches that include the entered string, not just ones that match the beginning of address book fields, which was the old method. If you install [https://nic-nac-project.org/~kaosmos/morecols-en.html MoreFunctionsForAddressBook], it will add a preference, morecols.autocomplete.match_just_beginning, which you can switch to true, and see if it makes any difference. Tools(or AppMenu/Options)/Options/Advanced/General/Config. editor, paste the preference in Search and double-click it to switch from false to true. Edit: Version 0.7 of MoreFunctionsForAddressBook includes this switch on the Autocomplete tab of its Options (valid for TB 31+).

Modified by sfhowes

Wayne Mery
  • Top 25 Contributor
  • Moderator
Sprendimų: 600 Atsakymų: 5741

DesTfox, please post your results - I am also interested in this. Thanks.

DesTfox, please post your results - I am also interested in this. Thanks.

Klausimą uždavęs asmuo

Thanks sfhowes, the problem is solved using the procedure suggested by you

Thanks sfhowes, the problem is solved using the procedure suggested by you
Qrzysio Sprendimų: 0 Atsakymų: 12

This solution doesn't work on my PC. (windows 8.1, TB 31.0)

This solution doesn't work on my PC. (windows 8.1, TB 31.0)
Wayne Mery
  • Top 25 Contributor
  • Moderator
Sprendimų: 600 Atsakymų: 5741

> This solution doesn't work on my PC. (windows 8.1, TB 31.0) How many contacts in your address books? And what have you tried so far - safe mode?

> This solution doesn't work on my PC. (windows 8.1, TB 31.0) How many contacts in your address books? And what have you tried so far - safe mode?
Qrzysio Sprendimų: 0 Atsakymų: 12

I have only 1410 contacts in my address book. I've installed MoreFunctionsForAddressBook add-on and I followed the instructio - I've changed "morecols.autocomplete.match_just_beginning" to "yes". That's all I did till now. Restarted TB, and noticed there is no difference.

I don't use a lot of adds-on. Just a few ones: Clippings 4.1, ImportExportTools 2.8.0.4, Mark Gmail Read 1.0.2, polish dictionary and recently installed MoreFunctionsForAddressBook.

I store huge amount of emails - my profile takes 27,1 GB, where "ImapMail" folder takes 26,8 GB.

Anyway before update everything was alright. After update to TB to 31.0 version, problem appeared.

One more thing: Im not "mouse-user". I prefer to switch between all form fields using keyboard. I've also noticed (since TB 31.0) when I'm typing an email address in "To:" field, waiting for filling up, then pressing "Tab" - it switches me to the next "To:" field below. If I press "Tab" again, when "To" field is empty, cursor finally goes to "Subject". It's also has changed. Before, to switch to the second field "To" I had to press "Enter", but "Tab" always took me to "Subject" field. It is also inconvenient. Takes more time to fill the form. Now "Enter" and "Tab" works exactly the same way. We are filling the form, and no matter what we press "Tab" or "Enter", It always takes me to the second "To" which people usually doesn't use, and the second press takes to "Subject".

I have only 1410 contacts in my address book. I've installed MoreFunctionsForAddressBook add-on and I followed the instructio - I've changed "morecols.autocomplete.match_just_beginning" to "yes". That's all I did till now. Restarted TB, and noticed there is no difference. I don't use a lot of adds-on. Just a few ones: Clippings 4.1, ImportExportTools 2.8.0.4, Mark Gmail Read 1.0.2, polish dictionary and recently installed MoreFunctionsForAddressBook. I store huge amount of emails - my profile takes 27,1 GB, where "ImapMail" folder takes 26,8 GB. Anyway before update everything was alright. After update to TB to 31.0 version, problem appeared. One more thing: Im not "mouse-user". I prefer to switch between all form fields using keyboard. I've also noticed (since TB 31.0) when I'm typing an email address in "To:" field, waiting for filling up, then pressing "Tab" - it switches me to the next "To:" field below. If I press "Tab" again, when "To" field is empty, cursor finally goes to "Subject". It's also has changed. Before, to switch to the second field "To" I had to press "Enter", but "Tab" always took me to "Subject" field. It is also inconvenient. Takes more time to fill the form. Now "Enter" and "Tab" works exactly the same way. We are filling the form, and no matter what we press "Tab" or "Enter", It always takes me to the second "To" which people usually doesn't use, and the second press takes to "Subject".
Wayne Mery
  • Top 25 Contributor
  • Moderator
Sprendimų: 600 Atsakymų: 5741

Qrzysio, Thanks for the info. I've experienced the same things while keyboarding. THere are bug reports for these and soneone is looking into it.

Regarding performance, you did not state what happens when you start Thunderbird in safe mode. Please do so.

Qrzysio, Thanks for the info. I've experienced the same things while keyboarding. THere are bug reports for these and soneone is looking into it. Regarding performance, you did not state what happens when you start Thunderbird in safe mode. Please do so.
sfhowes
  • Top 10 Contributor
Sprendimų: 1842 Atsakymų: 9089

As for the slow autocompletion, if the config. fix doesn't help, I would be inclined to see if there's a possible case of address book corruption. If you add or delete a contact, is the edit maintained after you restart TB? Also, I suggest disabling all add-ons except MoreFunctionsForAddressBook and seeing if that makes any difference.

As for the slow autocompletion, if the config. fix doesn't help, I would be inclined to see if there's a possible case of address book corruption. If you add or delete a contact, is the edit maintained after you restart TB? Also, I suggest disabling all add-ons except MoreFunctionsForAddressBook and seeing if that makes any difference.
Qrzysio Sprendimų: 0 Atsakymų: 12

Here is what I tried just now.

1. Safe mode with restored toolbars and disabled all adds-on - didnt help. 2. Safe mode as point 1. Enabled MoreFunctionsForAddressBook, then restart (only this add-on works) - didnt help. 3. Made some changes in address book (edited a few items, deleted another few ones). After restart everything was in the right place - as I left before restart (deleted contacts dont exists, edited ones are changed properly).

In my address book are 1384 personal contacts and 2877 collected addresses. If you want me to use another address book, I can try.

I use TB since version 2. This year (April) I did completely new installation of the newest version of TB. In the past some files were corrupted already, so I wanted to install it properly. Its clean then, I didnt touch any files yet, even didnt move the profile folder to another partition as I did before.

I have 6 accounts, which 4 of them are IMAP. The PC I use is new. SSD hard drive, Intel Core i5-3470 3.2 GHz, 8 GB DDRAM3, Windows 8.1.

Till now everything was alright. no problems at all. After update to the newest version of TB (31.0) these two problems appeared (autocomplete and switching between form's fields).

So it's not really seems like a problem on my side, but software is wrong. If anyone can help me, please let me know here. Im sure Im not the only one.

Here is what I tried just now. 1. Safe mode with restored toolbars and disabled all adds-on - didnt help. 2. Safe mode as point 1. Enabled MoreFunctionsForAddressBook, then restart (only this add-on works) - didnt help. 3. Made some changes in address book (edited a few items, deleted another few ones). After restart everything was in the right place - as I left before restart (deleted contacts dont exists, edited ones are changed properly). In my address book are 1384 personal contacts and 2877 collected addresses. If you want me to use another address book, I can try. I use TB since version 2. This year (April) I did completely new installation of the newest version of TB. In the past some files were corrupted already, so I wanted to install it properly. Its clean then, I didnt touch any files yet, even didnt move the profile folder to another partition as I did before. I have 6 accounts, which 4 of them are IMAP. The PC I use is new. SSD hard drive, Intel Core i5-3470 3.2 GHz, 8 GB DDRAM3, Windows 8.1. Till now everything was alright. no problems at all. After update to the newest version of TB (31.0) these two problems appeared (autocomplete and switching between form's fields). So it's not really seems like a problem on my side, but software is wrong. If anyone can help me, please let me know here. Im sure Im not the only one.
8472 Sprendimų: 0 Atsakymų: 8

I'm not sure whether the MoreFunctionsForAddressBook add-on helps at all, have tried it, but don't see any difference.

I've also noticed something more. I'm using a lot Nickname feature of the Address Book, to add recipients faster. Before, prior to TB 31, it was enough just to write the short nickname, and it was added immediately after I pressed enter. Since TB 31 it isn't working that fast anymore, I have to wait a 1-2 seconds for the autocomplete in order to continue.

(
I'm not sure whether the MoreFunctionsForAddressBook add-on helps at all, have tried it, but don't see any difference. I've also noticed something more. I'm using a lot Nickname feature of the Address Book, to add recipients faster. Before, prior to TB 31, it was enough just to write the short nickname, and it was added immediately after I pressed enter. Since TB 31 it isn't working that fast anymore, I have to wait a 1-2 seconds for the autocomplete in order to continue. :(
blocki Sprendimų: 1 Atsakymų: 4

I have the exact same issue (see https://support.mozilla.org/en-US/questions/1012335 ). Will try the suggested addon and let you know.

Update: No, it does not help. To reproduce the old behavior, I installed the previous TB version as a portable app and imported my contacts. In the TB 24 it is working like a charm. sample@email.id gets automatically filled in if I type just "samp" and hit tab to write the email. It happens with a small delay but it actually autocompletes correctly and works. Not like in TB 31 where you actually have to wait for the results to come up and than hit tab.

I have the exact same issue (see https://support.mozilla.org/en-US/questions/1012335 ). Will try the suggested addon and let you know. Update: No, it does not help. To reproduce the old behavior, I installed the previous TB version as a portable app and imported my contacts. In the TB 24 it is working like a charm. sample@email.id gets automatically filled in if I type just "samp" and hit tab to write the email. It happens with a small delay but it actually autocompletes correctly and works. Not like in TB 31 where you actually have to wait for the results to come up and than hit tab.

Modified by blocki

Qrzysio Sprendimų: 0 Atsakymų: 12

No new ideas?

No new ideas?
jmacauslan Sprendimų: 0 Atsakymų: 26

Further problem: I haven't checked 'MoreFunctionsForAddressBook' yet, but I installed it. And that operation -- unlike other installs in the past -- caused all of my open tabs (emails) to disappear.

Nasty.

Further problem: I haven't checked 'MoreFunctionsForAddressBook' yet, but I installed it. And that operation -- unlike other installs in the past -- caused all of my open tabs (emails) to disappear. Nasty.
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12422

I do not have a huge address book, but I have noticed that the autocomplete is now returning a huge number of addresses.

eg: If I type 'a' then virtually every address is offered.

it seems to be scanning for anything that has an 'a' anywhere in the First Name, Last Name, Display Name, email address or additional email address.

But any email address with a Display Name begining with A will not necessarily be easily findable as they are not listed necessarilly first or in top four. In fact they could be about 20th in the list!

for example: my mother has Display Name as 'Mum' her email address does not have a letter 'a' in it. Her surname does not have an 'a' in it Her first name has a letter 'a' in the middle of the name. This email address is returned in the top 4.

If I type 'm' then I get the first 'M' display name = 'Mum' as number 4 in the list and my website email address 'mail@ etc' will be first in the list, although my name has no 'm' anywhere in it.

The ones where display name have an M at start of name were listed as numbers 4, 5, 7, 14, 35 and later. A total of 149 were listed as returned by the autosearch. note: 49 contacts are in my PAB 60 in another 94 in another 83 in Collected Addresses

some of these were duplicates as I keep an additional record of important in other folder, just in case I lose an address book.

So the search is effectively returning virtually everything.

I also noticed that it returned my brothers email address which has no 'm' anywhere in his name or email address, but there was an 'm' in the middle of his additional email address, so both were returned in the search.


I then switched on the MoreFunctionsFor AddressBook option as stated by sfhowes. Applied same 'm' in a TO field, This time it returned 32 instead of 149.

So I regard this as an improvement. 'M' is now returned for anything where the first letter is 'M' in First name or Surname, or Display Name or email address. It will also return both email addresses if the additional one has 'm' matching the conditions listed above.

Switching on this option in config editor now makes the autocomplete search correct when searching on a one letter condition.

So could it be slowing down because of the nature of the search to return virtually the whole address books and with no apparent order ? I do not experience slowdown as I have few contacts in relative terms, but if the search was going through hundreds or thousands of contacts then it would explain why it was causing problems.

I do not have a huge address book, but I have noticed that the autocomplete is now returning a huge number of addresses. eg: If I type 'a' then virtually every address is offered. it seems to be scanning for anything that has an 'a' anywhere in the First Name, Last Name, Display Name, email address or additional email address. But any email address with a Display Name begining with A will not necessarily be easily findable as they are not listed necessarilly first or in top four. In fact they could be about 20th in the list! for example: my mother has Display Name as 'Mum' her email address does not have a letter 'a' in it. Her surname does not have an 'a' in it Her first name has a letter 'a' in the middle of the name. This email address is returned in the top 4. If I type 'm' then I get the first 'M' display name = 'Mum' as number 4 in the list and my website email address 'mail@ etc' will be first in the list, although my name has no 'm' anywhere in it. The ones where display name have an M at start of name were listed as numbers 4, 5, 7, 14, 35 and later. A total of 149 were listed as returned by the autosearch. note: 49 contacts are in my PAB 60 in another 94 in another 83 in Collected Addresses some of these were duplicates as I keep an additional record of important in other folder, just in case I lose an address book. So the search is effectively returning virtually everything. I also noticed that it returned my brothers email address which has no 'm' anywhere in his name or email address, but there was an 'm' in the middle of his additional email address, so both were returned in the search. I then switched on the MoreFunctionsFor AddressBook option as stated by sfhowes. Applied same 'm' in a TO field, This time it returned 32 instead of 149. So I regard this as an improvement. 'M' is now returned for anything where the first letter is 'M' in First name or Surname, or Display Name or email address. It will also return both email addresses if the additional one has 'm' matching the conditions listed above. Switching on this option in config editor now makes the autocomplete search correct when searching on a one letter condition. So could it be slowing down because of the nature of the search to return virtually the whole address books and with no apparent order ? I do not experience slowdown as I have few contacts in relative terms, but if the search was going through hundreds or thousands of contacts then it would explain why it was causing problems.
JoshClegg Sprendimų: 1 Atsakymų: 23

I have the same problems, and I don't want to install "extra software" to fix a problem that hasn't been in any version of Thunderbird before 31.

And it gets worse. Sometimes when I type just one letter of an e-mail address, Thunderbird hangs, goes white-out screen, and does not come back. I have to physically exit Thunderbird using Task Manager.

There's something very wrong about 31's auto-fill algorithm.

Win 7 Pro 8GB RAM SSD about 5000 contacts in address book

I have the same problems, and I don't want to install "extra software" to fix a problem that hasn't been in any version of Thunderbird before 31. And it gets worse. Sometimes when I type just one letter of an e-mail address, Thunderbird hangs, goes white-out screen, and does not come back. I have to physically exit Thunderbird using Task Manager. There's something very wrong about 31's auto-fill algorithm. Win 7 Pro 8GB RAM SSD about 5000 contacts in address book
PhilEvans Sprendimų: 0 Atsakymų: 6

Naudingas atsakymas

Just to add my voice to the list: I also have this problem, and critically, it's the "what happens when I hit tab/enter" that annoys me. Installing the add-on sped up the auto complete (although I think this sort of option should be a clickable option in the main preferences, not an add-on plus config-editor level change). But, even with this on, if I type "Dad" and press enter then instead of my dad's email address appearing in the "to" box, "Dad" remains there alone - I have to type "dad", wait for the auto complete to run, and then press enter/tab. Even though "Dad" is a complete nickname in the address book. This is a definite worsening of TB31 compared to previously and needs fixing ASAP or sooner.

Just to add my voice to the list: I also have this problem, and critically, it's the "what happens when I hit tab/enter" that annoys me. Installing the add-on sped up the auto complete (although I think this sort of option should be a clickable option in the main preferences, not an add-on plus config-editor level change). But, even with this on, if I type "Dad" and press enter then instead of my dad's email address appearing in the "to" box, "Dad" remains there alone - I have to type "dad", wait for the auto complete to run, and then press enter/tab. Even though "Dad" is a complete nickname in the address book. This is a definite worsening of TB31 compared to previously and needs fixing ASAP or sooner.
mark70 Sprendimų: 0 Atsakymų: 8

I'm having the same problem and it's a bug in Thunderbird. I'm running a Core i7, 16GB RAM, SSD. It's a brand new fast machine.

I have the same issue on my other Core i7 desktop.

Both of these worked fine until 31 was installed.

Now the same problem. I used to type "ryan<enter>" as fast as I wanted to and it would auto-fill correctly.

Now I do the same thing and all that's left in the address field is "ryan" without having expanded to the address that matches.

I don't think that a third party plug-in is a solution. I also think that if a name is typed in, even if I hit enter before Thunderbird is done looking up, that it should still pick an address with some sort of order has to how to do it.

1) If a nickname exists for a contact named "ryan" then that should be the address auto-filled.

2) If a name exists with Ryan at the beginning, then that should be auto-filled.

3) if none of the above, then the first address that matches Ryan somewhere in the name/nickname then perhaps that should be auto-filled.

If the auto-fill isn't the one I want, then I should be able to go back and correct it, but I hate having to go back to the previous address and retype and wait for TB to present the list. Seriously. Is there a bug logged for this one yet?

I'm having the same problem and it's a bug in Thunderbird. I'm running a Core i7, 16GB RAM, SSD. It's a brand new fast machine. I have the same issue on my other Core i7 desktop. Both of these worked fine until 31 was installed. Now the same problem. I used to type "ryan<enter>" as fast as I wanted to and it would auto-fill correctly. Now I do the same thing and all that's left in the address field is "ryan" without having expanded to the address that matches. I don't think that a third party plug-in is a solution. I also think that if a name is typed in, even if I hit enter before Thunderbird is done looking up, that it should still pick an address with some sort of order has to how to do it. 1) If a nickname exists for a contact named "ryan" then that should be the address auto-filled. 2) If a name exists with Ryan at the beginning, then that should be auto-filled. 3) if none of the above, then the first address that matches Ryan somewhere in the name/nickname then perhaps that should be auto-filled. If the auto-fill isn't the one I want, then I should be able to go back and correct it, but I hate having to go back to the previous address and retype and wait for TB to present the list. Seriously. Is there a bug logged for this one yet?
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12422

there is a bug reported and there is a lot of effort being done to try to fix. You can Vote for the bug:

re 'I don't think that a third party plug-in is a solution. I agree, it is not a solution, it is a temp workaround whilst the developers look at resolving this issue. You have a couple of options until a fix is implemented.

  1. Live with the problem until a fix update.
  2. Try the workaround information to make life easier.
  3. Go back to a previous version - info below

eg: version 24.7 can be located here:

choose the one suitable for your OS eg: win32 = Windows. then select the language eg: en-GB = english British then download the .exe file.

Note: If you go back to a previous version, remember to stop Thunderbird from performing auto updates.

  • Tools > Options > Advanced > Update tab
there is a bug reported and there is a lot of effort being done to try to fix. You can Vote for the bug: * https://bugzilla.mozilla.org/show_bug.cgi?id=970456 re 'I don't think that a third party plug-in is a solution. I agree, it is not a solution, it is a temp workaround whilst the developers look at resolving this issue. You have a couple of options until a fix is implemented. # Live with the problem until a fix update. # Try the workaround information to make life easier. # Go back to a previous version - info below eg: version 24.7 can be located here: * ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/24.7.0/ choose the one suitable for your OS eg: win32 = Windows. then select the language eg: en-GB = english British then download the .exe file. Note: If you go back to a previous version, remember to stop Thunderbird from performing auto updates. * Tools > Options > Advanced > Update tab
Matt
  • Top 10 Contributor
  • Moderator
Sprendimų: 3362 Atsakymų: 23309

This bug should be fixed in V31.1 in so much as the search is now faster, but the search is now on "contains" not "begins with" so other changes in behaviour may well be observer like typing certain strings no longer gets the same result.

This bug should be fixed in V31.1 in so much as the search is now faster, but the search is now on "contains" not "begins with" so other changes in behaviour may well be observer like typing certain strings no longer gets the same result.
PhilEvans Sprendimų: 0 Atsakymų: 6

Thanks for that update Matt.

One question: you refer to the speed of the lookup, and indeed the actual bug report only seems to refer to that. But many of the comments here, which direct to that bug report, are not just the speed but are the fact that when one tabs away from the "to" box, autocomplete stops completely (whereas in the old version, I could type "dad" and press enter, and, upon me pressing enter, "dad" would resolve to my dad's email address). Is that issue also resolved?

Thanks for that update Matt. One question: you refer to the speed of the lookup, and indeed the actual bug report only seems to refer to that. But many of the comments here, which direct to that bug report, are not just the speed but are the fact that when one tabs away from the "to" box, autocomplete stops completely (whereas in the old version, I could type "dad" and press enter, and, upon me pressing enter, "dad" would resolve to my dad's email address). Is that issue also resolved?