X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Extremly slow autocomplete for addresses after Thunderbird update

Paskelbta

Yesterday I upgraded Thunderbird from version 30 to 31, now while I writing messages the autocomplete for addresses is extremly slow to suggest contacts. If I enter only a letter in the destination field, thunderbird hangs for about twenty seconds and after show me the suggestions. Typing two letters quickly, thunderbird hangs for 13 seconds. typing 3 after 6 seconds All tested even in safe mode I have a local address book with about 9870 contacts (no remote address book) and before the upgrade everything worked fine

Yesterday I upgraded Thunderbird from version 30 to 31, now while I writing messages the autocomplete for addresses is extremly slow to suggest contacts. If I enter only a letter in the destination field, thunderbird hangs for about twenty seconds and after show me the suggestions. Typing two letters quickly, thunderbird hangs for 13 seconds. typing 3 after 6 seconds All tested even in safe mode I have a local address book with about 9870 contacts (no remote address book) and before the upgrade everything worked fine

Modified by Wayne Mery

Chosen solution

The problem may be due to the new feature in autocomplete that searches for matches that include the entered string, not just ones that match the beginning of address book fields, which was the old method.

If you install MoreFunctionsForAddressBook, it will add a preference, morecols.autocomplete.match_just_beginning, which you can switch to true, and see if it makes any difference. Tools(or AppMenu/Options)/Options/Advanced/General/Config. editor, paste the preference in Search and double-click it to switch from false to true.

Edit: Version 0.7 of MoreFunctionsForAddressBook includes this switch on the Autocomplete tab of its Options (valid for TB 31+).

Skaityti atsakymą kartu su kontekstu 12

Papildomi duomenys apie sistemą

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

Qrzysio Sprendimų: 0 Atsakymų: 12

Any difference after updating to 31.1.1?

Perhaps it's a little but faster, but it's still far far away to the speed we had in the past.

Any difference after updating to 31.1.1? Perhaps it's a little but faster, but it's still far far away to the speed we had in the past.
Matt
  • Top 10 Contributor
  • Moderator
Sprendimų: 3391 Atsakymų: 23491

I am not aware of it even being considered, but try it and let me know. I think it was probably a result of the slow lookup anyway but only once the fix is out there can other underlying issues often be clearly identified.

I am not aware of it even being considered, but try it and let me know. I think it was probably a result of the slow lookup anyway but only once the fix is out there can other underlying issues often be clearly identified.
PhilEvans Sprendimų: 0 Atsakymų: 6

I can confirm that this aspect of the problem is not fixed in 31.1.1 (I have tried with and without the addon "More Functions For Address Book" enabled).

it looks like, once you tab away from a field, the autocomplete function is aborted, whereas it used to continue.

I can confirm that this aspect of the problem is not fixed in 31.1.1 (I have tried with and without the addon "More Functions For Address Book" enabled). it looks like, once you tab away from a field, the autocomplete function is aborted, whereas it used to continue.
Qrzysio Sprendimų: 0 Atsakymų: 12

I noticed exactly the same behavior as "PhilEvans".

I noticed exactly the same behavior as "PhilEvans".
mark70 Sprendimų: 0 Atsakymų: 8

Naudingas atsakymas

See http://screencast.com/t/D38IYyk2

So it's when I type at normal speed and don't stop (hitting enter as soon as I type the name) the name is not auto completed.

If I wait, the list comes up and the autocomplete happens. But what busy person wants to wait. I want my fingers to fly and since I type fast, this is a royal PITA.

See http://screencast.com/t/D38IYyk2 So it's when I type at normal speed and don't stop (hitting enter as soon as I type the name) the name is not auto completed. If I wait, the list comes up and the autocomplete happens. But what busy person wants to wait. I want my fingers to fly and since I type fast, this is a royal PITA.
jmacauslan Sprendimų: 0 Atsakymų: 26

Strongly concur with mark70. By far the most expensive processor in my office isn't my PC, it's ME. Waiting for a needlessly slow application on my PC, "reprogramming" me to slow down for it, or having to interrupt & fix the resulting mistakes, is exceptionally poor use of time.

Strongly concur with mark70. By far the most expensive processor in my office isn't my PC, it's ME. Waiting for a needlessly slow application on my PC, "reprogramming" me to slow down for it, or having to interrupt & fix the resulting mistakes, is exceptionally poor use of time.
blocki Sprendimų: 1 Atsakymų: 4

I came to the conclusion to downgrade and than also switch the client to FossaMail (same developer from PaleMoon). Now I am totally fine again and do not miss anything from the new TB version.

I came to the conclusion to downgrade and than also switch the client to FossaMail (same developer from PaleMoon). Now I am totally fine again and do not miss anything from the new TB version.
deepestbluetoo Sprendimų: 0 Atsakymų: 4

This did not solve the problem for me, however by shear fluke I stumbled on the following solution.

Address book>tools>Options>Composition>Addressing> remove tick from directory server.

Happy happy

This did not solve the problem for me, however by shear fluke I stumbled on the following solution. Address book>tools>Options>Composition>Addressing> remove tick from directory server. Happy happy
chrishecker Sprendimų: 0 Atsakymų: 1

I just typed a reply and it seems like it got eaten? I guess I'll type it again...

I'm having problems with autocomplete since upgrading to 31.2.0 from 2x as well. If I type jon<enter> then in 2x I'd get my friend jon's email in the box. Now, I just get "jon" in the box, not a valid email or anything. This is really terrible for my workflow, because it makes me either wait for a completion before hitting enter, which sucks, or makes me go back to fix it when I hit enter too early, which also sucks.

I don't know if this is because completion is slower now and I was completing before I hit enter before, or if it would default to the first returned completion on enter, but either way, it's really annoying.

Is there a bug for this? The bug listed above is for the completion order.

Chris

I just typed a reply and it seems like it got eaten? I guess I'll type it again... I'm having problems with autocomplete since upgrading to 31.2.0 from 2x as well. If I type jon<enter> then in 2x I'd get my friend jon's email in the box. Now, I just get "jon" in the box, not a valid email or anything. This is really terrible for my workflow, because it makes me either wait for a completion before hitting enter, which sucks, or makes me go back to fix it when I hit enter too early, which also sucks. I don't know if this is because completion is slower now and I was completing before I hit enter before, or if it would default to the first returned completion on enter, but either way, it's really annoying. Is there a bug for this? The bug listed above is for the completion order. Chris
deepestbluetoo Sprendimų: 0 Atsakymų: 4

Sorry Chris, I don't have a clue.

I'm just a dumb use that stumbled across a solution to my problem (or a fortunate coincidence).

I just happened to notice that the server option in the addressing window was ticked. Clear the tick box and never looked back!

I guess the problem was that TB was looking for an address book that never existed.

Good luck

Sorry Chris, I don't have a clue. I'm just a dumb use that stumbled across a solution to my problem (or a fortunate coincidence). I just happened to notice that the server option in the addressing window was ticked. Clear the tick box and never looked back! I guess the problem was that TB was looking for an address book that never existed. Good luck
mark70 Sprendimų: 0 Atsakymų: 8

@deepestbluetoo, I don't have "directory server" checked/ticked, and the problem remains.

I don't doubt that having that ticked added to the slowness, but I still have issues with autocomplete not autocompleting if I hit enter before it completes. Somebody definitely broke between 2x and 3x. If you watch my screencast mentioned earlier in this threat, that is with the box you speak of being unticked. It's a matter of < 1/4 of a second. If I deliberately wait, it will autocomplete. If I'm crunching through adding addresses and I type fast, the autocomplete fails to happen.

@deepestbluetoo, I don't have "directory server" checked/ticked, and the problem remains. I don't doubt that having that ticked added to the slowness, but I still have issues with autocomplete not autocompleting if I hit enter before it completes. Somebody definitely broke between 2x and 3x. If you watch my screencast mentioned earlier in this threat, that is with the box you speak of being unticked. It's a matter of < 1/4 of a second. If I deliberately wait, it will autocomplete. If I'm crunching through adding addresses and I type fast, the autocomplete fails to happen.
deepestbluetoo Sprendimų: 0 Atsakymų: 4

This is not the same problem, when typing an address the auto complete would hang for about 15 seconds or so for each key stroke! You can imagine the frustration.

To be honest with my typing speed I would not notice the problem that your having.

Good luck.

This is not the same problem, when typing an address the auto complete would hang for about 15 seconds or so for each key stroke! You can imagine the frustration. To be honest with my typing speed I would not notice the problem that your having. Good luck.
curmudgeon942 Sprendimų: 0 Atsakymų: 7

I'm using TB 31.3.0 and have had this draggy autocompletion that is driving me nuts. The suggested extension/plug-in made no difference at all. Well, it seemed better on the first try and then reverted to the same old stuff.

\BUT THEN: I tried this: in Tools, Options, composition tab, there is a tab "addressing" . that page includes a variety of autocompletion options. On mine a checked option included "directory server" and yet no server was identified. there is no directory server to check.

I UNCHECKED that box, and my initial results were fast. Like in the olden days. I am hopeful

I'm using TB 31.3.0 and have had this draggy autocompletion that is driving me nuts. The suggested extension/plug-in made no difference at all. Well, it seemed better on the first try and then reverted to the same old stuff. \BUT THEN: I tried this: in Tools, Options, composition tab, there is a tab "addressing" . that page includes a variety of autocompletion options. On mine a checked option included "directory server" and yet no server was identified. there is no directory server to check. I UNCHECKED that box, and my initial results were fast. Like in the olden days. I am hopeful
jmacauslan Sprendimų: 0 Atsakymų: 26

Alas, my "directory server" box was already unchecked, and I have had the problem for a while now. (Currently running TB 34.x.)

Alas, my "directory server" box was already unchecked, and I have had the problem for a while now. (Currently running TB 34.x.)
Matt
  • Top 10 Contributor
  • Moderator
Sprendimų: 3391 Atsakymų: 23491

jmacauslan said

(Currently running TB 34.x.)

With these issues the X is important. There has been more than one "fix" to address auto complete since 34.0 If your not on 31.3 you need to be and 31.4 will rationalize the begins with Vs includes for the auto complete to prioritize begins with, so it is another must have.

''jmacauslan [[#answer-674545|said]]'' <blockquote> (Currently running TB 34.x.) </blockquote> With these issues the X is important. There has been more than one "fix" to address auto complete since 34.0 If your not on 31.3 you need to be and 31.4 will rationalize the begins with Vs includes for the auto complete to prioritize begins with, so it is another must have.
jmacauslan Sprendimų: 0 Atsakymų: 26

Point taken: Version is 31.3.0, and TB does not suggest any later version for me, as of now.

Point taken: Version is 31.3.0, and TB does not suggest any later version for me, as of now.
felixschweizer Sprendimų: 0 Atsakymų: 1

The fix was working for me up to 31.3.0 I just upgraded to 31.4.0 and the issue is back. Its not as bad as it was. But if I type and immediately hit enter, the address does not expand. If I hesitate just a bit, then hit enter, the program hangs a bit but then autocompletes. The issue is now fractions of a second vs 2-5 seconds or more, but unless you type more than 60 keys a minute, that is still an issue!

I am running Win7Pro Thunderbird 31.4.0 with all addons disabled.

The fix was working for me up to 31.3.0 I just upgraded to 31.4.0 and the issue is back. Its not as bad as it was. But if I type and immediately hit enter, the address does not expand. If I hesitate just a bit, then hit enter, the program hangs a bit but then autocompletes. The issue is now fractions of a second vs 2-5 seconds or more, but unless you type more than 60 keys a minute, that is still an issue! I am running Win7Pro Thunderbird 31.4.0 with all addons disabled.