Back up and restore information in Firefox profiles

Kol kas dar niekas nepadėjo išversti šio straipsnio. Prisijunkite prie mūsų ir padėkite tai atlikti!

Mozilla Firefox stores all your personal settings, such as bookmarks, passwords and extensions, in a profile folder on your computer, in a location separate from the Firefox program. This article explains how to back up your profile, restore it, or move your profile to a new location or computer.

Locate your profile folder

The default location of the Firefox profile folder is %APPDATA%\Mozilla\Firefox\Profiles\xxxxxxxx.default\.

  • %APPDATA% is shorthand for the C:\Users\<username>\AppData\Roaming\C:\Documents and Settings\<username>\Application Data\ folder, which depends on your Windows user account name.

The default location of the Firefox profile folder is ~/Library/Application Support/Firefox/Profiles/xxxxxxxx.default/.

The default location of the Firefox profile folder is ~/.mozilla/firefox/xxxxxxxx.default/.

  • xxxxxxxx represents a random string of 8 characters.

You can locate your profile folder using these instructions:

  1. Click the Windows Start button, and type %APPDATA%\Mozilla\Firefox\Profiles\ in the search box at bottom of the Start menu, without pressing Enter.
  2. A list of profiles will appear at the top of the Start menu. You can click on any of the profiles (e.g. xxxxxxxx.default) to open it with Windows Explorer.

98ed7b83d09ef2c94285fcf99165ff31-1258904886-852-1.png

  1. Click the Windows Start button, and select Run….

    win-run.png

  2. Type in %APPDATA%\Mozilla\Firefox\Profiles\ and then click OK.

    win-rundialog.png

Windows Explorer will open the Profiles folder, which contains a folder for each profile.

  1. Open the Charms and select Search.
  2. Search for Run in Apps.
  3. Select Run in the search results and you will be taken to the Desktop with the Run app open.
  4. In the Run app, type %APPDATA%\Mozilla\Firefox\Profiles\ and then press Enter. Windows Explorer will open the Profiles folder, which contains a folder for each profile.
  1. Click the Finder icon in the dock.
  2. On the menu bar, click the Go menu and select Go to Folder….
  3. In the Go to Folder window, paste in this text: ~/Library/Application Support/Firefox/Profiles and then click Go.
  4. A window will open containing profile folders.
  5. Double-click the folder with “default” in the name to open it.
  1. (Ubuntu) Click the Places menu on the top right of the screen and select Home Folder. A File Browser window will appear.
  2. Click the View menu and select Show Hidden Files if it isn't already checked.
  3. Double click the folder marked .mozilla.
  4. Double click the folder marked firefox. Your profile folders are within this folder.

Backing up your profile

To back up your profile, first close Firefox if it is open and then copy the profile folder to another location.

  1. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  2. Locate your profile folder, as explained above.
  3. Go to one level above your profile's folder, i.e. to %APPDATA%\Mozilla\Firefox\Profiles\~/Library/Application Support/Firefox/Profiles/~/.mozilla/firefox/
  4. Right-clickHold down the Ctrl key while you click on your profile folder (e.g. xxxxxxxx.default), and select Copy.
  5. Right-clickHold down the Ctrl key while you click the backup location (e.g. a USB-stick or a blank CD-RW disc), and select Paste item.

Restoring a profile backup

  1. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  2. If your existing profile folder and profile backup folder have the same name, simply replace the existing profile folder with the profile backup, then start Firefox.
    Important: The profile folder names must match exactly for this to work, including the random string of 8 characters. If the names do not match or if you are restoring a backup to a different location, follow the steps below.

Restoring to a different location

If the profile folder names do not match or if you want to move or restore a profile to a different location, do the following:

  1. Completely close Firefox, as explained above.
  2. Use the Firefox Profile Manager to create a new profile in your desired location, then exit the Profile Manager.
    Note: If you just installed Firefox on a new computer, you can use the default profile that is automatically created when you first run Firefox, instead of creating a new profile.
  3. Locate the backed up profile folder on your hard drive or backup medium (e.g., your USB-stick).
  4. Open the profile folder backup (e.g., the xxxxxxxx.default backup).
  5. Copy the entire contents of the profile folder backup, such as the mimeTypes.rdf file, prefs.js file, bookmarkbackups folder, etc.
  6. Locate and open the new profile folder as explained above and then close Firefox (if open).
  7. Paste the contents of the backed up profile folder into the new profile folder, overwriting existing files of the same name.
  8. Start Firefox.



Share this article: http://mzl.la/LHJo6V

Ar šis straipsnis buvo naudingas? Luktelėkite…

These fine people helped write this article: AliceWyman, Chris_Ilias, Tonnes, Verdi, scoobidiver, Swarnava, greasemonkey, Matt_G, erinereardon. You can help too - find out how.