Mozilla 도움말 검색

고객 지원 사기를 피하세요. 저희는 여러분께 절대로 전화를 걸거나 문자를 보내거나 개인 정보를 공유하도록 요청하지 않습니다. "악용 사례 신고"옵션을 사용하여 의심스러운 활동을 신고해 주세요.

Learn More

unwanted advertising in mozilla address bar

  • 6 답장
  • 0 이 문제를 만남
  • 18 보기
  • 최종 답변자: 38034

more options

I've noticed that Firefox auto-fills the address bar with links to stores. I have disabled address bar auto-fill except for bookmarks.

I've noticed that Firefox auto-fills the address bar with links to stores. I have disabled address bar auto-fill except for bookmarks.

모든 댓글 (6)

more options

Hi, when does the list of stores appear? What I mean is:

(A) You clicked in the bar but you haven't typed anything yet

Normally Firefox will show the first 8-10 shortcuts from the built-in Firefox Home / new tab page. To edit those sites, see the steps in: Customize items on your Firefox New Tab page.

If you never want to see this shortcuts list in the drop-down, uncheck "Shortcuts" on the Settings page, Address Bar section.

If items appear in the blank address bar scenario even after you've turned off Shortcuts, that would be suspicious.

(B) You have started typing text in the bar

Firefox has various icons for different sources of suggestions. These include a little clock icon for search history, a magnifying glass for a real-time/dynamic search engine suggestion, a site icon for history entries, and a site icon with an overlaid star icon for bookmark entries.

What do the store suggestions look like?


You may want to test in Firefox's Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

more options

Sorry, now that I read your question from last week -- Disable linking to Sportcheck.ca and other websites from address bar -- it sounds like you are not referring to the drop-down, but instead to the "in URL bar" autofill feature.

Address bar autofill is enabled/disabled by a hidden preference you could change through about:config if you NEVER want to see those suggestions. Let us know if you need the steps.

The top-level server addresses used for address bar autofill are sourced from a table of servers you have visited at some point in Firefox. There isn't a direct method to flush a server from that separate list, but one possible method is to visit a page on the site, then right-click the history entry and choose the drastic option "Forget About This Site". That feature does a deeper cleaning across Firefox.

more options

jscher2000 - Support Volunteer said

ok, I visited sportchek.ca to add it to my history, then i selected "forget about this site" and tried typing into the address bar again.

when i type "spo" i expect it to auto-fill to spotify, because i go there every day and have it bookmarked.

instead, it auto-fills to sportchek. sportchek is a retailer of sports clothing. why does this happen

more options

Try to enter about:config in the address bar and check the value of the browser.urlbar.suggest.quicksuggest.sponsored preference.

more options

글쓴이 cor-el 수정일시

more options

TyDraniu said

Try to enter about:config in the address bar and check the value of the browser.urlbar.suggest.quicksuggest.sponsored preference.

It is False

But the browser still keeps inserting these unwanted links in the address bar as I'm typing. I just tried going to Spotify because I wanted to listen to music. It auto-filled to Sportchek again and I accidentally went there instead.

Aha, I found a single bookmark to the sportchek website. For some reason, this didn't come up before. I'm deleting that bookmark, hopefully that stops this from happening.

글쓴이 38034 수정일시