Mozilla 도움말 검색

고객 지원 사기를 피하세요. 저희는 여러분께 절대로 전화를 걸거나 문자를 보내거나 개인 정보를 공유하도록 요청하지 않습니다. "악용 사례 신고"옵션을 사용하여 의심스러운 활동을 신고해 주세요.

Learn More

Disable fullscreen warning when mouse moves to the top edge

  • 3 답장
  • 1 이 문제를 만남
  • 11 보기
  • 최종 답변자: jistjak

more options

Ive tried all of these ↓ and the huge annoying black box still covers my screen when my mouse gets close to the top edge (which happens often in games). How do I disable the "URL is now fullscreen. press esc to exit." nagscreen? Please help (ps: concern for my security is irrelevant) full-screen-api.transition-duration.enter 0 0 full-screen-api.transition-duration.leave 0 0 full-screen-api.transition.timeout 0 full-screen-api.warning.delay 0 full-screen-api.warning.timeout 0 ↑ none of that worked

첨부된 스크린샷

모든 댓글 (3)

more options

You get this message when you use a profile with an older Firefox version (i.e. you downgrade), so it looks that you try to use a Firefox Beta profile with a Firefox release.

That is about this code for the DIV #fullscreen-and-pointerlock-wrapper that include both a message for full screen and for pointerlock.

You can hide the full section with this code in userChrome.css

*|div#fullscreen-and-pointerlock-wrapper { display:none!important; }

Hide only the full screen message:

*|div#fullscreen-warning { display:none!important; }

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true


more options

I made the "C:\Users\My Real Name\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxx.default\chrome\userChrome.css" file you suggested and pasted this

  • |div#fullscreen-and-pointerlock-wrapper { display:none!important; }
  • |div#fullscreen-warning { display:none!important; }

Restarted firefox and went to test HappyWheels in fullscreen mode and the Warning still shows everytime the mouse gets close to the top edge.

Im beginning to think this is a problem with the flash plugin itself and not a firefox issue because the fullscreen warning looks different on flash games' fullscreen than it does on html5 fullscreen Flash warning is much larger (size of a debit card) and firefox's warning is about the size of the searchbar.

But Good News tho: I found a workaround that I'm mostly satisfied with. A program called WinScroll allows me to set an area where my mouse will be restricted to. I just make it where i cannot move my mouse within 5 pixels of the top edge.

(ps, i changed some parts of the profile's directory because i'm paranoid.) (pps, the dots are suppose to be asterisks)

글쓴이 jistjak 수정일시

more options

{DELETED}... sorta

글쓴이 jistjak 수정일시