Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Mozilla 도움말 검색

고객 지원 사기를 피하세요. 저희는 여러분께 절대로 전화를 걸거나 문자를 보내거나 개인 정보를 공유하도록 요청하지 않습니다. "악용 사례 신고"옵션을 사용하여 의심스러운 활동을 신고해 주세요.

Learn More

"Use Hardware Acceleration when available" issue

  • 6 답장
  • 5 이 문제를 만남
  • 8 보기
  • 최종 답변자: GarfieldBesa

more options

Hello guys,

I running a simple web application and found out that Italics are not working, unless "USE HARDWARE ACCELERATION" is unchecked / disabled.

Firefox version 25.0 are working fine even the "HARDWARE ACCELERATION" is checked / enabled, but in latest version italics features are not working, here is my simple snippit of the code.

http://jsfiddle.net/Apg4S/31/

Hello guys, I running a simple web application and found out that Italics are not working, unless "USE HARDWARE ACCELERATION" is unchecked / disabled. Firefox version 25.0 are working fine even the "HARDWARE ACCELERATION" is checked / enabled, but in latest version italics features are not working, here is my simple snippit of the code. http://jsfiddle.net/Apg4S/31/

모든 댓글 (6)

more options

Could you post some comparison screen shots so users testing the jsfiddle will know what problem you are seeing?

more options

This is the screen shot. figure 1. Show's that it did italicized the font when the "use hardware acceleration " is unchecked. Figure 2. Show's that the italic feature did not do anything when the "use hardware acceleration" is checked...

however in older version of Firefox, like version 25.0 the italic feature works well without even un-checking the option.

more options

On Windows 7, I get the same result you do: the change works with hardware acceleration disabled, does not work with hardware acceleration enabled.

However, the problem does not occur if I switch to serif (Times New Roman), sans-serif (Arial), or Verdana. Weirdly, Tahoma goes from bold to not bold. When I look at the Windows font folder, there are differences between the styles installed for the different faces:

  • Aharoni: Bold
  • Arial: Regular, Italic, Bold, Bold Italic (and others)
  • Tahoma: Regular, Bold
  • Times New Roman: Regular, Italic, Bold, Bold Italic
  • Verdana: Regular, Italic, Bold, Bold Italic

So that brings some order to the test results: with hardware acceleration enabled, Firefox seems to be using only installed styles and not interpolating (or substituting, or whatever it is doing) when hardware acceleration is disabled.

more options

Then what should be the best work around with this sir? Look for the fonts that has the feature of italics?  :D

And by the way, Thank you for trying to see the result in your own.

more options

I think choosing fonts that ship in multiple styles, or making the oblique face a different font, would be safest. But I'm not experienced with canvas so maybe someone has a workaround.

more options

I guess that's the best way too. Since I'm using Google font's API which style is set only to normal, maybe I should find other font face's which have Italicized feature just like what you said.