• Solved

URL Drag-and-Drop into Windows File Explorer shortcut sometimes fails

Hello, This issue may be related with "[meta] Implement URL parser per URL Standard", opened 9 years ago(!), but updated only 1 month ago (bugzilla). If somehow applicabl… (read more)

Hello, This issue may be related with "[meta] Implement URL parser per URL Standard", opened 9 years ago(!), but updated only 1 month ago (bugzilla). If somehow applicable, just let me know that my issue is already being taken care. Thank you.

D&D a Firefox URL into Windows File Explorer, may fail. Just try it for yourself (Firefox for Windows, version 102):

Will fail (notice the additional folder created): D&D on this URL will fail

Will fail and may even create an invincible 0 byte file (Windows is unable to delete it...): D&D this URL will also fail

Won't fail: D&D this URL will *not* fail


I only noticed this wrong behavior in version 102.0 (Firefox 64-bit for Windows) but, as I use this D&D functionality quite often, I don't believe this problem to have occurred much before 101.x. Only tested it in Windows though (Windows 10 Pro - 21H2 19044.1766, 64-bit). This thus seems to be a BUG introduced in version 101.x or 102.0

By trial & error, I think I eventually found out what is leading the D&D to eventually fail: it's related with the web page title (i.e., the Firefox tab title). This behavior has nothing to do with the URL value itself.

When D&D an URL into File Explorer, the URL shortcut name is supposed to be created with the webpage title. However, Windows filenames have some unsupported characters: \ / : * ? ” <> |

So, I guess Firefox should first parse this title and remove all these unsupported characters (or replace them with, e.g., “-“), before assigning the title to the shortcut name (a .URL file). Which, as I understand it, is not happening anymore. I have not found any issue with the URL value itself.

In fact, the D&D result may vary, depending on the characters the webpage name includes.

If it contains a “/”, it will create one (or more) Windows folders before creating the URL shortcut. E.g., if I D&D a webpage URL into “C:\my URL shortcuts folder”, with title “CAT5E Shielded 3/50μ Gold-Plated”, it will create a shortcut (with the correct link) in C:\my URL shortcuts folder\CAT5E Shielded 3\50μ Gold-Plated.URL Obviously, even though the URL content is right, this is not the expected behavior!

More troublesome can be a webpage title that contains a “:”, because it creates a 0-byte no extension file which sometimes (but not always) refuses to be deleted by Windows. E.g., if I D&D a webpage URL into “C:\my URL shortcuts folder”, with title “ShinobiHub – Article: How to Update”, it will create a zero-byte file in “C:\my URL shortcuts” folder with name “ShinobiHub – Article” (no extension). Trying to remove the file in File Explorer may display the error message: “Item not found. This is no longer located in <PATH>. Verify the item’s location and try again.”

[BTW, after some digging I find out how to remove the file: Just open a DOS window and type: del "\\?\C:\my URL shortcuts folder\ShinobiHub - Article " No need to restart or do anything else, just need to put \\?\ before the directory when using the del command. Also use the tab button to make sure the name is correct; sometimes a space is added at the end that can be easily missed.]

Strangely enough, a “Verified by: Cloudfare” (or something similar) is also display just below Firefox Url.

I’m not sure about the effect of other different unsupported file name characters. Anyway, this was tested in 2 different Windows computers, both with same faulty results. The same operation in Chrome works as expected.

Conclusion: This issue should be easy enough to find but I could not find any *recent* report on a similar issue. That makes me wonder… is this really a bug?... Please help. Thank you. Cecilio

Asked by caecilius 1 day ago

Answered by cor-el 1 day ago

  • Solved

Trying to sign into Google/YouTube/etc. always leads to my old university log in page?

Every time I try to sign into my Google account (including related sites like YouTube), I'm rerouted to the Microsoft sign in page for my old university, and can't log in… (read more)

Every time I try to sign into my Google account (including related sites like YouTube), I'm rerouted to the Microsoft sign in page for my old university, and can't log in. This only happens on Firefox, if I switch to another browser then there's no problem.

So far I've tried:

  • Deleting all of my history including my cache and cookies.
  • Once I'm at the site I'm rerouted to, going into History, right-clicking on the url, and clicking "Forget this site."

Neither have worked. Any suggestions appreciated!

Asked by jonesjulia31 2 days ago

Answered by jonzn4SUSE 2 days ago

  • Solved

Blocking designated websites from search results

I recall recently discovering an option that allowed me to designate websites that I no longer wanted to see in my search results. I thought this was x-useful as it seems… (read more)

I recall recently discovering an option that allowed me to designate websites that I no longer wanted to see in my search results. I thought this was x-useful as it seems there are a few websites that frequently appeared near the top of the search results that were "come-ons"; that is when you click on the link in the search results, they only offered an option to "sign up" for access. I don't want to see this junk, and I did add one website to the list.

I've got another one I want to add, but I can't find the interface to add this website to the list. I thought it was a DuckDuckGo feature, but I don't see it anywhere! Is this a Firefox feature ? ... or have I lost my mind  :P

Asked by tmp003 2 days ago

Answered by tmp003 2 days ago

  • Solved

Cursor dissapears when i press space or `

Whenever I press space to scroll one page down the cursor dissapears. The same thing happens when I press `. As soon as I move the mouse it reappears but this is unwanted… (read more)

Whenever I press space to scroll one page down the cursor dissapears. The same thing happens when I press `. As soon as I move the mouse it reappears but this is unwanted and annoying behavior which didn't happen in the past. I'm not sure when it started happening but it hasn't been long since that. I tried restarting with all the plugins turned off but that didn't help. I'm using the latest version of FF on Win 7 x64.`

Asked by gambit1 4 days ago

Answered by cor-el 2 days ago

  • Solved

Can't sync firefox custom preferences

I know there's [[an article|https://support.mozilla.org/en-US/kb/sync-custom-preferences#w_sync-custom-preferences]] on how to sync custom preferences. I wanted to sync m… (read more)

I know there's [[an article|https://support.mozilla.org/en-US/kb/sync-custom-preferences#w_sync-custom-preferences]] on how to sync custom preferences. I wanted to sync my toolbar customizations and some other preferences like disabling disk caching. And I don't even have other firefox instances, instead I just want to sync only on one device, so that I can continue the same setup when I signin later on the same device.

I've tried to add services.sync.prefs.sync.browser.uiCustomization.state, "services.sync.prefs.sync.browser.cache.disk.enable" and set it to true. But it doesn't work. What am I missing? No one seems to address this. May I am missing something.

Asked by Prince Cooper 3 weeks ago

Answered by Prince Cooper 2 days ago

  • Solved

Missing Bookmarks

An automatic update of Firefox which resulted in a "quit/create new profile" choice has removed all my bookmarks Of the four profiles stored in "about:profile" three are … (read more)

An automatic update of Firefox which resulted in a "quit/create new profile" choice has removed all my bookmarks

Of the four profiles stored in "about:profile" three are identical (ie. have only the default bookmarks stored) and one, generates a "quit/create new profile" message.

The "bookmarksbackup" folder (in /home/user/.Mozilla/Firefox/zs1jki8t.default) is empty.

The "import/backup" option (in Manage Bookmarks) offers nothing to choose. There is no 'list of dated automatic backups.'

Firefox did not create an "Old Firefox Data" folder on the desktop.

Browser privacy "strict". "Never remember history" was selected.

Running Firefox in Manjaro (Linux)

Help.

Asked by Wayn58 3 days ago

Answered by Terry 2 days ago

  • Solved

Can't get rid of google.com as startup page

Hi, Just installed Ubuntu on a new laptop, with Firefox. No add ons. Have changed my homepage to www.duckduckgo. Have changed my default search engine to duckduckgo. In a… (read more)

Hi, Just installed Ubuntu on a new laptop, with Firefox. No add ons.

Have changed my homepage to www.duckduckgo. Have changed my default search engine to duckduckgo. In about:config my browser.startup.homepage says www.duckduckgo.

Have also changed browser.startup.homepage_override.buildID to www.duckduckgo.com and browser.startup.homepage_override.mstone to www.duckduckgo.com

But STILL, every time I start Firefox, I'm taken to google.com. Please cn someone tell me how to stop google coming up when I start Firefox.

Thanks, Ivan

Asked by ivanwonbtanner 2 days ago

Answered by jscher2000 - Support Volunteer 2 days ago

  • Solved

Background inactivity

Hello i've been having some problems on the latest software of yours i'm most of the time watching livestreams but from update v.100 of your software it became weird tab… (read more)

Hello i've been having some problems on the latest software of yours i'm most of the time watching livestreams but from update v.100 of your software it became weird tab suspends after some in activity which is a problem for me

i found a solution through ABOUT:CONFIG and disabled these 3 for videos 1 - media.suspend-bkgnd-video.enabled 2 - media.resume-bkgnd-video-on-tabhover 3 - browser.tabs.unloadOnLowMemory

for videos and live streams it was good it didn't suspend but my problem now since update v.102 is that video plays but the CHAT stops and doesn't reload until i reopen firefox to the front of my programs

although it is runnning in the background and NOT MINIMIZED

even when the live stream has some lags and re-buffer it doesn't rebuffer or refresh the page to reconnect to the live stream until i force my firefox in front of my programs or games and again it was not minimized

if there is an option in the about:config to change this please tell me i'm already losing my mind as i missed one of my friends live stream because of that suspension

thank in advance

Asked by MegaDooOooM 6 days ago

Answered by MegaDooOooM 2 days ago

  • Solved

I am logged off FF, but passwords and addons are still showing

so firefox I am logged out, you can tell where it say "save and sync - sign in". but even though I am not signed in, my passwords and addons are still showing up. how to … (read more)

so firefox I am logged out, you can tell where it say "save and sync - sign in". but even though I am not signed in, my passwords and addons are still showing up.

how to fix this

thank you!!

Asked by Rick (Proton) 6 days ago

Answered by Rick (Proton) 5 days ago

  • Solved

Reddit fails to load on Firefox for the last three days on 102.0 (64 bit) and Windows 10.

So the Reddit website seems to load, but ends up with a big old blank white page. I've cleared my cache, I've cleared my DNS cache. I've pressed ctrl + f5, I've reboote… (read more)

So the Reddit website seems to load, but ends up with a big old blank white page. I've cleared my cache, I've cleared my DNS cache. I've pressed ctrl + f5, I've rebooted the computer. Nothing seems to be aloowing mt to open reddit. Please advise.

Asked by Jeff Brown 3 days ago

Answered by cor-el 3 days ago

  • Solved

igHome and Google Calendar

I am using the latest Firefox version 102.0 and I have igHome set as my home page. Yesterday the Google Calendar Gadget would no longer display the calendar but would dis… (read more)

I am using the latest Firefox version 102.0 and I have igHome set as my home page. Yesterday the Google Calendar Gadget would no longer display the calendar but would display this message:

Firefox Can’t Open This Page To protect your security, accountsgooglecom will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

If I click on the “Open Site in New Window” button it does open the calendar. (See attached screenshot.) I have tried login out and back into igHome and my Google account but it doesn’t fix the issue. This is happening on both my laptop and desktop computers running Windows 10 Home. All Windows updates are up to date. I opened Firefox in Troubleshooting Mode and the calendar still does not show. When I use the Google Chrome browser with the same igHome home page the Calendar works fine. Is this something Firefox can fix, or do I need to contact Google?

Asked by jterps52 5 days ago

Answered by cor-el 3 days ago

  • Solved

Default email setting

Firefox is set as my default email app in W10 - pls see uploaded image. I have tried to change it by using the options at the bottom of that default app screen. I use Sk… (read more)

Firefox is set as my default email app in W10 - pls see uploaded image. I have tried to change it by using the options at the bottom of that default app screen. I use Sky Yahoo mail but I cannot change from Firefox. I want to set Sky Yahoo as my default email for W10.

Any help for this old novice much appreciated.

Thank you.

Asked by R.1C 5 days ago

Answered by Dropa 4 days ago

  • Locked

logins and passwords are gone...

my passwords and logins are not showing..!! even my bookmarks are not showing on firefox after i logged in using my firefox account. please help me resolve this its very … (read more)

my passwords and logins are not showing..!! even my bookmarks are not showing on firefox after i logged in using my firefox account. please help me resolve this its very important Sir/Ma'am.

Asked by karanarunraut 3 days ago

Last reply by Paul 3 days ago

  • Solved

Sign in password problem.

Hi, I hope someone can help me. I am an author and sell my book through KDP Amazon. Firefox is my default browser but will not let me log in to KDP. No problem with othe… (read more)

Hi, I hope someone can help me. I am an author and sell my book through KDP Amazon. Firefox is my default browser but will not let me log in to KDP. No problem with other websites including Amazon.com When I open the KDP log in page it accepts my email address but the password button has a row of asterix right across the window. I cannot delete whatever is in there or change the password via the forgotten password route. Thus to sign in to KDP I have to use an alternate browser. With both Opera and Chrome I can sign in with no problems. I have added a screenshot of the KDP log in which illustrates the problem. Grateful for any solution to this irritation. Thanks, Paul

Asked by paullie1 3 days ago

Answered by jonzn4SUSE 3 days ago

  • Solved

Login Screen Won't Load

One particular website that I login to frequently in Firefox suddenly stopped opening the login screen when I click "Login." It opens in Safari and Tor browsers, but not… (read more)

One particular website that I login to frequently in Firefox suddenly stopped opening the login screen when I click "Login." It opens in Safari and Tor browsers, but not Firefox. How do I get the login screen to appear? I have disabled enabled Pop Up Windows for this site, but it still won't load the login screen. It works in Troubleshoot mode. What does that mean and how do I get it to load the login screen in normal mode?

Asked by jmm0255 4 days ago

Answered by cor-el 3 days ago

  • Solved

Gap to the left of tabs when menu bar is hidden/unchecked

Hello, I am running Firefox v101.0.1 (64-bit) on Linux (Pop!_OS, installed as a flatpak). I am using the default system theme in dark mode, though switching to the Firefo… (read more)

Hello,

I am running Firefox v101.0.1 (64-bit) on Linux (Pop!_OS, installed as a flatpak). I am using the default system theme in dark mode, though switching to the Firefox dark theme or other themes does not change anything. When I allow the Menu Bar (File, Edit, View, etc.) to be present, the browser tabs on the next line are aligned correctly, going all of the way to the left. When I uncheck the Menu Bar, however, a gap appears to the left of the tabs. I have not seen this behavior on Firefox in other environments (Debian, RHEL, Windows), and I'm wondering if there's a way I can remove that gap. I have attached screenshots showing how the tabs are aligned with and without the Menu Bar.

Thanks so much!

Asked by avram.meir 5 days ago

Answered by cor-el 4 days ago

  • Solved

Adblocker stopped working on my Macbook macOS version 12.4 Monterey with this latest Firefox update.

Adblocker stopped working on my Macbook macOS version 12.4 Monterey with this latest Firefox update. It says it is turned on, but pop-up ads AND content blocking are occu… (read more)

Adblocker stopped working on my Macbook macOS version 12.4 Monterey with this latest Firefox update. It says it is turned on, but pop-up ads AND content blocking are occurring on https://www.wunderground.com/weather.

Asked by charlotte14 4 days ago

Answered by charlotte14 3 days ago

  • Solved

Connection to my router is denied

I have the problem with firefox AND edge, that when I want to log into my router, via 192.168.8.1, I receive message that an error has occurred or that it is not secure.… (read more)

I have the problem with firefox AND edge, that when I want to log into my router, via 192.168.8.1, I receive message that an error has occurred or that it is not secure.

How do I avoid these messages? I have made rules in my Bitdefender to allow it, but still it does not work. Any suggestions how to be able to log into my router, is welcomed.

Best regards Stones.

In Swedish: Anslutningen misslyckades

Ett fel uppstod under anslutning till 192.168.8.1.

   Webbplatsen kan tillfälligt vara nere eller upptagen. Försök igen om en stund.
   Om du inte kan öppna sidor, kontrollera datorns nätverksanslutning.
   Om datorn eller nätverket skyddas av en brandvägg eller proxy, kontrollera att Firefox har tillstånd att ansluta till webben.

Asked by Argao1 4 days ago

Answered by Argao1 3 days ago