Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Very small popup windows for "Downloads", "Add bookmark" and "Add extension"

  • 6 replies
  • 1 has this problem
  • 16 views
  • Last reply by Arjit Dixit

more options

As can be seen in screenshots, the popup windows for some of the browser functions is very small and characters are illegible. "Bookmarks" and "History" popups are fine (normal sized), so not all windows are affected.

Problem started when I updated to latest version of Firefox.

The screenshots are from "troubleshooting mode", so yeah... it did not help. I know refresh is my last option, but are there any other ideas to fix the issue? I have quite a few extensions, and re-configuring them will be a pain.

Attached screenshots

Chosen solution

FredMcD said

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file. Close Firefox. Open your file browser to this hidden location:
  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data \Mozilla\Firefox\Profiles\
Search for the above file. Then rename or delete it. Restart Firefox.

Okay, so I tried this and there was no change. I thought there might be some other file in profile which could cause this, so I created a new profile and launched it with no-remote option. The problem was still there.

Now I upgraded from Firefox 87, so I reinstalled Firefox 87 in different location, and launched it with new profile (since existing one not working with old version), and voila problem solved. I did the same thing with version 88, and no problems there as well.

So now I need to use my existing profile with old Firefox version. I looked around and found "allow-downgrade" option. It kind of works now.

I will wait for the problem to get fixed in future releases before upgrading, since the problem seems to be with latest Firefox version 89.

Read this answer in context 👍 0

All Replies (6)

more options

Are you possibly using a multi-monitor setup as that might be causing such an issue ?

Helpful?

more options

cor-el said

Are you possibly using a multi-monitor setup as that might be causing such an issue ?

No. Just a single monitor.

Helpful?

more options

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data \Mozilla\Firefox\Profiles\

Search for the above file. Then rename or delete it. Restart Firefox.

Helpful?

more options

Chosen Solution

FredMcD said

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file. Close Firefox. Open your file browser to this hidden location:
  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data \Mozilla\Firefox\Profiles\
Search for the above file. Then rename or delete it. Restart Firefox.

Okay, so I tried this and there was no change. I thought there might be some other file in profile which could cause this, so I created a new profile and launched it with no-remote option. The problem was still there.

Now I upgraded from Firefox 87, so I reinstalled Firefox 87 in different location, and launched it with new profile (since existing one not working with old version), and voila problem solved. I did the same thing with version 88, and no problems there as well.

So now I need to use my existing profile with old Firefox version. I looked around and found "allow-downgrade" option. It kind of works now.

I will wait for the problem to get fixed in future releases before upgrading, since the problem seems to be with latest Firefox version 89.

Modified by Arjit Dixit

Helpful?

more options

You can try to disable WebRender to see whether this has effect.

You can disable WebRender by setting this pref to true on the the about:config page.

  • gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

cor-el said

You can try to disable WebRender to see whether this has effect. You can disable WebRender by setting this pref to true on the the about:config page.
  • gfx.webrender.force-disabled = true
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Hi cor-el, Tried it but with no effect. Still the same issue persists.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.