Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

Why isn't the popup blocker exception working for sites I have added? It still asks me to "allow" them.

  • 8 件の返信
  • 4 人がこの問題に困っています
  • 36 回表示
  • 最後の返信者: Poole

more options

Even though I have added sites to the Exceptions in the Popup Blocker preferences, I constantly have to press the Allow button to actually go to the next window. The sites are staying in the Exceptions list and I can get there, but something clearly isn't working properly.

Even though I have added sites to the Exceptions in the Popup Blocker preferences, I constantly have to press the Allow button to actually go to the next window. The sites are staying in the Exceptions list and I can get there, but something clearly isn't working properly.

選ばれた解決策

See:

  • Firefox > Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Preferences > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

この回答をすべて読む 👍 0

すべての返信 (8)

more options

If the website domain is different from the popup domain, you will need to add and exception to both the popup domain and website domain.

more options

I have been adding each domain name that pops up that's different from the original website and Firefox is still asking me to "Allow" it. Very frustrating...

more options

Does clicking Allow and remember work?

more options

The only option I'm given is "Allow." There isn't an "Allow and Remember" or anything else available.

more options

Are you using a third party addon or program to block popups?


The below screenshot shows what should be the default options when a popup tries to open. If you click the edit option you should be able to easily added the website to the exception list. Is Firefox not saving your exception list?

more options

I'm simply using Firefox. Haven't modified it, added to it or anything else to my knowledge.

I'm attaching a screen shot of the only option provided for adding an "allow" for a website to be able to simply open another window. I click the Allow button and I've even checked to see that the previous and new webpage are listed in the Exceptions to the Pop-up blocker and they are. But Firefox continues to require me to press "Allow" each time I try to go to the new page.

The site I use most often that continues to have this issue is the USPS.com website, but the 511.org and other sites also have this problem. I get a message indicating that Firefox automatically prevented a page from Re-directing or from Re-loading. I'm attaching both a screen shot of the typical message I get and of the Pop-up Exceptions list (recently cleared).

more options

選ばれた解決策

See:

  • Firefox > Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Preferences > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

この投稿は cor-el により に変更されました

more options

Poole said

Even though I have added sites to the Exceptions in the Popup Blocker preferences, I constantly have to press the Allow button to actually go to the next window. The sites are staying in the Exceptions list and I can get there, but something clearly isn't working properly.

Thank you! This finally seems to be the needed solution. I didn't realize there were two different things going on (with Pop up Blocker and Warning about websites redirecting pages). Thank you again!