Thunderbird への移行

Apple Mail から Thunderbird への移行

Thunderbird は、メッセージと OS X のアドレス帳をインポートできますが、アカウント設定はインポートできません。(今のところ、メッセージとアドレス帳のインポートは、Apple Mail 5.0 以前のバージョンにのみ対応しています。)

Apple Mail メッセージのインポート

  1. メニューバー上の ツール メニューを開き、設定とデータを読み込む... をクリックします。読み込みアシスタントが開きます。

    mac-toolsimport

  2. Mail を選択し、続ける ボタンをクリックします。

    mac-importwizard

  3. Apple Mail を選択し、続ける ボタンをクリックします。

    mac-importmail

  4. フォルダーの読み込み完了のログが表示されます。完了 ボタンをクリックしてインポートアシスタントを閉じてください。

    mac-mailimportedsuccess

インポートされたメッセージは、ローカルフォルダーのアカウントの "Apple Mail Import" フォルダーに読み込まれます。
mac-whereimportedmail

OS X アドレス帳のインポート

Thunderbird は、OS X のアドレス帳を読み取り、Thunderbird のアドレス帳ウインドウに表示します。メニューバーの ウインドウ メニューを開き、アドレス帳 をクリックしてください。左ペインに OS X のアドレス帳が表示されます。
mac-OSXaddressbook

OS X のアドレス帳を Thunderbird のアドレス帳にインポートしたいときは、連絡先を Mac OS X アドレス帳のフォルダーから個人用アドレス帳へドラッグしてください。

補足: command キーを押しながら A キーを押すと、一度にすべての連絡先を選択できます。

Windows Mail または Windows Live Mail から Thunderbird への移行

Windows Mail は、Windows Vista に含まれる既定のメールクライアントです。 Windows Live Mail は、Windows Live Essentials に同梱されたメールクライアントです。 どちらのクライアントプログラムも、メールを eml 形式のファイルに格納します。このメッセージを Windows Mail や Windows Live Mail から Thunderbird へ移行するには、Windows アプリケーションからメッセージをエクスポートし、それを Thunderbird へインポートしなければなりません。アドレス帳の移行についても、同様の方法で行う必要があります。

Windows Mail または Windows Live Mail のメールファイルが保存された場所を見つけるには、メニューの ツール > オプション > 詳細設定タブ を開き、メンテナンス... ボタン、保存フォルダー... ボタンの順にクリックします。


Windows Mail メッセージのインポート

Windows Mail (.eml ファイル) から Thunderbird へのインポートは、サードパーティ製のアドオンである ImportExport Tools を使用し、メッセージ形式を変換してインポートします。ImportExportTools アドオン をダウンロードし、Thunderbird にインストールしてください。

  1. まず、Windows Mail でメッセージを .eml 形式のファイルにエクスポートしておいてください。(Windows Mail のメニューの ファイル > エクスポート > メッセージ からエクスポートできます。)
  2. Thunderbird で、"ローカルフォルダー" 内にインポートしたメールを格納するためのフォルダーを作成してください。
  3. 作成したフォルダーを右クリックし、 ImportExportTools > フォルダーからすべての eml ファイルをインポート > サブフォルダーも含む を選択します。
  4. .eml ファイルを保存したフォルダーを開いてください。Windows Live Mail の既定の場所は、C:\Users\<username>\AppData\Local\Microsoft\Windows Live Mail (または \Windows Mail) です。
    注意: "App Data" フォルダーを表示するには、先に Windows エクスプローラーの ツール > フォルダー オプション を開き、表示 タブの詳細設定で "ファイルとフォルダーの表示" を 隠しファイル、隠しフォルダー、および隠しドライブを表示する に設定しておく必要があります。
  5. 開く ボタンをクリックすると、メッセージデータがインポートされます。

Windows Mail アドレス帳のインポート

Windows アドレス帳を Thunderbird にインポートするには、アドレス帳をテキストファイル (.csv 形式) にエクスポートし、それを Thunderbird にインポートしなければなりません。Windows でアドレス帳をエクスポートする手順は、Microsoft.comOutlook から連絡先をエクスポートする の記事をご覧ください。

必要なファイルをエクスポートした後、Thunderbird のインポートウィザードを使用してアドレス帳をインポートしてください:

  1. Thunderbird の ツール メニューから 設定とデータのインポート... を選択します。
  2. アドレス帳 を選び、次へ ボタンをクリックします。
  3. テキストファイル (LDIF, .tab, .csv, .txt) を選び、次へ ボタンをクリックします。
  4. アドレス帳ファイルの選択ウィンドウで、右下のドロップダウンリストから カンマ区切り (または すべてのファイル) を選び、エクスポートした .csv ファイルを選択して 開く ボタンをクリックしてください。
  5. インポートが完了したら、完了 ボタンをクリックします。

次に、アドレス帳のインポートウィンドウで、上へ移動下へ移動 ボタンを使い、左側のアドレス帳の各フィールドと右側のインポートするデータを正しく一致させてください。インポートしたくないデータは、項目のチェックマークを外してください。作業が完了したら OK ボタンをクリックします。アドレス帳が Thunderbird にインポートされ、使用できるようになります。

注記: アドレス帳の各フィールドが正しくインポートされない (アドレス帳のインポートウィンドウで、最初のフィールドにすべての項目が表示されてしまうなど) 場合は、エクスポートした .csv ファイルの書式がカンマ (,) の代わりにセミコロン (;) または他の記号で区切られている可能性があります。これは、例えば、.csv ファイルを英語版の Windows でエクスポートし、他の言語版の Thunderbird でインポートしようとした場合に起こることがあります。つまり、リスト (または値) の区切り文字が、Windows の地域設定と Thunderbird のロケールの言語の間で異なっている可能性があります。この場合は、.csv ファイルにエクスポートする前に、区切り文字を Windows の地域設定と合わせるか、すでにエクスポートした .csv ファイルを、テキストエディタを使用してすべてのセミコロンをカンマに (あるいはカンマからセミコロンに) 置き換える必要があります。その後、インポートの手順を再度お試しください。

Outlook と Eudora からのインポート

通常の Thunderbird のインポート手順では、Eudora や Outlook がコンピューターにインストールされている必要があります。これらがインストールされていない場合は、以下の代わりの手順でインポートしてください。

Thunderbird のインポート手順を用いるには、Thunderbird バージョン 38 およびそれ以降のバージョンでは Outlook と Eudora 向けのインポートウィザードが無効化されているため、古いバージョンの Thunderbird を使用する必要があります。バージョン 31.8 (注: Mac OS 版は こちら) をインストールし、データをインポートしてから、Thunderbird の 更新機能 を利用して最新バージョンの Thunderbird へアップグレードしてください。

Eudora について、データの問題やクラッシュが起こる場合は、さらに古いバージョンの Thunderbird で試し、データを整理してください。Mac OS 向けのデータ整理ツールには、Eudora Mailbox Cleaner があります。

Thunderbird のインポートウィザードの代わりとしては、メールデータを mbox 形式 (.mbx) に変換するツールを見つけ、Thunderbird の Import Export Tools アドオンを利用して mbox ファイルをインポートする方法があります。Eudora 向けの mbox への変換ツールには、Eudora Rescue があります。

Eudora がインストールされていない

Eudora がインストールされておらず、Thunderbird のインポートウィザードを使用したい場合は、Eudora ファイルを指す Windows のレジストリーを変更するだけで、インポートウィザードを実行することができます。

  • eudora.reg という名前で .reg ファイル を作成し、以下の行を含めてください。ただし、"H:\\SCRATCH\\Eudoradata" をご使用のコンピューターの Eudora データがある場所に書き換えてください。(バックスラッシュ記号 2 個と空行に注意)

=== Registry file, adjust file location as required ===
Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Qualcomm\Eudora\CommandLine]
"Current"="Anything H:\\SCRATCH\\Eudoradata Anything"
===

  • Windows のコマンドプロンプトで次のコマンドを実行します: regedit /s eudora.reg
  • Thunderbird のインポートウィザードを実行します。

Evolution から Thunderbird への移行

以下は、Evolution のメッセージとアドレス帳を Thunderbird にインポートする手順です。

Evolution メッセージのインポート

Thunderbird と Evolution は、メールの格納形式に同じフォーマット (mbox 形式) を使用しています。そのため、メッセージのインポートは難しくありません。

  1. Nautilus を開いてください。
  2. Evolution のメールが格納されたフォルダー (~/.local/share/evolution/mail/local) を開きます。
  3. 拡張子無しのファイル (Inbox, Outbox など) をすべて、Thunderbird のメールが格納されたフォルダー (例: ~/.thunderbird/xxxxxxxx.default/Mail/Local Folders。"xxxxxxxx" は任意の文字列) にコピーしてください。
    Thunderbird に既存のメールがある場合は、ファイルを上書きすると置き換えられてしまうので注意してください。
  4. Thunderbird を起動し、すべてのメールが正しくインポートされているか確認してください。

Evolution アドレス帳のインポート

  1. Evolution のアドレス帳を開いてください。連絡先を右クリックし、Save as vcard... を選択して vCard 形式のファイルにエクスポートします。
  2. エクスポートしたファイルを Thunderbird にインポートします:
    • Thunderbird 3 および 3.1 の場合は、vCard ファイルをインポートできるようにするために MoreFunctionForAddressBook 拡張機能をインストールしておく必要があります。この拡張機能をインストールしたら、Thunderbird のアドレス帳ウィンドウを開き、連絡先一覧のエリアを右クリックして Import vCard/vcf を選択します。次に、上記の手順で保存した .vcf ファイルを選択してください。
    1. Thunderbird 5 以降の場合は、ツール > インポート... メニューを開き、アドレス帳 を選択して 次へ ボタンをクリックし、vCard file ( *.vcf) を選択して連絡先ファイルを選択してください。

ウェブベースのメールアプリケーションから Thunderbird への移行

あなたのインターネットサービスプロバイダー (ISP) により提供されている ウェブベースのメールアプリケーションを利用している場合は、メールアカウントを Thunderbird で設定するだけで移行できるでしょう。設定手順は アカウントの手動設定 の記事をご覧ください。また、特定の ISP の設定方法については ISP ごとのアカウント設定 の記事を参照してください。

一度 Thunderbird でアカウントの設定を行えば、すべてのメッセージ (受信メールと送信メール) へアクセスできるようになるはずです。しかしながら、アドレス帳 (連絡先) やメールフィルタ、その他の設定は自動的に Thunderbird へ転送されません。

一部のウェブベースのメールアプリケーションには、アドレス帳をカンマ区切りのテキストファイルにエクスポートする機能があります。詳しくは、ご利用の ISP のドキュメントを参照するか、ISP にお問い合わせください。アドレス帳をインポートするには、Thunderbird のメニューの ツール > 設定とデータのインポート... を選択し、画面の指示に従ってください。

参照

この記事は役に立ちましたか? しばらくお待ちください...

この記事の貢献者: marsf。あなたも手助けしませんか?- 貢献するにはこちらから