X
Tocca qui per la versione per piattaforma mobile del sito.
La versione utilizzata di Firefox è obsoleta e costituisce un rischio per la sicurezza! Aggiornare Firefox

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Java not working in Firefox

Inviato

I am having trouble getting Java to work in Firefox (Opera too) on Mac. http://www.java.com/en/download/installed.jsp?detect=jre tells me "We are unable to verify if Java is currently installed and enabled in your browser." Notice that when I access the page, Firefox wants me to activate Java in a pop-up. I did this.

I know that Java is installed because I can open the Java Control Panel. The setting "Enable Java content in the browser" is checked and Security Level is set to High. I have tried setting the security level to a lower setting, but that doesn't help.

I have verified that the Java plugin is enabled. I have tried clearing Java cache via the control panel - no luck.

I realise that Apple has blocked Java according to this article: http://appleinsider.com/articles/13/01/31/apple-again-blocks-latest-version-of-java-through-os-x-anti-malware-system. I have been able to get Java to work with Safari (this doesn't help for Firefox) by editing the file /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist, but that is only a temporary solution, as it shouldn't be necessary to do this edit.

Version details: Mac OS X 10.8.2 Firefox 18.0.1 Java version 7 update 11

Dettagli aggiuntivi sul sistema

Plugin installati

  • Version 3.13.1.11376
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0
  • 20-20 Technologies - 20-20 3D Viewer for IKEA v5.0.94.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • doubleTwist Web Plugin
  • Picasa plugin.
  • 20-20 Technologies - 20-20 3D Viewer v5.0.4.0
  • iPhoto6

Applicazione

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

Ulteriori informazioni

ideato
  • Top 25 Contributor
617 soluzioni 4263 risposte

Hello epb9, your solution is the only one that maybe works right now, see AliceWyman's reply in the next link: https://support.mozilla.org/en-US/forums/contributors/708898?last=50518#post-50518

thank you

Utente che ha posto la domanda

Yeah, it says that it is the only way to get it to work in FF. But that solution only works for Safari on my computer :(

I have now installed java 7 update 13. Now it works in Safari without any tweaks, but it still doesn't work in FF (or in Opera).

TheWall 0 soluzioni 2 risposte

What's this mean? > Java Plug-in 10.17.2.02 Using JRE version 1.7.0_17-b02 Java HotSpot(TM) Client VM User home directory = C:\Users\Wally


c: clear console window f: finalize objects on finalization queue g: garbage collect h: display this help message l: dump classloader list m: print memory usage o: trigger logging q: hide console r: reload policy configuration s: dump system and deployment properties t: dump thread list v: dump thread stack x: clear classloader cache 0-5: set trace level to <n>


milindpandey 0 soluzioni 2 risposte

I'm having java 6.5 in my system. while opening one site i get error - Install mising plugin. . when i click on install. mozilla unable to find plugin. and while downloading manually the site

http://java.sun.com/products/archive/j2se/6u12/index.html NOT OPENING. pls resolve my issue.....
philipp
  • Top 10 Contributor
  • Moderator
2046 soluzioni 8901 risposte

hello milindpandey, please download java 7 update 21 directly from java.com.

milindpandey 0 soluzioni 2 risposte

hey Philipp, Same problem arises.. after updating to java 7 update 21 again install missing plugin comes. i have jinitiator 1.3.22 installed. In internet explorer 7 and above my oracle ERP App. is working but in mozilla firefox any version its not working. even in safari browser its working. help me out plzz..