Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How do I get the ‘Welcome to Firefox’ page that shows up after an update to quit showing up? It’s been coming up when ever I start up Firefox for days.

  • 7 risposte
  • 12 hanno questo problema
  • 4570 visualizzazioni
  • Ultima risposta di Oldtimer1

more options

The ‘Welcome to Firefox’ page that shows up after an update is installed has been coming up when ever I start up Firefox since I did the last update to 18.0.1, several days ago. How do I get it to stop?

Tutte le risposte (7)

more options

Soluzione scelta

more options

I have started having this problem a few days ago. The solution suggested is that my home page was reset, but that is not the case. My home page comes up as a second tab overlaid by the Welcome to Firefox first tab. How do I get rid of it?

more options

Did you check the home page setting?

Firefox supports multiple home pages separated by '|' symbols.

  • Tools > Options > General > Startup: Home page

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

more options

My home page setting was correct as before and does NOT have a mozilla URL in it. responent cor-el suggested several methods for resetting for resetting all preferences, but the cure is far worse than the disease.

HOWEVER ........ I fixed the problem a different way. Looking at about:config I noticed that the item browser.startup.homepage_override.mstone had the value 19.0.2 (the previous browser version). I edited the prefs.js file to change the value to 20.0 to match the current version of the browser and the problem went away with no other apparent adverse effects. Later I noticed that the prefs value gecko.mstone had the same value 19.0.2 and I corrected it the same way, again with no apparent after-effects.

more options

Can you explain how to do this? I have the same problem as well. Thanks!

more options

The problem turned out to be an error on the prefs.js file where one or two of the parameters with the current version number were not properly updated, so the browser always thought I was opening it for the first time on a new version. I edited the version number in those parameters to agree with the version number in the Help/About dropdown and the problem went away. It has been a while now and I do not recall which were the faulty parameters, but here are the ones in my current prefs.js file that refer to the browser version (currently 21.0 for me):

user_pref("browser.startup.homepage_override.mstone", "21.0");

user_pref("extensions.enabledAddons", "%7Bd40f5e7b-d2cf-4856-b441-cc613eeffbe3%7D:1.68,%7B02450914-cdd9-410f-b1da-db004e18c671%7D:0.97.12c,%7BBBDA0591-3099-440a-AA10-41764D9DB4DB%7D:11.3.0.9%20-%205,%7B2D3F3651-74B9-4795-BDEC-6DA2F431CB62%7D:2013.4.1.2,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:21.0");

user_pref("extensions.lastAppVersion", "21.0");

user_pref("extensions.lastPlatformVersion", "21.0");

user_pref("gecko.mstone", "21.0");

I have not encountered the same problem with recent version upgrades. Good luck!!

more options

P.S. The prefs.js file is located in the C:\Documents and Settings\[user]\Application Data\Mozilla\Firefox\Profiles\hyytidn2.default folder.